summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Gethyn ThomasQuail2015-12-18 07:09:48 +0100
committer Willy Sudiarto Raharjo2015-12-19 01:22:59 +0100
commit4aae39fa23939913bab9527451bd8244b3a5d420 (patch)
treeb8df66848132a73997deda228c26fc86dbf1f097 /network
parentcd0a76abb45734331025bb97dc584756b50b23aa (diff)
downloadslackbuilds-4aae39fa23939913bab9527451bd8244b3a5d420.tar.gz
network/uTox: Added (The lightest and fluffiest Tox client).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/uTox/README1
-rw-r--r--network/uTox/locationfix.diff13
-rw-r--r--network/uTox/slack-desc19
-rw-r--r--network/uTox/uTox.SlackBuild85
-rw-r--r--network/uTox/uTox.info10
5 files changed, 128 insertions, 0 deletions
diff --git a/network/uTox/README b/network/uTox/README
new file mode 100644
index 0000000000..b0ee2ed7a5
--- /dev/null
+++ b/network/uTox/README
@@ -0,0 +1 @@
+Lightweight Tox client that uses Xlib. Supports many features and is on-par with other Tox clients.
diff --git a/network/uTox/locationfix.diff b/network/uTox/locationfix.diff
new file mode 100644
index 0000000000..9c19d44aac
--- /dev/null
+++ b/network/uTox/locationfix.diff
@@ -0,0 +1,13 @@
+--- uTox-0.4.5/Makefile 2015-12-09 16:56:06.000000000 -0700
++++ uTox-0.4.5-fix/Makefile 2015-12-13 06:28:47.453261588 -0700
+@@ -104,8 +104,8 @@
+ install -m 644 utox.desktop $(DESTDIR)$(PREFIX)/share/applications/utox.desktop
+ if [ "$(UNITY)" -eq "1" ]; then echo "X-MessagingMenu-UsesChatSection=true" >> $(DESTDIR)$(PREFIX)/share/applications/utox.desktop; fi
+
+- mkdir -p $(DESTDIR)$(PREFIX)/share/man/man1
+- install -m 644 utox.1 $(DESTDIR)$(PREFIX)/share/man/man1/utox.1
++ mkdir -p $(DESTDIR)$(PREFIX)/man/man1
++ install -m 644 utox.1 $(DESTDIR)$(PREFIX)/man/man1/utox.1
+
+ main.o: xlib/main.c xlib/keysym2ucs.c
+
diff --git a/network/uTox/slack-desc b/network/uTox/slack-desc
new file mode 100644
index 0000000000..53cd9630b2
--- /dev/null
+++ b/network/uTox/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler--------------------------------------------------------|
+uTox: uTox (The lightest and fluffiest Tox client)
+uTox:
+uTox: Lightweight Tox client that uses Xlib. Supports many features and is
+uTox: on-par with other Tox clients.
+uTox:
+uTox: Homepage: https://github.com/GrayHatter/utox
+uTox:
+uTox:
+uTox:
+uTox:
+uTox:
diff --git a/network/uTox/uTox.SlackBuild b/network/uTox/uTox.SlackBuild
new file mode 100644
index 0000000000..3a55332fcc
--- /dev/null
+++ b/network/uTox/uTox.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for uTox
+#
+# Copyright 2015 Gethyn ThomasQuail <gethyn@bloodbathsoftworks.com>
+# All rights reserved.
+#
+# Permission to use, copy, modify, and/or distribute this software for any
+# purpose with or without fee is hereby granted, provided that the above
+# copyright notice and this permission notice appear in all copies.
+#
+# THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+# WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+# ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+# WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+# ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+# OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+
+PRGNAM=uTox
+VERSION=${VERSION:-0.4.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/v$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+patch -p1 < $CWD/locationfix.diff
+
+make
+make DESTDIR=$PKG \
+ PREFIX=/usr \
+ install
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md utox_theme.ini $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/uTox/uTox.info b/network/uTox/uTox.info
new file mode 100644
index 0000000000..da2811bc61
--- /dev/null
+++ b/network/uTox/uTox.info
@@ -0,0 +1,10 @@
+PRGNAM="uTox"
+VERSION="0.4.5"
+HOMEPAGE="https://github.com/GrayHatter/utox"
+DOWNLOAD="https://github.com/GrayHatter/uTox/archive/v0.4.5.tar.gz"
+MD5SUM="be36aeebaf39cb8da927d8cefe3460cb"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="toxcore libfilteraudio"
+MAINTAINER="Gethyn ThomasQuail"
+EMAIL="gethyn@bloodbathsoftworks.com"