summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Niki Kovacs2012-12-27 18:05:01 +0100
committer Matteo Bernardini2012-12-27 18:07:12 +0100
commit7941012fb8d958417582100e82342eafbdeedca6 (patch)
tree11a485faebc9c46975ffbbf8aeb56feae49cfb3c /network
parentc1a8fd49940a63b583b61403d3da5a8eb354b46a (diff)
downloadslackbuilds-7941012fb8d958417582100e82342eafbdeedca6.tar.gz
network/mozilla-firefox-esr: Added (firefox web browser ESR).
(Renamed from mozilla-firefox, noted incompatibility with mozilla-firefox, updated for 17.0.1, removed unnecessary patches, use icons provided with the tarball, cleanups, switched to .mozconfig with support for PGO building --ponce) Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/mozilla-firefox-esr/README22
-rw-r--r--network/mozilla-firefox-esr/doinst.sh9
-rw-r--r--network/mozilla-firefox-esr/mozilla-firefox-esr.SlackBuild211
-rw-r--r--network/mozilla-firefox-esr/mozilla-firefox-esr.info10
-rw-r--r--network/mozilla-firefox-esr/mozilla-firefox.desktop80
-rw-r--r--network/mozilla-firefox-esr/slack-desc19
6 files changed, 351 insertions, 0 deletions
diff --git a/network/mozilla-firefox-esr/README b/network/mozilla-firefox-esr/README
new file mode 100644
index 0000000000..8673f8014e
--- /dev/null
+++ b/network/mozilla-firefox-esr/README
@@ -0,0 +1,22 @@
+Mozilla Firefox ESR (Extended Support Release) is meant for
+organizations that manage their client desktops, including schools,
+businesses and other institutions that want to offer Firefox.
+
+Notes:
+- This package is not compatible/substitutes Slackware's
+ mozilla-firefox package: install only one of the two.
+
+- The package generated from this SlackBuild will be branded
+ like an official Mozilla.org Slackware package, so it cannot
+ be redistributed.
+
+- This script supports PGO building: it will need double the time
+ and disk space to complete but at the end you will have an
+ optimized build of firefox. This will work at its best if
+ run from the same host that will run the final binary, but
+ speed/reactivity will benefit also if run elsewhere.
+ To enable it, launch the script with PGO=yes
+
+- To run this SlackBuild you will need ~4 Gb of free disk space
+ (~8 Gb for a PGO-enabled build) and if you don't want to hit
+ swap during the run you will need 5 Gb of free RAM.
diff --git a/network/mozilla-firefox-esr/doinst.sh b/network/mozilla-firefox-esr/doinst.sh
new file mode 100644
index 0000000000..3e5691a052
--- /dev/null
+++ b/network/mozilla-firefox-esr/doinst.sh
@@ -0,0 +1,9 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/network/mozilla-firefox-esr/mozilla-firefox-esr.SlackBuild b/network/mozilla-firefox-esr/mozilla-firefox-esr.SlackBuild
new file mode 100644
index 0000000000..4aabfd1690
--- /dev/null
+++ b/network/mozilla-firefox-esr/mozilla-firefox-esr.SlackBuild
@@ -0,0 +1,211 @@
+#!/bin/sh
+
+# Copyright 2008, 2009, 2010, 2011, 2012 Patrick J. Volkerding, Sebeka, Minnesota, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# Modified by Niki Kovacs <info@microlinux.fr>
+# Modified by the slackbuilds.org project
+
+PRGNAM=mozilla-firefox-esr
+VERSION=${VERSION:-17.0.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) export ARCH=i486 ;;
+ arm*) export ARCH=arm ;;
+ *) export ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+MOZVERS=${MOZVERS:-esr17}
+RELEASEVER=$(echo $VERSION | cut -f 1 -d r | cut -f 1 -d b)
+
+# Try to be gentle to the compiler, no optimizations:
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "s390" ]; then
+ SLKCFLAGS="-O"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "arm" ]; then
+ SLKCFLAGS="-O2 -march=armv4 -mtune=xscale"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "armel" ]; then
+ SLKCFLAGS="-O2 -march=armv4t"
+ LIBDIRSUFFIX=""
+fi
+
+export PYTHON=$(which python)
+
+# PGO building
+PGO=${PGO:-no}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG/usr/lib$LIBDIRSUFFIX
+
+cd $TMP
+rm -rf mozilla-$MOZVERS
+tar xvf $CWD/firefox-${VERSION}esr.source.tar.?z*
+cd mozilla-$MOZVERS
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Fix a long standing bug that's prevented staying current on GTK+.
+# Thanks to the BLFS folks. :-)
+cat << EOF >> layout/build/Makefile.in
+
+ifdef MOZ_ENABLE_CANVAS
+EXTRA_DSO_LDOPTS += \$(XLDFLAGS) -lX11 -lXrender
+endif
+
+EOF
+
+# Our building options, in a configure-like display
+OPTIONS="\
+ --enable-official-branding \
+ --prefix=/usr \
+ --libdir=/usr/lib$LIBDIRSUFFIX \
+ --with-default-mozilla-five-home=/usr/lib$LIBDIRSUFFIX/firefox-$RELEASEVER \
+ --with-system-zlib \
+ --enable-application=browser \
+ --enable-default-toolkit=cairo-gtk2 \
+ --enable-startup-notification \
+ --enable-crypto \
+ --enable-svg \
+ --enable-canvas \
+ --enable-logging \
+ --enable-xft \
+ --enable-webm \
+ --enable-xinerama \
+ --enable-optimize \
+ --enable-reorder \
+ --enable-strip \
+ --enable-cpp-rtti \
+ --enable-single-profile \
+ --disable-gnomevfs \
+ --disable-ldap \
+ --disable-accessibility \
+ --disable-crashreporter \
+ --disable-debug \
+ --disable-tests \
+ --disable-pedantic \
+ --disable-installer \
+ --disable-mailnews \
+ --disable-composer \
+ --disable-profilesharing"
+# Complains about missing APNG support in Slackware's libpng:
+# --with-system-png \
+# This option breaks mozilla-12.0:
+# --enable-system-cairo \
+
+# Mozilla devs enforce using an objdir for building
+# and launching configure with the absolute path
+# https://developer.mozilla.org/en/Configuring_Build_Options#Building_with_an_objdir
+mkdir obj
+export MOZILLA_OFFICIAL="1"
+export BUILD_OFFICIAL="1"
+export MOZ_PHOENIX="1"
+export CFLAGS="$SLKCFLAGS"
+export CXXFLAGS="$SLKCFLAGS"
+export MOZ_MAKE_FLAGS="$MAKEFLAGS"
+unset DBUS_SESSION_BUS_ADDRESS ORBIT_SOCKETDIR SESSION_MANAGER \
+ XDG_SESSION_COOKIE XAUTHORITY MAKEFLAGS
+
+# Assemble our .mozconfig, we use this method for building, seems
+# needed for PGO.
+echo ". \$topsrcdir/browser/config/mozconfig" > .mozconfig
+echo "mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj" >> .mozconfig
+for option in $OPTIONS; do echo "ac_add_options $option" >> .mozconfig; done
+
+# Thanks to ArchLinux and Gentoo for the hints.
+# We use Xvfb to let the build run his profile tests.
+if [ "$PGO" = "yes" ]; then
+ echo "mk_add_options PROFILE_GEN_SCRIPT='\$(PYTHON) \$(MOZ_OBJDIR)/_profile/pgo/profileserver.py 10'" >> .mozconfig
+ export MOZ_PGO=1
+ export DISPLAY=:99
+ Xvfb -nolisten tcp -extension GLX -screen 0 1280x1024x24 $DISPLAY &
+ dbus-launch --exit-with-session make -f client.mk build
+ kill $! || true
+ make -f client.mk install DESTDIR=$PKG
+else
+ make -f client.mk build
+ make -f client.mk install DESTDIR=$PKG
+fi
+
+# We don't need these (just symlinks anyway):
+rm -rf $PKG/usr/lib$LIBDIRSUFFIX/firefox-devel-$RELEASEVER
+
+# Nor these:
+rm -rf $PKG/usr/include
+
+mkdir -p $PKG/usr/lib$LIBDIRSUFFIX/mozilla/plugins
+mkdir -p $PKG/usr/share/applications
+cat $CWD/mozilla-firefox.desktop > $PKG/usr/share/applications/mozilla-firefox.desktop
+
+# These files/directories are usually created if Firefox is run as root,
+# which on many systems might (and possibly should) be never. Therefore, if we
+# don't see them we'll put stubs in place to prevent startup errors.
+( cd $PKG/usr/lib$LIBDIRSUFFIX/firefox-$RELEASEVER
+ if [ -d extensions/talkback\@mozilla.org ]; then
+ if [ ! -r extensions/talkback\@mozilla.org/chrome.manifest ]; then
+ echo > extensions/talkback\@mozilla.org/chrome.manifest
+ fi
+ fi
+ if [ ! -d updates ]; then
+ mkdir -p updates/0
+ fi
+)
+
+# Need some default icons in the right place:
+for i in 16 22 24 32 48 256; do
+ install -m 0644 -D browser/branding/official/default${i}.png \
+ $PKG/usr/share/icons/hicolor/${i}x${i}/apps/firefox.png
+done
+mkdir -p $PKG/usr/lib$LIBDIRSUFFIX/firefox-$RELEASEVER/chrome/icons/default
+install -m 644 browser/branding/official/default16.png \
+ $PKG/usr/lib$LIBDIRSUFFIX/firefox-$RELEASEVER/icons/
+install -m 644 browser/branding/official/default16.png \
+ $PKG/usr/lib$LIBDIRSUFFIX/firefox-$RELEASEVER/chrome/icons/default/
+
+# Copy over the LICENSE
+install -p -c -m 644 LICENSE $PKG/usr/lib$LIBDIRSUFFIX/firefox-$RELEASEVER/
+
+mkdir $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/mozilla-firefox-esr/mozilla-firefox-esr.info b/network/mozilla-firefox-esr/mozilla-firefox-esr.info
new file mode 100644
index 0000000000..7f78d16800
--- /dev/null
+++ b/network/mozilla-firefox-esr/mozilla-firefox-esr.info
@@ -0,0 +1,10 @@
+PRGNAM="mozilla-firefox-esr"
+VERSION="17.0.1"
+HOMEPAGE="http://www.mozilla.org/en-US/firefox/organizations/"
+DOWNLOAD="https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/17.0.1esr/source/firefox-17.0.1esr.source.tar.bz2"
+MD5SUM="95df7fa6f40e1613658a11889f314e68"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Niki Kovacs"
+EMAIL="info@microlinux.fr"
diff --git a/network/mozilla-firefox-esr/mozilla-firefox.desktop b/network/mozilla-firefox-esr/mozilla-firefox.desktop
new file mode 100644
index 0000000000..23be26f3a8
--- /dev/null
+++ b/network/mozilla-firefox-esr/mozilla-firefox.desktop
@@ -0,0 +1,80 @@
+[Desktop Entry]
+Exec=firefox %u
+Icon=firefox
+Type=Application
+Categories=Network;
+Name=Firefox
+Name[bn]=ফায়ারফক্স
+Name[eo]=Mozilo Fajrovulpo
+Name[fi]=Mozilla Firefox
+Name[pa]=ਫਾਇਰਫੋਕਸ
+Name[tg]=Рӯбоҳи оташин
+GenericName=Web Browser
+GenericName[af]=Web Blaaier
+GenericName[ar]=متصفح ويب
+GenericName[az]=Veb Səyyahı
+GenericName[bg]=Браузър
+GenericName[bn]=ওয়েব ব্রাউজার
+GenericName[br]=Furcher ar Gwiad
+GenericName[bs]=WWW Preglednik
+GenericName[ca]=Fullejador web
+GenericName[cs]=WWW prohlížeč
+GenericName[cy]=Porydd Gwe
+GenericName[da]=Browser
+GenericName[de]=Web-Browser
+GenericName[el]=Περιηγητής Ιστού
+GenericName[eo]=TTT-legilo
+GenericName[es]=Navegador web
+GenericName[et]=Veebilehitseja
+GenericName[eu]=Web arakatzailea
+GenericName[fa]=مرورگر وب
+GenericName[fi]=WWW-selain
+GenericName[fo]=Alnótsfar
+GenericName[fr]=Navigateur web
+GenericName[gl]=Navegador Web
+GenericName[he]=דפדפן אינטרנט
+GenericName[hi]=वेब ब्राउज़र
+GenericName[hr]=Web preglednik
+GenericName[hu]=Webböngésző
+GenericName[is]=Vafri
+GenericName[it]=Browser Web
+GenericName[ja]=ウェブブラウザ
+GenericName[ko]=웹 브라우저
+GenericName[lo]=ເວັບບຣາວເຊີ
+GenericName[lt]=Žiniatinklio naršyklė
+GenericName[lv]=Web Pārlūks
+GenericName[mk]=Прелистувач на Интернет
+GenericName[mn]=Веб-Хөтөч
+GenericName[nb]=Nettleser
+GenericName[nds]=Nettkieker
+GenericName[nl]=Webbrowser
+GenericName[nn]=Nettlesar
+GenericName[nso]=Seinyakisi sa Web
+GenericName[pa]=ਵੈਬ ਝਲਕਾਰਾ
+GenericName[pl]=Przeglądarka WWW
+GenericName[pt]=Navegador Web
+GenericName[pt_BR]=Navegador Web
+GenericName[ro]=Navigator de web
+GenericName[ru]=Веб-браузер
+GenericName[se]=Fierpmádatlogan
+GenericName[sk]=Webový prehliadač
+GenericName[sl]=Spletni brskalnik
+GenericName[sr]=Веб претраживач
+GenericName[sr@Latn]=Veb pretraživač
+GenericName[ss]=Ibrawuza yeWeb
+GenericName[sv]=Webbläsare
+GenericName[ta]=வலை உலாவி
+GenericName[tg]=Тафсиргари вэб
+GenericName[th]=เว็บบราวเซอร์
+GenericName[tr]=Web Tarayıcı
+GenericName[uk]=Навігатор Тенет
+GenericName[uz]=Веб-браузер
+GenericName[ven]=Buronza ya Webu
+GenericName[vi]=Trình duyệt Web
+GenericName[wa]=Betchteu waibe
+GenericName[xh]=Umkhangeli zincwadi we Web
+GenericName[zh_CN]=网页浏览器
+GenericName[zh_TW]=網頁瀏覽器
+GenericName[zu]=Umcingi we-Web
+MimeType=text/html;
+X-KDE-StartupNotify=true
diff --git a/network/mozilla-firefox-esr/slack-desc b/network/mozilla-firefox-esr/slack-desc
new file mode 100644
index 0000000000..db3a493d97
--- /dev/null
+++ b/network/mozilla-firefox-esr/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+mozilla-firefox-esr: mozilla-firefox-esr (Mozilla Firefox Web browser ESR)
+mozilla-firefox-esr:
+mozilla-firefox-esr: Mozilla Firefox ESR (Extended Support Release) is meant for
+mozilla-firefox-esr: organizations that manage their client desktops, including schools,
+mozilla-firefox-esr: businesses and other institutions that want to offer Firefox.
+mozilla-firefox-esr:
+mozilla-firefox-esr: Note that this package cannot be redistributed.
+mozilla-firefox-esr:
+mozilla-firefox-esr: Visit the Mozilla Firefox Extended Support Release page online:
+mozilla-firefox-esr: http://www.mozilla.org/en-US/firefox/organizations/
+mozilla-firefox-esr: