summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author markus reichelt2012-04-16 04:27:48 +0200
committer Erik Hanson2012-04-16 12:36:00 +0200
commitb4a5985ebe06ea82111246b8716b59d9421bc1f8 (patch)
tree280dea881c085d6d6c8a6545579ced1fe2095780 /network
parent57337b79ff5ecc14a6ae130df2b1467d88af303f (diff)
downloadslackbuilds-b4a5985ebe06ea82111246b8716b59d9421bc1f8.tar.gz
network/allmydata-tahoe: Updated for version 1.9.1 new maintainer.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/allmydata-tahoe/README12
-rw-r--r--network/allmydata-tahoe/allmydata-tahoe.SlackBuild36
-rw-r--r--network/allmydata-tahoe/allmydata-tahoe.info12
-rw-r--r--network/allmydata-tahoe/introducer.furl1
-rw-r--r--network/allmydata-tahoe/slack-desc2
5 files changed, 36 insertions, 27 deletions
diff --git a/network/allmydata-tahoe/README b/network/allmydata-tahoe/README
index 31b2e73c7a..a065e8758c 100644
--- a/network/allmydata-tahoe/README
+++ b/network/allmydata-tahoe/README
@@ -5,10 +5,10 @@ remains available even when some of the peers are unavailable, malfunctioning,
or malicious.
Build in the listed order, all are available from SlackBuilds.org.
-pysetuptools, darcsver, argparse, simplejson, pyOpenSSL, zope.interface,
-python-twisted, Nevow, foolscap, pyutil, zbase32, zfec, cryptopp,
-pycryptopp.
+mock, pyasn1, pycrypto, pysetuptools, darcsver, argparse, simplejson,
+pyOpenSSL, zope.interface, python-twisted, Nevow, foolscap, pyutil,
+zbase32, zfec, cryptopp, pycryptopp.
-This package will also ship the introducer.furl file to be able to join the
-public test grid. For more informations see running.html and using.html in the
-doc folder.
+Numpy is optional at runtime.
+
+For more information see running.rst in the docs folder.
diff --git a/network/allmydata-tahoe/allmydata-tahoe.SlackBuild b/network/allmydata-tahoe/allmydata-tahoe.SlackBuild
index eaffe1d191..20828091b0 100644
--- a/network/allmydata-tahoe/allmydata-tahoe.SlackBuild
+++ b/network/allmydata-tahoe/allmydata-tahoe.SlackBuild
@@ -3,6 +3,7 @@
# Slackware build script for allmydata-tahoe.
# Copyright 2009 Marco Bonetti <sid77@slackware.it>
+# Copyright 2011,2012 Markus Reichelt, Aachen, DE
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -21,18 +22,21 @@
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# Originally written by Marco Bonetti - Thanks!
+# Now maintained by Markus Reichelt <slackbuilds@mareichelt.de>, 0xCCEEF115
+# 2011 Nov 01 - adapted to Tahoe-LAFS 1.9.0
+# 2012 Jan 12 - adapted to Tahoe-LAFS 1.9.1
PRGNAM=allmydata-tahoe
-VERSION=${VERSION:-1.6.1}
+VERSION=${VERSION:-1.9.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -42,14 +46,18 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-DOCS="COPYING.GPL COPYING.TGPPL.html README docs"
-
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
fi
set -e
@@ -67,19 +75,21 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py build || exit 1
-python setup.py install --root=$PKG || exit 1
+python setup.py install --root=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-# ship the introducer furl to join the public test grid
-cat $CWD/introducer.furl > $PKG/usr/doc/$PRGNAM-$VERSION/introducer.furl
-cat $CWD/slack-desc > $PKG/usr/doc/$PRGNAM-$VERSION/slack-desc
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION $PKG/usr/man/man1
+cp -a \
+ COPYING.* README.txt docs \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+mv $PKG/usr/doc/$PRGNAM-$VERSION/docs/man/tahoe.1 $PKG/usr/man/man1
+gzip -9 $PKG/usr/man/man1/tahoe.1
+rmdir $PKG/usr/doc/$PRGNAM-$VERSION/docs/man/
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/network/allmydata-tahoe/allmydata-tahoe.info b/network/allmydata-tahoe/allmydata-tahoe.info
index 0c8570be94..0c76edf692 100644
--- a/network/allmydata-tahoe/allmydata-tahoe.info
+++ b/network/allmydata-tahoe/allmydata-tahoe.info
@@ -1,10 +1,10 @@
PRGNAM="allmydata-tahoe"
-VERSION="1.6.1"
-HOMEPAGE="http://allmydata.org/"
-DOWNLOAD="http://tahoe-lafs.org/source/tahoe-lafs/releases/allmydata-tahoe-1.6.1.tar.bz2"
-MD5SUM="a7009767a9ef77ee42941a87bd0ac2cc"
+VERSION="1.9.1"
+HOMEPAGE="https://tahoe-lafs.org/"
+DOWNLOAD="https://tahoe-lafs.org/source/tahoe-lafs/releases/allmydata-tahoe-1.9.1.tar.bz2"
+MD5SUM="20d88c5b9e40b04fc7a032258fe7c55f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-MAINTAINER="Marco Bonetti"
-EMAIL="sid77@slackware.it"
+MAINTAINER="markus reichelt"
+EMAIL="slackbuilds@mareichelt.de"
APPROVED="dsomero"
diff --git a/network/allmydata-tahoe/introducer.furl b/network/allmydata-tahoe/introducer.furl
deleted file mode 100644
index 89fd66e838..0000000000
--- a/network/allmydata-tahoe/introducer.furl
+++ /dev/null
@@ -1 +0,0 @@
-pb://todjw7qkb4dgq4fkeo7cqydcu5vneioh@tahoecs2.allmydata.com:52106/introducer
diff --git a/network/allmydata-tahoe/slack-desc b/network/allmydata-tahoe/slack-desc
index 7d69d06283..9c3c2f451a 100644
--- a/network/allmydata-tahoe/slack-desc
+++ b/network/allmydata-tahoe/slack-desc
@@ -13,7 +13,7 @@ allmydata-tahoe: is encrypted and spread over multiple peers in such a way that
allmydata-tahoe: remains available even when some of the peers are unavailable,
allmydata-tahoe: malfunctioning, or malicious.
allmydata-tahoe:
-allmydata-tahoe: Homepage: http://allmydata.org/
+allmydata-tahoe: Homepage: https://tahoe-lafs.org/
allmydata-tahoe:
allmydata-tahoe:
allmydata-tahoe: