summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Larry Hajali2010-09-11 23:13:02 +0200
committer Robby Workman2010-09-13 06:08:52 +0200
commitd763644dfbcf959f5cce4eae8d9b8c8bc5f3ee63 (patch)
tree2e8cdc3e1b38249b0ea23aeb75ac5a59ae2df257 /network
parentff249ef8ec5ed43bc9303194c3feb07092a2478c (diff)
downloadslackbuilds-d763644dfbcf959f5cce4eae8d9b8c8bc5f3ee63.tar.gz
network/qwit: Updated for version 1.1_pre2.
Since Twitter disabled one the auth styles in favor of oauth, we have to update the clients (as needed) to support oauth. Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/qwit/README2
-rw-r--r--network/qwit/doinst.sh1
-rw-r--r--network/qwit/qwit.SlackBuild42
-rw-r--r--network/qwit/qwit.info6
4 files changed, 32 insertions, 19 deletions
diff --git a/network/qwit/README b/network/qwit/README
index 840d96d693..f6a819cf11 100644
--- a/network/qwit/README
+++ b/network/qwit/README
@@ -1 +1,3 @@
Qwit - free cross-platform Qt4-based Twitter client.
+
+Qwit requires qoauth.
diff --git a/network/qwit/doinst.sh b/network/qwit/doinst.sh
index 4e8ba7071d..5fb28930db 100644
--- a/network/qwit/doinst.sh
+++ b/network/qwit/doinst.sh
@@ -1,4 +1,3 @@
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
-
diff --git a/network/qwit/qwit.SlackBuild b/network/qwit/qwit.SlackBuild
index ee434fbc53..917a8bfe20 100644
--- a/network/qwit/qwit.SlackBuild
+++ b/network/qwit/qwit.SlackBuild
@@ -5,16 +5,14 @@
# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
PRGNAM=qwit
-VERSION=${VERSION:-0.10}
+VERSION=1.1_pre2
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -26,10 +24,16 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
fi
set -e
@@ -37,9 +41,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION-src
-tar xvf $CWD/$PRGNAM-$VERSION-src.tar.bz2
-cd $PRGNAM-$VERSION-src
+rm -rf $PRGNAM-${VERSION/_/-}-src
+tar xvf $CWD/$PRGNAM-${VERSION/_/-}-src.tar.bz2
+cd $PRGNAM-${VERSION/_/-}-src
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -47,21 +51,29 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Fix .desktop and CMakeLists.txt.
+sed -i '/^Categories/s|Internet||' $PRGNAM.desktop
echo "StartupNotify=false" >> $PRGNAM.desktop
+sed -i \
+ -e 's|\${QT_BINARY_DIR}|bin|' -e 's|/qca2||' \
+ -e 's|/icons|/pixmaps|' CMakeLists.txt
-qmake -unix PREFIX=/usr -o Makefile $PRGNAM.pro
-make \
- CFLAGS="-pipe $SLKCFLAGS -g -Wall -W -D_REENTRANT \$(DEFINES)" \
- CXXFLAGS="-pipe $SLKCFLAGS -g -Wall -W -D_REENTRANT \$(DEFINES)"
-make install INSTALL_ROOT=$PKG
+mkdir build
+cd build
+ cmake -G "Unix Makefiles" \
+ -DCMAKE_INSTALL_PREFIX:PATH="/usr" \
+ -DLIB_SUFFIX="$LIBDIRSUFFIX" \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_BUILD_TYPE=Release ..
+
+ make VERBOSE=1
+ make install DESTDIR=$PKG
+cd ..
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-mkdir -p $PKG/usr/share/pixmaps
-install -m 0644 images/$PRGNAM.png $PKG/usr/share/pixmaps/
-rm -rf $PKG/usr/share/icons
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
AUTHORS COPYING INSTALL README \
diff --git a/network/qwit/qwit.info b/network/qwit/qwit.info
index 02d52bb98b..fc3062ed1f 100644
--- a/network/qwit/qwit.info
+++ b/network/qwit/qwit.info
@@ -1,8 +1,8 @@
PRGNAM="qwit"
-VERSION="0.10"
+VERSION="1.1_pre2"
HOMEPAGE="http://code.google.com/p/qwit/"
-DOWNLOAD="http://qwit.googlecode.com/files/qwit-0.10-src.tar.bz2"
-MD5SUM="b94e0819f3aa8747acc1cf57e7b372ab"
+DOWNLOAD="http://qwit.googlecode.com/files/qwit-1.1-pre2-src.tar.bz2"
+MD5SUM="e8775236e5a8a83937bdf009193b7618"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="Larry Hajali"