summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author Lionel Young2010-12-19 04:03:00 +0100
committer Robby Workman2010-12-21 05:44:03 +0100
commit2ffb8f82518fc3bd6ac6a4edfa81fa429b4577de (patch)
tree4b4142bbd0f790fd93d72be32655325cd0da8d61 /network
parent3564bd44f41820a5ed600fedf2cb273547bfd050 (diff)
downloadslackbuilds-2ffb8f82518fc3bd6ac6a4edfa81fa429b4577de.tar.gz
network/flexget: Added (multipurpose content downloader)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/flexget/README11
-rw-r--r--network/flexget/flexget.SlackBuild56
-rw-r--r--network/flexget/flexget.info10
-rw-r--r--network/flexget/slack-desc19
4 files changed, 96 insertions, 0 deletions
diff --git a/network/flexget/README b/network/flexget/README
new file mode 100644
index 0000000000..f9e7591196
--- /dev/null
+++ b/network/flexget/README
@@ -0,0 +1,11 @@
+FlexGet is a multipurpose automation tool for content like torrents,
+nzbs, podcasts, comics, etc. FlexGet is able to handle different kinds
+of sources like RSS-feeds, html pages and csv files. There are even some
+plugins for sites that do not provide any kind of useful feeds.
+
+FlexGet is extremely useful in conjunction with applications which have
+watch directory support, such as rtorrent.
+
+Requires: pysetuptools, FeedParser, SQLAlchemy, PyYAML, BeautifulSoup,
+html5lib, PyRSS2Gen, pynzb, progressbar
+
diff --git a/network/flexget/flexget.SlackBuild b/network/flexget/flexget.SlackBuild
new file mode 100644
index 0000000000..e7181ebc76
--- /dev/null
+++ b/network/flexget/flexget.SlackBuild
@@ -0,0 +1,56 @@
+#!/bin/sh
+# Generated by Alien's SlackBuild Toolkit: http://slackware.com/~alien/AST
+# Copyright 2009-2010 Eric Hameleers, Eindhoven, Netherlands
+# Slackware build script for flexget
+# Written by Lionel Young <redtricycle@gmail.com>
+# Based on http://slackbuilds.org/template.SlackBuild
+
+PRGNAM=flexget
+VERSION=${VERSION:-1.0r1656}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+TARNAM=FlexGet # their tarball is capitalized
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) export ARCH=i486 ;;
+ arm*) export ARCH=arm ;;
+ *) export ARCH=$( uname -m ) ;;
+ esac
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$TARNAM-$VERSION.tar.gz
+cd $TARNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py build || exit 1
+python setup.py install --root=$PKG || exit 1
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README LICENSE PKG-INFO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/flexget/flexget.info b/network/flexget/flexget.info
new file mode 100644
index 0000000000..921ef5a8d2
--- /dev/null
+++ b/network/flexget/flexget.info
@@ -0,0 +1,10 @@
+PRGNAM="flexget"
+VERSION="1.0r1656"
+HOMEPAGE="http://flexget.com/"
+DOWNLOAD="http://download.flexget.com/unstable/FlexGet-1.0r1656.tar.gz"
+MD5SUM="f2ae7eb7f457fb44c1eb752c61caa6ad"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Lionel Young"
+EMAIL="redtricycle@gmail.com"
+APPROVED="Niels Horn"
diff --git a/network/flexget/slack-desc b/network/flexget/slack-desc
new file mode 100644
index 0000000000..30cd0e10dc
--- /dev/null
+++ b/network/flexget/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+flexget: flexget (multipurpose content downloader)
+flexget:
+flexget: FlexGet is a multipurpose automation tool for content like torrents,
+flexget: nzbs, podcasts, comics, etc. FlexGet is able to handle different
+flexget: kinds of sources like RSS-feeds, html pages and csv files.
+flexget:
+flexget: FlexGet is extremely useful in conjunction with applications which
+flexget: have watch directory support, such as rtorrent.
+flexget:
+flexget: Home: http://flexget.com/
+flexget: