summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author David Woodfall2010-10-25 04:22:23 +0200
committer Erik Hanson2010-10-25 14:55:11 +0200
commit563c4b4b0303abb7ab926a94a1e4229035fc9630 (patch)
tree2390d2c4abefb582a8327136b511e3080c6a8b32 /network
parent1de860d3da499a5dbdd27d6d2d953a0bb5e72385 (diff)
downloadslackbuilds-563c4b4b0303abb7ab926a94a1e4229035fc9630.tar.gz
network/python-stomper: Added (client for the STOMP protocol)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/python-stomper/README6
-rw-r--r--network/python-stomper/python-stomper.SlackBuild87
-rw-r--r--network/python-stomper/python-stomper.info10
-rw-r--r--network/python-stomper/slack-desc20
4 files changed, 123 insertions, 0 deletions
diff --git a/network/python-stomper/README b/network/python-stomper/README
new file mode 100644
index 0000000000..95596ac86e
--- /dev/null
+++ b/network/python-stomper/README
@@ -0,0 +1,6 @@
+This is a python client implementation of the STOMP protocol.
+
+The client is attempting to be transport layer neutral. This module
+provides functions to create and parse STOMP messages in a
+programatic fashion. The messages can be easily generated and parsed,
+however its up to the user to do the sending and receiving.
diff --git a/network/python-stomper/python-stomper.SlackBuild b/network/python-stomper/python-stomper.SlackBuild
new file mode 100644
index 0000000000..ee28ec7082
--- /dev/null
+++ b/network/python-stomper/python-stomper.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for python-stomper
+# Copyright 2010 David Woodfall <dave@dawoodfall.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+SRCNAM=stomper
+PRGNAM=python-$SRCNAM
+VERSION=${VERSION:-0.2.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/python-stomper/python-stomper.info b/network/python-stomper/python-stomper.info
new file mode 100644
index 0000000000..72792aff40
--- /dev/null
+++ b/network/python-stomper/python-stomper.info
@@ -0,0 +1,10 @@
+PRGNAM="python-stomper"
+VERSION="0.2.3"
+HOMEPAGE="http://code.google.com/p/stomper/"
+DOWNLOAD="http://stomper.googlecode.com/files/stomper-0.2.3.tar.gz"
+MD5SUM="4f64beb3823455d46544c5f10922362a"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="David Woodfall"
+EMAIL="dave@dawoodfall.net"
+APPROVED="dsomero"
diff --git a/network/python-stomper/slack-desc b/network/python-stomper/slack-desc
new file mode 100644
index 0000000000..3b1b9cd0b2
--- /dev/null
+++ b/network/python-stomper/slack-desc
@@ -0,0 +1,20 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+python-stomper: python-stomper ( client implementation of the STOMP protocol )
+python-stomper:
+python-stomper: This is a python client implementation of the STOMP protocol.
+python-stomper:
+python-stomper: Homepage: http://code.google.com/p/stomper/
+python-stomper:
+python-stomper:
+python-stomper:
+python-stomper:
+python-stomper:
+python-stomper:
+