summaryrefslogtreecommitdiffstats
path: root/network
diff options
context:
space:
mode:
author David Woodfall2010-10-25 04:21:42 +0200
committer Erik Hanson2010-10-25 14:55:11 +0200
commit1de860d3da499a5dbdd27d6d2d953a0bb5e72385 (patch)
treeb01f89fc9e071a2286e1d2f8199719ddf0e1b6b0 /network
parent4a18247104850693691aa7df16d5daf285d8ddbc (diff)
downloadslackbuilds-1de860d3da499a5dbdd27d6d2d953a0bb5e72385.tar.gz
network/python-orbited: Added (RT Communication for the Browser)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'network')
-rw-r--r--network/python-orbited/README19
-rw-r--r--network/python-orbited/python-orbited.SlackBuild84
-rw-r--r--network/python-orbited/python-orbited.info10
-rw-r--r--network/python-orbited/slack-desc19
4 files changed, 132 insertions, 0 deletions
diff --git a/network/python-orbited/README b/network/python-orbited/README
new file mode 100644
index 0000000000..84710be1a9
--- /dev/null
+++ b/network/python-orbited/README
@@ -0,0 +1,19 @@
+Orbited provides a pure JavaScript/HTML socket in the browser. It is
+a web router and firewall that allows you to integrate web
+applications with arbitrary back-end systems. You can implement any
+network protocol in the browser—without resorting to plugins.
+
+The following dependencies are needed at compile-timee:
+
+pysetuptools
+
+The following dependencies are need at runtime:
+
+python-demjson
+python-morbid
+python-stomper
+python-uuid
+python-twisted
+
+Build scripts for all these are available at Slackbuilds.org
+
diff --git a/network/python-orbited/python-orbited.SlackBuild b/network/python-orbited/python-orbited.SlackBuild
new file mode 100644
index 0000000000..e9c87d15ea
--- /dev/null
+++ b/network/python-orbited/python-orbited.SlackBuild
@@ -0,0 +1,84 @@
+#!/bin/sh
+
+# Slackware build script for python-orbited
+# Copyright 2010 David Woodfall <dave@dawoodfall.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+SRCNAM=orbited
+PRGNAM=python-$SRCNAM
+VERSION=${VERSION:-0.7.10}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/python-orbited/python-orbited.info b/network/python-orbited/python-orbited.info
new file mode 100644
index 0000000000..3d12243e65
--- /dev/null
+++ b/network/python-orbited/python-orbited.info
@@ -0,0 +1,10 @@
+PRGNAM="python-orbited"
+VERSION="0.7.10"
+HOMEPAGE="http://orbited.org/"
+DOWNLOAD="http://pypi.python.org/packages/source/o/orbited/orbited-0.7.10.tar.gz"
+MD5SUM="4f4e85d197466c141b1af466782445c1"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="David Woodfall"
+EMAIL="dave@dawoodfall.net"
+APPROVED="dsomero"
diff --git a/network/python-orbited/slack-desc b/network/python-orbited/slack-desc
new file mode 100644
index 0000000000..5b6372b065
--- /dev/null
+++ b/network/python-orbited/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+python-orbited: python-orbited ( Realtime Communication for the Browser )
+python-orbited:
+python-orbited: Orbited provides a pure JavaScript/HTML socket in the browser. It is
+python-orbited: a web router and firewall that allows you to integrate web
+python-orbited: applications with arbitrary back-end systems. You can implement any
+python-orbited: network protocol in the browser—without resorting to plugins.
+python-orbited:
+python-orbited: Homepage: http://orbited.org/
+python-orbited:
+python-orbited:
+python-orbited: