summaryrefslogtreecommitdiffstats
path: root/network/unicornscan/patches
diff options
context:
space:
mode:
author Robert E. Lee2013-01-05 20:23:11 +0100
committer dsomero2013-01-10 00:52:22 +0100
commit5fd657a3af7bd78f3573e05a5da82db71144f7db (patch)
tree70df89d65c1bc74ccbbe5c4f3bc6384b7e601fe5 /network/unicornscan/patches
parentfdb29e78157187d8bd031eb170107985bb076d08 (diff)
downloadslackbuilds-5fd657a3af7bd78f3573e05a5da82db71144f7db.tar.gz
network/unicornscan: Added (flexible and efficient network probing).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'network/unicornscan/patches')
-rw-r--r--network/unicornscan/patches/unicornscan-0.4.7-config.patch56
-rw-r--r--network/unicornscan/patches/unicornscan-0.4.7-geoip.patch31
-rw-r--r--network/unicornscan/patches/unicornscan-0.4.7-lib64.patch47
-rw-r--r--network/unicornscan/patches/unicornscan-0.4.7-man.patch29
4 files changed, 163 insertions, 0 deletions
diff --git a/network/unicornscan/patches/unicornscan-0.4.7-config.patch b/network/unicornscan/patches/unicornscan-0.4.7-config.patch
new file mode 100644
index 0000000000..dd97d0f09e
--- /dev/null
+++ b/network/unicornscan/patches/unicornscan-0.4.7-config.patch
@@ -0,0 +1,56 @@
+--- unicornscan-0.4.7/etc/modules.conf 2006-10-18 18:57:05.000000000 +0200
++++ unicornscan-0.4.7/etc/modules.conf.config 2009-12-05 20:34:31.000000000 +0100
+@@ -1,16 +1,9 @@
+
+ module "pgsqldb" {
+- dbconf: "user=scan password=scanit! host=localhost dbname=scan";
++ dbconf: "user=unicornscan password=scanit! host=localhost dbname=unicornscan";
+ logpacket: "true";
+ };
+
+-module "mysqldb" {
+- username: "scan";
+- password: "scanit!";
+- hostname: "localhost";
+- dbname: "foo";
+-};
+-
+ module "osdetect" {
+ /* Stim TCPFLG TTL DF WS TOS Misc */
+ /* tcpopts type desc */
+--- unicornscan-0.4.7/www-front-end/config.php 2007-11-27 11:23:35.000000000 +0100
++++ unicornscan-0.4.7/www-front-end/config.php.config 2009-12-05 20:35:13.000000000 +0100
+@@ -4,16 +4,16 @@
+ define("config_master_include", 1);
+
+ // Web Server location stuff
+- $PHPLIB["uri_base"]="http://localhost/unicornscan/"; // http://vhost.domain.tld/something/
++ $PHPLIB["uri_base"]="/unicornscan/"; // http://vhost.domain.tld/something/
+
+- $PHPLIB["filesystem_base"]="/var/www/htdocs/unicornscan/"; // Base directory content is in
+- $PHPLIB["filesystem_phplib"]="/var/www/htdocs/unicornscan/lib/"; // Where phplib is
+- $PHPLIB["filesystem_temporary"]="/tmp/"; // Where can i write files to?
++ $PHPLIB["filesystem_base"]="/var/www/htdocs/unicornscan/"; // Base directory content is in
++ $PHPLIB["filesystem_phplib"]="/var/www/htdocs/unicornscan/lib/";// Where phplib is
++ $PHPLIB["filesystem_temporary"]="/tmp/"; // Where can i write files to?
+
+ // DataBase Variables
+- $PHPLIB["database_name"]="scan"; // change this for sure , its the database name
+- $PHPLIB["database_type"]="pgsql"; // pgsql, mysql, youll need the right class though
+- $PHPLIB["database_username"]="scan";
++ $PHPLIB["database_name"]="unicornscan"; // change this for sure , its the database name
++ $PHPLIB["database_type"]="pgsql"; // and something else isn't supported right now
++ $PHPLIB["database_username"]="unicornscan";
+ $PHPLIB["database_password"]="scanit!";
+ $PHPLIB["database_host"]="127.0.0.1";
+ $PHPLIB["database_db"]["default"]="";
+@@ -24,6 +24,9 @@
+ // formclass2.php stuff
+ $PHPLIB["formclass_warnimage"]="exl.gif"; // warning image for invalid forms
+
++ // No PHP error reporting
++ error_reporting(0);
++
+ } // Double Inclusion detection
+
+ require("./lib/connect_todb.php");
diff --git a/network/unicornscan/patches/unicornscan-0.4.7-geoip.patch b/network/unicornscan/patches/unicornscan-0.4.7-geoip.patch
new file mode 100644
index 0000000000..2ba6941f6a
--- /dev/null
+++ b/network/unicornscan/patches/unicornscan-0.4.7-geoip.patch
@@ -0,0 +1,31 @@
+Patch by Robert Scheck <robert@fedoraproject.org> for unicornscan >= 0.4.7, which adds the
+standard location of GeoIP data at Fedora in front of the original opening try. Unicornscan
+upstream is expecting /etc/unicornscan/GeoIP.dat instead of /usr/share/GeoIP/GeoIP.dat by
+default. This patch is looking for the existence of /usr/share/GeoIP/GeoIP.dat, otherwise
+/etc/unicornscan/GeoIP.dat will be used to not break the standards from upstream, if patch
+gets applied for a future unicornscan release.
+
+--- unicornscan-0.4.7/src/scan_progs/report.c 2006-10-18 18:57:05.000000000 +0200
++++ unicornscan-0.4.7/src/scan_progs/report.c.geoip 2009-11-17 13:16:04.000000000 +0100
+@@ -68,9 +68,18 @@
+ report_t=rbinit(123);
+
+ #ifdef HAVE_LIBGEOIP
+- gi=GeoIP_open(CONF_DIR "/GeoIP.dat", GEOIP_MEMORY_CACHE);
+- if (gi == NULL) {
+- ERR("error opening geoip database `%s/%s': %s", CONF_DIR, "/GeoIP.dat", strerror(errno));
++
++ if (access("/usr/share/GeoIP/GeoIP.dat", F_OK) == 0) {
++ gi=GeoIP_open("/usr/share/GeoIP/GeoIP.dat", GEOIP_MEMORY_CACHE);
++ if (gi == NULL) {
++ ERR("error opening geoip standard database `/usr/share/GeoIP/GeoIP.dat': %s", strerror(errno));
++ }
++ }
++ else {
++ gi=GeoIP_open(CONF_DIR "/GeoIP.dat", GEOIP_MEMORY_CACHE);
++ if (gi == NULL) {
++ ERR("error opening geoip database `%s/%s': %s", CONF_DIR, "/GeoIP.dat", strerror(errno));
++ }
+ }
+
+ #endif
diff --git a/network/unicornscan/patches/unicornscan-0.4.7-lib64.patch b/network/unicornscan/patches/unicornscan-0.4.7-lib64.patch
new file mode 100644
index 0000000000..bbfaa37adf
--- /dev/null
+++ b/network/unicornscan/patches/unicornscan-0.4.7-lib64.patch
@@ -0,0 +1,47 @@
+Patch by Robert Scheck <robert@fedoraproject.org> for unicornscan >= 0.4.7, which
+adds support for x86_64, ppc64 or other 64 bit architectures using /usr/lib64 for
+their libraries. Having lib64 in front of lib is mandatory, as 64 bit systems are
+likely to run with multi-lib, that means 32 bit libraries are parallel in use. If
+you apply this patch, don't run autoconf > 2.6.3, as it will break, because whole
+autotools stuff from upstream is unfortunately a bit broken.
+
+--- unicornscan-0.4.7/configure.ac 2007-11-29 15:51:20.000000000 +0100
++++ unicornscan-0.4.7/configure.ac.lib64 2009-11-16 23:32:27.000000000 +0100
+@@ -269,7 +269,7 @@
+ AC_MSG_RESULT(no)
+ fi
+ else
+- for i in lib lib/mysql; do
++ for i in lib64 lib lib64/mysql lib/mysql; do
+ str="$MYSQL_DIR/$i/libmysqlclient.*"
+ for j in `echo $str`; do
+ if test -r $j; then
+@@ -331,7 +331,7 @@
+ AC_MSG_RESULT(no)
+ fi
+ else
+- for i in lib lib/postgresql; do
++ for i in lib64 lib lib64/postgresql lib/postgresql; do
+ str="$PGSQL_DIR/$i/libpq.*"
+ for j in `echo $str`; do
+ if test -r $j; then
+--- unicornscan-0.4.7/configure 2007-12-18 16:26:12.000000000 +0100
++++ unicornscan-0.4.7/configure.lib64 2009-12-05 12:04:32.000000000 +0100
+@@ -26275,7 +26275,7 @@
+ echo "${ECHO_T}no" >&6; }
+ fi
+ else
+- for i in lib lib/mysql; do
++ for i in lib64 lib lib64/mysql lib/mysql; do
+ str="$MYSQL_DIR/$i/libmysqlclient.*"
+ for j in `echo $str`; do
+ if test -r $j; then
+@@ -26438,7 +26438,7 @@
+ echo "${ECHO_T}no" >&6; }
+ fi
+ else
+- for i in lib lib/postgresql; do
++ for i in lib64 lib lib64/postgresql lib/postgresql; do
+ str="$PGSQL_DIR/$i/libpq.*"
+ for j in `echo $str`; do
+ if test -r $j; then
diff --git a/network/unicornscan/patches/unicornscan-0.4.7-man.patch b/network/unicornscan/patches/unicornscan-0.4.7-man.patch
new file mode 100644
index 0000000000..02793ae40a
--- /dev/null
+++ b/network/unicornscan/patches/unicornscan-0.4.7-man.patch
@@ -0,0 +1,29 @@
+*** unicornscan-0.4.7/docs/unicornscan.1.orig 2006-10-18 09:57:05.000000000 -0700
+--- unicornscan-0.4.7/docs/unicornscan.1 2013-01-04 07:33:46.281014368 -0700
+***************
+*** 10,21 ****
+
+ .fi
+ ..
+! .TH "UNICORNSCAN" "1" "03/30/05" "Network Tools " "Network Tools "
+ .SH NAME
+
+ .PP
+ unicornscan
+! Version 0.4.6b is a asynchronous network stimulus delivery/response recoring
+ tool.
+ .PP
+ .SH SYNOPSIS
+--- 10,21 ----
+
+ .fi
+ ..
+! .TH "UNICORNSCAN" "1" "01/05/13" "Network Tools " "Network Tools "
+ .SH NAME
+
+ .PP
+ unicornscan
+! Version 0.4.7 is a asynchronous network stimulus delivery/response recoring
+ tool.
+ .PP
+ .SH SYNOPSIS