summaryrefslogtreecommitdiffstats
path: root/network/ufw
diff options
context:
space:
mode:
author Robby Workman2011-03-14 22:15:25 +0100
committer Robby Workman2011-03-14 22:15:25 +0100
commita7ea463fff1c1d11c4d6596bfa7b56f96c78dc95 (patch)
tree945d1cd80648af3932ba9bcf61ff2ceabc306adc /network/ufw
parent780c6943a41428ff6ff0a10dcb2df62d03c5056f (diff)
downloadslackbuilds-a7ea463fff1c1d11c4d6596bfa7b56f96c78dc95.tar.gz
network/ufw: Removed (unmaintained)
Reference: http://lists.slackbuilds.org/pipermail/slackbuilds-users/2010-November/006660.html Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org> Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'network/ufw')
-rw-r--r--network/ufw/README28
-rw-r--r--network/ufw/slack-desc20
-rw-r--r--network/ufw/ufw.SlackBuild63
-rw-r--r--network/ufw/ufw.info10
4 files changed, 0 insertions, 121 deletions
diff --git a/network/ufw/README b/network/ufw/README
deleted file mode 100644
index 2b700eefe6..0000000000
--- a/network/ufw/README
+++ /dev/null
@@ -1,28 +0,0 @@
-Ufw (Uncomplicated Firewall) is program for managing a netfilter firewall.
-It provides a command line interface and aims to be uncomplicated and easy
-to use. It is not intended to provide a complete firewall functionality via
-its command interface, but provides an easy way to add or remove simple rules.
-
-To run ufw at boot you can add the following code to rc.local file:
-
-if [ -x /etc/init.d/ufw ]; then
-/etc/init.d/ufw start
-fi
-
-Rules can be added with ports, services or application names. To specify an
-application you need a profile stored under /etc/ufw/applications.d directory.
-
-To add a profile create a app_name.INI file as the following:
-
-[Samba]
-title=File/printer server for Unix
-description=Samba is a collection of programs that implements the SMB/CIFS protocol for unix systems.
-ports=137,138/udp|139,445/tcp
-
-Then, for example you can run:
-ufw allow from xx.xx.xx.xx app samba
-
-
-
-
-
diff --git a/network/ufw/slack-desc b/network/ufw/slack-desc
deleted file mode 100644
index b87f40b44c..0000000000
--- a/network/ufw/slack-desc
+++ /dev/null
@@ -1,20 +0,0 @@
-IT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|' on
-# the right side marks the last column you can put a character in. You must make
-# exactly 11 lines for the formatting to be correct. It's also customary to
-# leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-ufw: ufw (Uncomplicated Firewall)
-ufw:
-ufw: Ufw is a program for managing a netfilter firewall. It provide a
-ufw: command line interface and aims to be uncomplicated and easy to use.
-ufw:
-ufw: Homepage: https://launchpad.net/ufw
-ufw:
-ufw:
-ufw:
-ufw:
-ufw:
-
diff --git a/network/ufw/ufw.SlackBuild b/network/ufw/ufw.SlackBuild
deleted file mode 100644
index f6961f6af6..0000000000
--- a/network/ufw/ufw.SlackBuild
+++ /dev/null
@@ -1,63 +0,0 @@
-#!/bin/sh
-# Slackware build script for ufw
-# Written by Marco Cecchetti (mrc.ildp@gmail.com)
-
-PRGNAM=ufw
-VERSION=${VERSION:-0.27}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-# Automatically determine the architecture we're building on:
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python ./setup.py install --root=$PKG
-
-
-mv $PKG/usr/share/man $PKG/usr/man
-
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
-
-mkdir -p $PKG/etc/init.d
-
-ln -s /usr/share/ufw/ufw-init $PKG/etc/init.d/ufw
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS ChangeLog* COPYING README* TODO \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
-
diff --git a/network/ufw/ufw.info b/network/ufw/ufw.info
deleted file mode 100644
index 745ffe9713..0000000000
--- a/network/ufw/ufw.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="ufw"
-VERSION="0.27"
-HOMEPAGE="https://launchpad.net/ufw"
-DOWNLOAD="http://launchpad.net/ufw/ufw-0.27-jaunty/0.27/+download/ufw-0.27.tar.gz"
-MD5SUM="acad0f150d7c58dccd97348215c1652f"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="Marco Cecchetti"
-EMAIL="mrc.ildp@gmail.com"
-APPROVED="dsomero"