summaryrefslogtreecommitdiffstats
path: root/network/sic
diff options
context:
space:
mode:
author Haroldo F. Jardim2011-05-27 19:26:59 +0200
committer Robby Workman2011-06-13 07:30:55 +0200
commit9114764a9cad5cc8c99afdd017b3a8a906c8223c (patch)
treee2000e02a84f76323ffbe992bbd1bd89752062c0 /network/sic
parentbb8fbee1cb21fe95447266c2a5d1fd9fee9ecb8a (diff)
downloadslackbuilds-9114764a9cad5cc8c99afdd017b3a8a906c8223c.tar.gz
network/sic: Added (simple irc client)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'network/sic')
-rw-r--r--network/sic/README1
-rw-r--r--network/sic/sic.SlackBuild91
-rw-r--r--network/sic/sic.info10
-rw-r--r--network/sic/slack-desc19
4 files changed, 121 insertions, 0 deletions
diff --git a/network/sic/README b/network/sic/README
new file mode 100644
index 0000000000..e721f1205d
--- /dev/null
+++ b/network/sic/README
@@ -0,0 +1 @@
+sic is an extremely simple IRC client.
diff --git a/network/sic/sic.SlackBuild b/network/sic/sic.SlackBuild
new file mode 100644
index 0000000000..1e15a7d2d5
--- /dev/null
+++ b/network/sic/sic.SlackBuild
@@ -0,0 +1,91 @@
+#!/bin/bash
+#
+# Slackware build script for sic
+# Copyright 2011 Haroldo F. Jardim <hfjardim@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=sic
+VERSION=${VERSION:-1.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvzf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+sed -i "s/CFLAGS =/CFLAGS +=/" config.mk
+
+CFLAGS="$SLKCFLAGS" \
+DESTDIR=$PKG \
+make \
+ PREFIX=/usr \
+ MANPREFIX=/usr/man \
+ install
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc -type f -exec chmod 0644 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/sic/sic.info b/network/sic/sic.info
new file mode 100644
index 0000000000..e1f0596fa2
--- /dev/null
+++ b/network/sic/sic.info
@@ -0,0 +1,10 @@
+PRGNAM="sic"
+VERSION="1.1"
+HOMEPAGE="http://tools.suckless.org/sic"
+DOWNLOAD="http://dl.suckless.org/tools/sic-1.1.tar.gz"
+MD5SUM="856d0e5faa151ae9602713ee7d34a2d5"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Haroldo F. Jardim"
+EMAIL="hfjardim@gmail.com"
+APPROVED="Niels Horn"
diff --git a/network/sic/slack-desc b/network/sic/slack-desc
new file mode 100644
index 0000000000..1c087f10b8
--- /dev/null
+++ b/network/sic/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+sic: sic (simple irc client)
+sic:
+sic: sic is an extremely simple IRC client. It consists of less that 250
+sic: lines of code.
+sic:
+sic: http://tools.suckless.org/sic
+sic:
+sic:
+sic:
+sic:
+sic: