summaryrefslogtreecommitdiffstats
path: root/network/pyzor
diff options
context:
space:
mode:
author LukenShiro2012-12-28 19:40:55 +0100
committer Matteo Bernardini2012-12-28 19:41:21 +0100
commit85d946e29130f94e9d0fa5a2bbcff8b6adbb6891 (patch)
treeb6a9bfbd5dbed5057d5c952fde7033b0847d2b14 /network/pyzor
parent0ef8e082daca99c23d3cc390994030d05f7e67e0 (diff)
downloadslackbuilds-85d946e29130f94e9d0fa5a2bbcff8b6adbb6891.tar.gz
network/pyzor: Added patch for better compatibility with python 2.7.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'network/pyzor')
-rw-r--r--network/pyzor/better-py27-compat.patch8
-rw-r--r--network/pyzor/pyzor.SlackBuild14
2 files changed, 19 insertions, 3 deletions
diff --git a/network/pyzor/better-py27-compat.patch b/network/pyzor/better-py27-compat.patch
new file mode 100644
index 0000000000..6ca107966c
--- /dev/null
+++ b/network/pyzor/better-py27-compat.patch
@@ -0,0 +1,8 @@
+--- pyzor-0.5.0.orig/scripts/pyzor 2009-04-29 17:53:50.000000000 -0300
++++ pyzor-0.5.0/scripts/pyzor 2012-11-30 19:42:39.601001128 -0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python -Wignore::DeprecationWarning
+
+ import os
+ # set umask
diff --git a/network/pyzor/pyzor.SlackBuild b/network/pyzor/pyzor.SlackBuild
index a7a54eb7d0..b478931ba1 100644
--- a/network/pyzor/pyzor.SlackBuild
+++ b/network/pyzor/pyzor.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for pyzor
-# Copyright 2009 LukenShiro <lukenshiro@ngi.it>
+# Copyright 2009-2013 LukenShiro <lukenshiro@ngi.it>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,9 +22,11 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# Thanks to Carlos Xavier for a patch with better compatibility against Python 2.7
+
PRGNAM=pyzor
VERSION=${VERSION:-0.5.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
# Automatically determine the architecture we're building on:
@@ -54,7 +56,13 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+patch -p1 < $CWD/better-py27-compat.patch
# Avoid /usr/share/doc html file's installation
sed -r -i "s|share/doc/pyzor|doc/pyzor-$VERSION|g" setup.py