summaryrefslogtreecommitdiffstats
path: root/network/mz
diff options
context:
space:
mode:
author Heinz Wiesinger2010-05-13 00:37:25 +0200
committer Erik Hanson2010-05-13 00:37:25 +0200
commitf36565bc7e7ffb6df4fb4fa1e3ca6991de24ac99 (patch)
tree6e5b2053789a79219fd6f804c40b483e9e5ec614 /network/mz
parent2b0c3a2f95294ac1ce9a27a97c6eb421089f9dd5 (diff)
downloadslackbuilds-f36565bc7e7ffb6df4fb4fa1e3ca6991de24ac99.tar.gz
network/mz: Updated for version 0.34.9
Diffstat (limited to 'network/mz')
-rw-r--r--network/mz/README2
-rw-r--r--network/mz/mz.SlackBuild16
-rw-r--r--network/mz/mz.info12
3 files changed, 20 insertions, 10 deletions
diff --git a/network/mz/README b/network/mz/README
index 6d3ba2a34c..a322cfc62c 100644
--- a/network/mz/README
+++ b/network/mz/README
@@ -15,4 +15,4 @@ Mausezahn can be used for example
the command line with a simple syntax and online help. It could also be
used within (bash-) scripts to perform combination of tests.
-Mausezahn requires libnet, which is also available from SlackBuilds.org. \ No newline at end of file
+Mausezahn requires libnet, which is also available from SlackBuilds.org.
diff --git a/network/mz/mz.SlackBuild b/network/mz/mz.SlackBuild
index 910d47ad81..8e1b96362a 100644
--- a/network/mz/mz.SlackBuild
+++ b/network/mz/mz.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for mz
-# Copyright 2008-2009 Heinz Wiesinger <pprkut@liwjatan.at>
+# Copyright 2008-2009 Heinz Wiesinger, Amsterdam, The Netherlands
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=mz
-VERSION=0.34.6
+VERSION=0.34.9
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -35,10 +35,13 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
fi
set -e
@@ -56,10 +59,15 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# we need to link to libssp to not fail because of -fstack-protector
+sed -i "s/pcap rt/pcap rt ssp/" src/CMakeLists.txt
+
cmake \
-DCMAKE_C_FLAGS="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS="$SLKCFLAGS" \
- -DCMAKE_INSTALL_PREFIX=/usr
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX="$LIBDIRSUFFIX" \
+ .
make
make install DESTDIR=$PKG
@@ -84,4 +92,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/mz/mz.info b/network/mz/mz.info
index 4154eb00a4..b80ad64a66 100644
--- a/network/mz/mz.info
+++ b/network/mz/mz.info
@@ -1,8 +1,10 @@
PRGNAM="mz"
-VERSION="0.34.6"
+VERSION="0.34.9"
HOMEPAGE="http://www.perihel.at/sec/mz"
-DOWNLOAD="http://www.perihel.at/sec/mz/mz-0.34.6.tar.gz"
-MD5SUM="807bf2bce15206d4dd33e6651c959831"
-MAINTAINER="ppr:kut"
+DOWNLOAD="http://www.perihel.at/sec/mz/mz-0.34.9.tar.gz"
+MD5SUM="17dcc41248744a14690a62bce3b637b2"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Heinz Wiesinger"
EMAIL="pprkut@liwjatan.at"
-APPROVED="michiel"
+APPROVED="Erik Hanson"