summaryrefslogtreecommitdiffstats
path: root/network/gns3
diff options
context:
space:
mode:
author Alam Guntur Nugroho2010-05-12 23:32:11 +0200
committer Robby Workman2010-05-12 23:32:11 +0200
commita69eff4bed983d39341ce26f06b192034b703f2a (patch)
tree48ec89e165cec187f6b457960530df46fdf95c8b /network/gns3
parent45728f38d448465622702a671a70fcecbac5b321 (diff)
downloadslackbuilds-a69eff4bed983d39341ce26f06b192034b703f2a.tar.gz
network/gns3: Added to 12.2 repository
Diffstat (limited to 'network/gns3')
-rw-r--r--network/gns3/README22
-rw-r--r--network/gns3/gns3.SlackBuild79
-rw-r--r--network/gns3/gns3.info8
-rw-r--r--network/gns3/gns3.pngbin0 -> 2375 bytes
-rw-r--r--network/gns3/slack-desc19
5 files changed, 128 insertions, 0 deletions
diff --git a/network/gns3/README b/network/gns3/README
new file mode 100644
index 0000000000..ebabcf3f9a
--- /dev/null
+++ b/network/gns3/README
@@ -0,0 +1,22 @@
+GNS3 is a graphical network simulator that allows simulation of complex
+networks. To allow complete simulations, GNS3 is strongly linked with:
+ * Dynamips, the core program that allows Cisco IOS emulation.
+ * Dynagen, a text-based front-end for Dynamips.
+ * Pemu, a Cisco PIX firewall emulator based on Qemu.
+
+GNS3 is an excellent complementary tool to real labs for Cisco network
+engineers, administrators and people wanting to pass certifications such
+as CCNA, CCNP, CCIP or CCIE. It can also be used to experiment features
+of Cisco IOS or to check configurations that need to be deployed later on
+real routers.
+
+Features overview
+ * Design of high quality and complex network topologies.
+ * Emulation of many Cisco router platforms and PIX firewalls.
+ * Simulation of simple Ethernet, ATM and Frame Relay switches.
+ * Connection of the simulated network to the real world!
+ * Packet capture using Wireshark.
+
+Important notice: users have to provide their own Cisco IOS to use with GNS3.
+
+This requires qt4, sip, and PyQT from SlackBuilds.org.
diff --git a/network/gns3/gns3.SlackBuild b/network/gns3/gns3.SlackBuild
new file mode 100644
index 0000000000..a0038d77c8
--- /dev/null
+++ b/network/gns3/gns3.SlackBuild
@@ -0,0 +1,79 @@
+#!/bin/sh
+
+# Slackware build script for gns3 (http://www.gns3.net)
+
+# Copyright 2008 Alam Guntur Nugroho (alamgn@mail.ugm.ac.id)
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=gns3
+VERSION=${VERSION:-0.6}
+ARCH=noarch
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf GNS3-$VERSION-src
+tar xvf $CWD/GNS3-$VERSION-src.tar.bz2
+cd GNS3-$VERSION-src
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/man/man1
+gzip -9c docs/man/gns3.1 > $PKG/usr/man/man1/gns3.1.gz
+
+# Create a desktop menu entry with an icon
+mkdir -p $PKG/usr/share/{applications,pixmaps}
+cat << EOF > $PKG/usr/share/applications/$PRGNAM.desktop
+[Desktop Entry]
+Type=Application
+Name=GNS3
+GenericName=Graphical Network Simulator
+Comment=GNS3 is a graphical network simulator that allows simulation of complex networks.
+Icon=gns3
+Exec=gns3
+Terminal=false
+Categories=Qt;System;
+StartupNotify=true
+EOF
+cat $CWD/$PRGNAM.png > $PKG/usr/share/pixmaps/$PRGNAM.png
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS CHANGELOG LICENSE README TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc -type f -exec chmod 0644 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-${BUILD}${TAG}.tgz
diff --git a/network/gns3/gns3.info b/network/gns3/gns3.info
new file mode 100644
index 0000000000..26f155b02c
--- /dev/null
+++ b/network/gns3/gns3.info
@@ -0,0 +1,8 @@
+PRGNAM="gns3"
+VERSION="0.6"
+HOMEPAGE="http://www.gns3.net"
+DOWNLOAD="http://downloads.sourceforge.net/gns-3/GNS3-0.6-src.tar.bz2"
+MD5SUM="ec3688e053406eebdf7bf6bb600ea089"
+MAINTAINER="Alam Guntur Nugroho"
+EMAIL="alamgn@mail.ugm.ac.id"
+APPROVED="rworkman"
diff --git a/network/gns3/gns3.png b/network/gns3/gns3.png
new file mode 100644
index 0000000000..b4be8e7f47
--- /dev/null
+++ b/network/gns3/gns3.png
Binary files differ
diff --git a/network/gns3/slack-desc b/network/gns3/slack-desc
new file mode 100644
index 0000000000..eb9be0c989
--- /dev/null
+++ b/network/gns3/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+gns3: GNS3 (A Graphical Network Simulator)
+gns3:
+gns3: GNS3 is a graphical network simulator that allows simulation of
+gns3: complex networks.To allow complete simulations, GNS3 is strongly
+gns3: linked with :
+gns3: Dynamips, the core program that allows Cisco IOS emulation.
+gns3: Dynagen, a text-based front-end for Dynamips.
+gns3: Pemu, a Cisco PIX firewall emulator based on Qemu.
+gns3:
+gns3: Home : http://www.gns3.net
+gns3: