summaryrefslogtreecommitdiffstats
path: root/network/fail2ban/fail2ban.SlackBuild
diff options
context:
space:
mode:
author Nishant Limbachia2010-05-13 00:36:23 +0200
committer David Somero2010-05-13 00:36:23 +0200
commitbe48e858385bef134f4bcb7a55d1325f4b16f5e2 (patch)
treee1bf88131f8fe18f57a1e0ace92798828d3f4750 /network/fail2ban/fail2ban.SlackBuild
parentd8af4d8eefc2ed0063a7ff95f6a2f98d7176b88e (diff)
downloadslackbuilds-be48e858385bef134f4bcb7a55d1325f4b16f5e2.tar.gz
network/fail2ban: Updated for version 0.8.4
Diffstat (limited to 'network/fail2ban/fail2ban.SlackBuild')
-rw-r--r--network/fail2ban/fail2ban.SlackBuild67
1 files changed, 39 insertions, 28 deletions
diff --git a/network/fail2ban/fail2ban.SlackBuild b/network/fail2ban/fail2ban.SlackBuild
index d95b11cd2a..2bc98313ab 100644
--- a/network/fail2ban/fail2ban.SlackBuild
+++ b/network/fail2ban/fail2ban.SlackBuild
@@ -3,15 +3,15 @@
# Slackware Package Build Script for fail2ban
# Home Page http://www.fail2ban.org/wiki/index.php/Main_Page
-# Copyright (c) 2008-2009, Nishant Limbachia (nishant@mnspace.net)
+# Copyright (c) 2008-2009, Nishant Limbachia, Hoffman Est, IL, USA (nishant@mnspace.net)
# All rights reserved.
-#
+
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
-#
+
# 1. Redistributions of script must retain the above copyright notice,
# this list of conditions and the following disclaimer.
-#
+
# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
@@ -25,9 +25,9 @@
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=fail2ban
-VERSION=0.8.3
-ARCH=${ARCH:-noarch}
-BUILD=${BUILD:-2}
+VERSION=0.8.4
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
TMP=${TMP:-/tmp/SBo}
@@ -35,47 +35,58 @@ PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
CWD=$(pwd)
+# exit on most errors
set -e
+# clean up from previous builds
rm -fr $PKG $TMP/$PRGNAM-$VERSION
mkdir -p $PKG $TMP $OUTPUT
cd $TMP
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
cd $TMP/$PRGNAM-$VERSION
chown -R root.root .
find . \
- \( -perm 777 -o -perm 775 -o -perm 771 -o -perm 711 -o -perm 555 -o -perm 551 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 660 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+\( -perm 777 -o -perm 775 -o -perm 771 -o -perm 711 -o -perm 555 -o -perm 551 -o -perm 511 \) \
+-exec chmod 755 {} \; -o \
+\( -perm 666 -o -perm 664 -o -perm 660 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+-exec chmod 644 {} \;
python setup.py install --root=$PKG
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- COPYING ChangeLog PKG-INFO README TODO \
- $PKG/usr/doc/$PRGNAM-$VERSION
-install -m 0644 $CWD/README.SLACKWARE $CWD/$PRGNAM.SlackBuild \
- $PKG/usr/doc/$PRGNAM-$VERSION
-
+# installing man pages
mkdir -p $PKG/usr/man/man1
-install -m 0644 man/*.1 $PKG/usr/man/man1
+install -m 0644 man/fail2ban-client.1 man/fail2ban-regex.1 \
+man/fail2ban-server.1 $PKG/usr/man/man1
-install -D -m 0755 $CWD/rc.fail2ban $PKG/etc/rc.d/rc.fail2ban.new
+# move config files to .new
+( cd $PKG/etc/fail2ban
+ for file in $(find . -type f); do
+ mv $file "$file.new"
+ done
+)
+# compress man pages
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
+)
+
+# install startup script
+install -D -m 0644 $CWD/rc.fail2ban $PKG/etc/rc.d/rc.fail2ban.new
+
+# install logrotate script
install -D -m 0644 $CWD/fail2ban.logrotate $PKG/etc/logrotate.d/fail2ban.new
-# Make directory for socket and pid file
+# make directory for socket and pid file
mkdir -p $PKG/var/run/fail2ban
-( cd $PKG/usr/man || exit 1
- find . -type f -exec gzip -9 {} \;
- for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
-)
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING ChangeLog PKG-INFO README TODO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+# building package
mkdir -p $PKG/install
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
-
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}