summaryrefslogtreecommitdiffstats
path: root/network/asciinema
diff options
context:
space:
mode:
author B. Watson2022-04-03 19:31:38 +0200
committer B. Watson2022-04-03 19:31:38 +0200
commit90065abccb0c4911bb42aa7f40537bc705e0c635 (patch)
treedf79b97e002bf29885b810e483cdb67f1449ba1a /network/asciinema
parentb075ab0f1149ab1e624eae13bad320f3526ae791 (diff)
downloadslackbuilds-90065abccb0c4911bb42aa7f40537bc705e0c635.tar.gz
network/asciinema: Install docs to correct dir.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'network/asciinema')
-rw-r--r--network/asciinema/asciinema.SlackBuild26
1 files changed, 11 insertions, 15 deletions
diff --git a/network/asciinema/asciinema.SlackBuild b/network/asciinema/asciinema.SlackBuild
index bddfb6dc92..db068b5d79 100644
--- a/network/asciinema/asciinema.SlackBuild
+++ b/network/asciinema/asciinema.SlackBuild
@@ -22,11 +22,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20220403 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - install docs to correct dir, /usr/doc/$PRGNAM-$VERSION
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=asciinema
VERSION=${VERSION:-2.1.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -75,23 +75,19 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-# Fixed doc and manpage path
-sed -i -e "s/share\/doc/doc/" -e "s/share\/man/man/" setup.py
+# Fix manpage path
+sed -i -e "s/share\/man/man/" setup.py
python3 setup.py install --root=$PKG
-
-# install man page
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+gzip -9 $PKG/usr/man/man*/*
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+mv $PKG/usr/share/doc/$PRGNAM/* $PKG/usr/doc/$PRGNAM-$VERSION
+rm -rf $PKG/usr/share # nothing here but empty doc/ dir.
cp -a *.md PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild