summaryrefslogtreecommitdiffstats
path: root/network/PyRSS2Gen/PyRSS2Gen.SlackBuild
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2013-11-12 01:41:24 +0100
committer Robby Workman2013-11-12 08:25:02 +0100
commit6e479bf61613b7b9fffb0af5986fdb1ae3ffb41f (patch)
tree3f0d3950f4ee6a50674b8002da0f3a5309d1f0d0 /network/PyRSS2Gen/PyRSS2Gen.SlackBuild
parentb22a42c040936a9d70a4bbd43d0db41e09615917 (diff)
downloadslackbuilds-6e479bf61613b7b9fffb0af5986fdb1ae3ffb41f.tar.gz
network/PyRSS2Gen: Updated for version 1.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackware-id.org> Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'network/PyRSS2Gen/PyRSS2Gen.SlackBuild')
-rw-r--r--network/PyRSS2Gen/PyRSS2Gen.SlackBuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/network/PyRSS2Gen/PyRSS2Gen.SlackBuild b/network/PyRSS2Gen/PyRSS2Gen.SlackBuild
index 09ddbe5259..2285cf259b 100644
--- a/network/PyRSS2Gen/PyRSS2Gen.SlackBuild
+++ b/network/PyRSS2Gen/PyRSS2Gen.SlackBuild
@@ -6,7 +6,7 @@
# Based on http://slackbuilds.org/template.SlackBuild
PRGNAM=PyRSS2Gen
-VERSION=${VERSION:-1.0.0}
+VERSION=${VERSION:-1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -32,11 +32,12 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py build || exit 1
python setup.py install --root=$PKG || exit 1