summaryrefslogtreecommitdiffstats
path: root/network/DenyHosts
diff options
context:
space:
mode:
author chopp2011-05-18 21:09:29 +0200
committer Robby Workman2011-05-18 21:09:29 +0200
commitd9c3239d6a3ca214324f7c2c95b8f2d4eb5e105b (patch)
tree78b9238c9db1c6802f34027990496e17f616268b /network/DenyHosts
parentcfbbc1a4d5dddddd8949d05ab132613eb62eda3c (diff)
downloadslackbuilds-d9c3239d6a3ca214324f7c2c95b8f2d4eb5e105b.tar.gz
network/DenyHosts: Added (script to help thwart SSH server attacks)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'network/DenyHosts')
-rw-r--r--network/DenyHosts/DenyHosts.SlackBuild70
-rw-r--r--network/DenyHosts/DenyHosts.info10
-rw-r--r--network/DenyHosts/README4
-rw-r--r--network/DenyHosts/slack-desc19
4 files changed, 103 insertions, 0 deletions
diff --git a/network/DenyHosts/DenyHosts.SlackBuild b/network/DenyHosts/DenyHosts.SlackBuild
new file mode 100644
index 0000000000..2e09a38dcf
--- /dev/null
+++ b/network/DenyHosts/DenyHosts.SlackBuild
@@ -0,0 +1,70 @@
+#!/bin/sh
+# Slackware build script for denyhosts
+# Written by chopp (nix4me@gmail.com)
+# Some portions, methods and/or ideas obtained from:
+# http://slackbuilds.org/python-template.SlackBuild
+
+
+PRGNAM=DenyHosts
+VERSION=${VERSION:-2.6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+for docfile in CHANGELOG.txt LICENSE.txt README.txt ; do
+ ln -s /usr/share/denyhosts/$docfile $PKG/usr/doc/$PRGNAM-$VERSION/ ;
+done
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/DenyHosts/DenyHosts.info b/network/DenyHosts/DenyHosts.info
new file mode 100644
index 0000000000..0918a9f020
--- /dev/null
+++ b/network/DenyHosts/DenyHosts.info
@@ -0,0 +1,10 @@
+PRGNAM="DenyHosts"
+VERSION="2.6"
+HOMEPAGE="http://denyhosts.sourceforge.net/"
+DOWNLOAD="http://downloads.sourceforge.net/denyhosts/DenyHosts-2.6.tar.gz"
+MD5SUM="fc2365305a9402886a2b0173d1beb7df"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="chopp"
+EMAIL="nix4me@gmail.com"
+APPROVED="rworkman"
diff --git a/network/DenyHosts/README b/network/DenyHosts/README
new file mode 100644
index 0000000000..823f2b3e16
--- /dev/null
+++ b/network/DenyHosts/README
@@ -0,0 +1,4 @@
+DenyHosts is a python program that automatically blocks ssh attacks
+by adding entries to /etc/hosts.deny. DenyHosts will also inform
+Linux administrators about offending hosts, attacked users, and
+suspicious logins.
diff --git a/network/DenyHosts/slack-desc b/network/DenyHosts/slack-desc
new file mode 100644
index 0000000000..4af2620196
--- /dev/null
+++ b/network/DenyHosts/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+DenyHosts: DenyHosts (script to help thwart SSH server attacks)
+DenyHosts:
+DenyHosts: DenyHosts is a python program that automatically blocks ssh attacks
+DenyHosts: by adding entries to /etc/hosts.deny. DenyHosts will also inform
+DenyHosts: Linux administrators about offending hosts, attacked users, and
+DenyHosts: suspicious logins.
+DenyHosts:
+DenyHosts: Homepage: http://denyhosts.sourceforge.net/
+DenyHosts:
+DenyHosts:
+DenyHosts: