summaryrefslogtreecommitdiffstats
path: root/network/2ping/2ping.SlackBuild
diff options
context:
space:
mode:
author B. Watson2018-08-27 20:16:35 +0200
committer Willy Sudiarto Raharjo2018-09-01 02:32:28 +0200
commit16bc40f500ca0e616dcbce4dce62423ea958ac8d (patch)
tree28e5980c12dba62267a257a80272612f6c5b29d0 /network/2ping/2ping.SlackBuild
parent843e3bb5332fd2c0037df9c73fbb018394f39c20 (diff)
downloadslackbuilds-16bc40f500ca0e616dcbce4dce62423ea958ac8d.tar.gz
network/2ping: Updated for version 4.2.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'network/2ping/2ping.SlackBuild')
-rw-r--r--network/2ping/2ping.SlackBuild25
1 files changed, 18 insertions, 7 deletions
diff --git a/network/2ping/2ping.SlackBuild b/network/2ping/2ping.SlackBuild
index bdb398e8f5..263ffa123b 100644
--- a/network/2ping/2ping.SlackBuild
+++ b/network/2ping/2ping.SlackBuild
@@ -6,8 +6,13 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20180821 bkw:
+# - update for v4.2.
+# - document optional deps in README.
+# - include wireshark stuff in package.
+
PRGNAM=2ping
-VERSION=${VERSION:-4.1}
+VERSION=${VERSION:-4.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -41,18 +46,24 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
python3 setup.py install --root=$PKG
+# Include wireshark stuff, if we have a wireshark that can use it (built
+# with lua52). The lua script is for decoding, the .pcap file is a sample
+# packet capture (belongs in doc dir).
+if [ -x /usr/bin/wireshark ] && ldd /usr/bin/wireshark | fgrep -q lua5.2; then
+ mkdir -p $PKG/usr/lib$LIBDIRSUFFIX/wireshark/plugins
+ cp -a wireshark/*.lua $PKG/usr/lib$LIBDIRSUFFIX/wireshark/plugins
+fi
+
mkdir -p $PKG/usr/man/man1
gzip -9c < doc/$PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/wireshark
cp -a README* COPYING ChangeLog doc/*.py doc/*.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a wireshark/*.pcap $PKG/usr/doc/$PRGNAM-$VERSION/wireshark
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc