summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author B. Watson2022-04-21 21:31:55 +0200
committer B. Watson2022-04-21 21:31:55 +0200
commit638a614b59e926ce142e24f58cda9480a1c1634b (patch)
treeee07cbacf5e81079395370f7ca4892b9baad7359 /multimedia
parentf605ac666d1b34bbfd475a7410761fff5ab0a782 (diff)
downloadslackbuilds-638a614b59e926ce142e24f58cda9480a1c1634b.tar.gz
multimedia/openshot: Fix doinst.sh, stop spamming /usr.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/openshot/doinst.sh6
-rw-r--r--multimedia/openshot/openshot.SlackBuild11
2 files changed, 16 insertions, 1 deletions
diff --git a/multimedia/openshot/doinst.sh b/multimedia/openshot/doinst.sh
index 9a8ded3c60..9424ce43ff 100644
--- a/multimedia/openshot/doinst.sh
+++ b/multimedia/openshot/doinst.sh
@@ -5,3 +5,9 @@ fi
if [ -x /usr/bin/update-mime-database ]; then
/usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/multimedia/openshot/openshot.SlackBuild b/multimedia/openshot/openshot.SlackBuild
index f6f6bbc4a3..5db1182ff1 100644
--- a/multimedia/openshot/openshot.SlackBuild
+++ b/multimedia/openshot/openshot.SlackBuild
@@ -44,12 +44,16 @@
# From Oct 22nd, 2016-2020
# Maintenance & various version upgrades - Christoph Willing <chris.willing@linux.com>
+# 20220421 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - add gtk-update-icon-cache to doinst.sh.
+# - stop writing outside of $TMP (except /root/.openshot_qt/).
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=openshot
SRCNAM=openshot-qt
VERSION=${VERSION:-2.6.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -100,6 +104,11 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# 20220421 bkw: setup.py doesn't need to call update-mime-database and
+# update-desktop-database; it spams the real /usr, and our doinst.sh
+# already does the job.
+sed -i '/^if ROOT and/,$d' setup.py
+
python3 setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \