summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author Christoph Willing2021-05-09 02:48:38 +0200
committer Robby Workman2021-05-10 06:09:38 +0200
commit443761b97f0d13852881f258b2a62877ea0a83fa (patch)
tree2465d14bf56f50fe06124df77197339b47704781 /multimedia
parent339f304db3aab75dbe2dc544058bed3657f0b9b9 (diff)
downloadslackbuilds-443761b97f0d13852881f258b2a62877ea0a83fa.tar.gz
multimedia/obs-studio: Updated for version 26.1.2.
Signed-off-by: Christoph Willing <chris.willing@linux.com>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/obs-studio/README6
-rw-r--r--multimedia/obs-studio/obs-studio.SlackBuild36
-rw-r--r--multimedia/obs-studio/obs-studio.info16
3 files changed, 31 insertions, 27 deletions
diff --git a/multimedia/obs-studio/README b/multimedia/obs-studio/README
index 22446edbfb..22929f0463 100644
--- a/multimedia/obs-studio/README
+++ b/multimedia/obs-studio/README
@@ -6,9 +6,3 @@ For full functionality, plug-ins using jack, luajit and vlc will be
constructed if those packages (all available at SBo) are detected at
build time.
-Another optional build requirement is the mbedtls package which is used
-to provide RTMPS support. However it will be disabled unless at least
-version 2.7.0 of the mbedtls package is detected at build time.
-
-Due to the cmake version in Slackware-14.2,
-the latest buildable version of obs-studio is restricted to version 24.0.6.
diff --git a/multimedia/obs-studio/obs-studio.SlackBuild b/multimedia/obs-studio/obs-studio.SlackBuild
index 01784c0c87..477796494e 100644
--- a/multimedia/obs-studio/obs-studio.SlackBuild
+++ b/multimedia/obs-studio/obs-studio.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for Open Broadcaster Software
#
# Copyright 2015 Gethyn ThomasQuail <gethyn@bloodbathsoftworks.com>
-# Copyright 2016-2020 Christoph Willing, Brisbane Australia
+# Copyright 2016-2021 Christoph Willing, Brisbane Australia
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=obs-studio
-VERSION=${VERSION:-26.0.2}
+VERSION=${VERSION:-26.1.2}
+COMMIT=3514f4fea5ead7aa15f1e57934a86a55b579fed0
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -44,12 +45,15 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
+ CEF_ROOT=cef_binary_87.1.14+ga29e9a3+chromium-87.0.4280.141_linux32_minimal
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
+ CEF_ROOT=cef_binary_87.1.14+ga29e9a3+chromium-87.0.4280.141_linux32_minimal
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+ CEF_ROOT=cef_binary_87.1.14+ga29e9a3+chromium-87.0.4280.141_linux64_minimal
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
@@ -60,9 +64,19 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $PRGNAM-$COMMIT
+tar xvf $CWD/$PRGNAM-$COMMIT.tar.gz
+tar xvf $CWD/$CEF_ROOT.tar.bz2
+cd $CEF_ROOT
+ strip -v Release/*.so
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_BUILD_TYPE=Release .
+ make libcef_dll_wrapper
+ cd ..
+cd $PRGNAM-$COMMIT
+sed -i -e "s/^obs_install/#obs_install/" libobs/CMakeLists.txt
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -70,15 +84,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Check for mbedtls existence and version suitability (need at least version 2.7.0)
-mbedtls="-DMBEDTLS_LIB=OFF"
-if test -e /usr/include/mbedtls/version.h ; then
- version_number_line=$(grep MBEDTLS_VERSION_NUMBER /usr/include/mbedtls/version.h)
- if [ "$?" = "0" ]; then
- version_number=$(expr substr $(echo $version_number_line | rev | cut -d' ' -f1 | rev) 3 8)
- if expr $version_number \> 02070000 1>/dev/null ; then mbedtls="" ; fi
- fi
-fi
mkdir -p build
cd build
@@ -89,7 +94,8 @@ cd build
-DOBS_MULTIARCH_SUFFIX="$LIBDIRSUFFIX" \
-DOBS_VERSION_OVERRIDE=${VERSION} \
-DUNIX_STRUCTURE=ON \
- $mbedtls \
+ -DBUILD_BROWSER=ON \
+ -DCEF_ROOT_DIR="../../$CEF_ROOT" \
-DCMAKE_BUILD_TYPE=Release ..
make
make install DESTDIR=$PKG
diff --git a/multimedia/obs-studio/obs-studio.info b/multimedia/obs-studio/obs-studio.info
index 93970733a5..e575b867a4 100644
--- a/multimedia/obs-studio/obs-studio.info
+++ b/multimedia/obs-studio/obs-studio.info
@@ -1,10 +1,14 @@
PRGNAM="obs-studio"
-VERSION="26.0.2"
+VERSION="26.1.2"
HOMEPAGE="https://obsproject.com/"
-DOWNLOAD="https://github.com/obsproject/obs-studio/archive/26.0.2/obs-studio-26.0.2.tar.gz"
-MD5SUM="75dea679867dce642c8d1910ef6da0a5"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="faac luajit rtmpdump x264 jack libfdk-aac"
+DOWNLOAD="https://sourceforge.net/projects/slackbuildsdirectlinks/files/obs/obs-studio-3514f4fea5ead7aa15f1e57934a86a55b579fed0.tar.gz \
+ https://cef-builds.spotifycdn.com/cef_binary_87.1.14%2Bga29e9a3%2Bchromium-87.0.4280.141_linux32_minimal.tar.bz2"
+MD5SUM="932f6cd4787671d07919427d88f0468b \
+ 0612e9d056cb4af780ccdad0a0e99b13"
+DOWNLOAD_x86_64="https://sourceforge.net/projects/slackbuildsdirectlinks/files/obs/obs-studio-3514f4fea5ead7aa15f1e57934a86a55b579fed0.tar.gz \
+ https://cef-builds.spotifycdn.com/cef_binary_87.1.14%2Bga29e9a3%2Bchromium-87.0.4280.141_linux64_minimal.tar.bz2"
+MD5SUM_x86_64="932f6cd4787671d07919427d88f0468b \
+ 0aae132dd4d4cd86d412ef81327a8324"
+REQUIRES="faac luajit rtmpdump x264 jack libfdk-aac mbedtls"
MAINTAINER="Christoph Willing"
EMAIL="chris.willing@linux.com"