summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2014-02-18 21:57:05 +0100
committer Erik Hanson2014-02-18 21:57:05 +0100
commitb44d59789b5827e9083b7a5d38153f061067f2ca (patch)
treec2ea1a125c0e55e89f00c5856ba387f03436b8f4 /multimedia
parent263cf1a0ae368ced5850e2b12b909e2d086054c3 (diff)
downloadslackbuilds-b44d59789b5827e9083b7a5d38153f061067f2ca.tar.gz
multimedia/x265: Added (H265/HEVC video encoder)
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/x265/README2
-rw-r--r--multimedia/x265/slack-desc19
-rw-r--r--multimedia/x265/x265.SlackBuild105
-rw-r--r--multimedia/x265/x265.info10
4 files changed, 136 insertions, 0 deletions
diff --git a/multimedia/x265/README b/multimedia/x265/README
new file mode 100644
index 0000000000..ca00a89d95
--- /dev/null
+++ b/multimedia/x265/README
@@ -0,0 +1,2 @@
+x265 is free software library and application for encoding video
+streams into the H.265/MPEG-H HEVC compression format.
diff --git a/multimedia/x265/slack-desc b/multimedia/x265/slack-desc
new file mode 100644
index 0000000000..4d2c2bb0f4
--- /dev/null
+++ b/multimedia/x265/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+x265: x265 (H265/HEVC video encoder)
+x265:
+x265: x265 is free software library and application for encoding video
+x265: streams into the H.265/MPEG-H HEVC compression format.
+x265:
+x265:
+x265:
+x265: Project URL: https://bitbucket.org/multicoreware/x265
+x265:
+x265:
+x265:
diff --git a/multimedia/x265/x265.SlackBuild b/multimedia/x265/x265.SlackBuild
new file mode 100644
index 0000000000..a81ecaf678
--- /dev/null
+++ b/multimedia/x265/x265.SlackBuild
@@ -0,0 +1,105 @@
+#!/bin/sh
+
+# Slackware build script for x265
+
+# Copyright 2014 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=x265
+VERSION=${VERSION:-0.7}
+REVISION=${REVISION:-d24e2a8c4326}
+SRCNAM=multicoreware
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$PRGNAM-$REVISION
+tar xvf $CWD/$SRCNAM-$PRGNAM-$REVISION.tar.bz2
+cd $SRCNAM-$PRGNAM-$REVISION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# patched for x86_64
+sed -i "s|/lib|/lib${LIBDIRSUFFIX}|" source/x265.pc.in
+sed -i "s|/lib|/lib${LIBDIRSUFFIX}|" source/CMakeLists.txt
+sed -i "s|LIBRARY DESTINATION lib|LIBRARY DESTINATION lib${LIBDIRSUFFIX}|" source/CMakeLists.txt
+sed -i "s|ARCHIVE DESTINATION lib|ARCHIVE DESTINATION lib${LIBDIRSUFFIX}|" source/CMakeLists.txt
+
+cd build/linux
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release ../../source
+ make
+ make install DESTDIR=$PKG
+
+cd ../..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+# Remove static library
+rm -f $PKG/usr/lib${LIBDIRSUFFIX}/libx265.a
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING doc/intra/ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/multimedia/x265/x265.info b/multimedia/x265/x265.info
new file mode 100644
index 0000000000..76dacf04d4
--- /dev/null
+++ b/multimedia/x265/x265.info
@@ -0,0 +1,10 @@
+PRGNAM="x265"
+VERSION="0.7"
+HOMEPAGE="https://www.videolan.org/developers/x265.html"
+DOWNLOAD="https://bitbucket.org/multicoreware/x265/get/0.7.tar.bz2"
+MD5SUM="042f8518e58ec69c870e6ae499fc0c55"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Willy Sudiarto Raharjo"
+EMAIL="willysr@slackbuilds.org"