summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-03-07 11:54:10 +0100
committer Willy Sudiarto Raharjo2014-03-07 11:54:10 +0100
commit691fc39fbd4349c73917d5fd39cc796b4a4c5735 (patch)
tree748560fd166159546d110f5702582d9eb8a97eb6 /multimedia
parentb51b76725051a41f78aca465660750b4d733733f (diff)
downloadslackbuilds-691fc39fbd4349c73917d5fd39cc796b4a4c5735.tar.gz
multimedia/Mopidy: Added (Music server).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Mopidy/Mopidy.SlackBuild86
-rw-r--r--multimedia/Mopidy/Mopidy.info10
-rw-r--r--multimedia/Mopidy/README5
-rw-r--r--multimedia/Mopidy/doinst.sh3
-rw-r--r--multimedia/Mopidy/slack-desc19
5 files changed, 123 insertions, 0 deletions
diff --git a/multimedia/Mopidy/Mopidy.SlackBuild b/multimedia/Mopidy/Mopidy.SlackBuild
new file mode 100644
index 0000000000..15760f4931
--- /dev/null
+++ b/multimedia/Mopidy/Mopidy.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for Mopidy
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=Mopidy
+VERSION=${VERSION:-0.18.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS LICENSE PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/multimedia/Mopidy/Mopidy.info b/multimedia/Mopidy/Mopidy.info
new file mode 100644
index 0000000000..eb31f84a46
--- /dev/null
+++ b/multimedia/Mopidy/Mopidy.info
@@ -0,0 +1,10 @@
+PRGNAM="Mopidy"
+VERSION="0.18.3"
+HOMEPAGE="http://www.mopidy.com/"
+DOWNLOAD="https://pypi.python.org/packages/source/M/Mopidy/Mopidy-0.18.3.tar.gz"
+MD5SUM="5848665c7649219e5ded0cc47948a3d4"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools Pykka CherryPy ws4py gst-python"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/multimedia/Mopidy/README b/multimedia/Mopidy/README
new file mode 100644
index 0000000000..d12942a260
--- /dev/null
+++ b/multimedia/Mopidy/README
@@ -0,0 +1,5 @@
+Mopidy is a music server which can play music both from multiple sources, like
+your local hard drive, radio streams, and from Spotify and SoundCloud. Searches
+combines results from all music sources, and you can mix tracks from all
+sources in your play queue. Your playlists from Spotify or SoundCloud are also
+available for use.
diff --git a/multimedia/Mopidy/doinst.sh b/multimedia/Mopidy/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/multimedia/Mopidy/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/multimedia/Mopidy/slack-desc b/multimedia/Mopidy/slack-desc
new file mode 100644
index 0000000000..d4c18a013f
--- /dev/null
+++ b/multimedia/Mopidy/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+Mopidy: Mopidy (Music server)
+Mopidy:
+Mopidy: Mopidy is a music server which can play
+Mopidy: music both from multiple sources, like your
+Mopidy: local hard drive, radio streams, and from
+Mopidy: Spotify and SoundCloud.
+Mopidy:
+Mopidy: Homepage: http://www.mopidy.com/
+Mopidy:
+Mopidy:
+Mopidy: