summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author Heinz Wiesinger2010-05-11 20:30:42 +0200
committer Heinz Wiesinger2010-05-11 20:30:42 +0200
commit5953bc5be2592ce5e491acbe6b0c170ba0f7a42b (patch)
tree57104f80afe1c3bddfbe5ca928cfcd1e731ad92a /multimedia
parent4ce0dbc9f70c1c1d7b4cb95c8e1c1e7ff1b1f904 (diff)
downloadslackbuilds-5953bc5be2592ce5e491acbe6b0c170ba0f7a42b.tar.gz
audio/abcde: Moved from multimedia
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/abcde/Makefile.diff31
-rw-r--r--multimedia/abcde/README13
-rw-r--r--multimedia/abcde/abcde.SlackBuild80
-rw-r--r--multimedia/abcde/abcde.info8
-rw-r--r--multimedia/abcde/doinst.sh15
-rw-r--r--multimedia/abcde/slack-desc19
6 files changed, 0 insertions, 166 deletions
diff --git a/multimedia/abcde/Makefile.diff b/multimedia/abcde/Makefile.diff
deleted file mode 100644
index 9a7d24f353..0000000000
--- a/multimedia/abcde/Makefile.diff
+++ /dev/null
@@ -1,31 +0,0 @@
-diff -Nur abcde-2.3.3.orig/Makefile abcde-2.3.3/Makefile
---- abcde-2.3.3.orig/Makefile 2005-08-25 17:43:27.000000000 -0500
-+++ abcde-2.3.3/Makefile 2007-02-01 10:21:55.000000000 -0600
-@@ -4,7 +4,7 @@
- # Installation directories
- prefix = ${DESTDIR}/usr
- exec_prefix = ${prefix}
--mandir = ${prefix}/share/man/man1
-+mandir = ${prefix}/man/man1
- bindir = ${exec_prefix}/bin
- etcdir = ${DESTDIR}/etc
-
-@@ -14,13 +14,13 @@
-
- install:
- $(INSTALL) -d -m 755 $(bindir)
-- $(INSTALL) -m 755 -o 0 abcde $(bindir)
-- $(INSTALL) -m 755 -o 0 cddb-tool $(bindir)
-+ $(INSTALL) -m 755 abcde $(bindir)
-+ $(INSTALL) -m 755 cddb-tool $(bindir)
- $(INSTALL) -d -m 755 $(mandir)
-- $(INSTALL) -m 644 -o 0 abcde.1 $(mandir)
-- $(INSTALL) -m 644 -o 0 cddb-tool.1 $(mandir)
-+ $(INSTALL) -m 644 abcde.1 $(mandir)
-+ $(INSTALL) -m 644 cddb-tool.1 $(mandir)
- $(INSTALL) -d -m 755 $(etcdir)
-- $(INSTALL) -m 644 -o 0 abcde.conf $(etcdir)
-+ $(INSTALL) -m 644 abcde.conf $(etcdir)
-
- tarball:
- @cd .. && tar czvf abcde_$(VERSION).orig.tar.gz \
diff --git a/multimedia/abcde/README b/multimedia/abcde/README
deleted file mode 100644
index 77ae4f39bf..0000000000
--- a/multimedia/abcde/README
+++ /dev/null
@@ -1,13 +0,0 @@
-abcde is a frontend command-line utility (actually, a shell script)
-that grabs tracks off a CD encodes them to Ogg/Vorbis, MP3, FLAC,
-OGG/Speex, and/or MPP/MP+(Musepack) format, and tags them, all in one
-go.
-
-abcde requires cd-discid, which is also available at SlackBuilds.org.
-If you want to have mp3 encoding capability, you need to install the
-lame package (lame is also available at SlackBuilds.org).
-
-There are many more features that abcde supports that you can add on, such as
-mkcue and encoding in other various formats, see the man page for more info.
-Try running abcde as root (sudo or whatever) if abcde/cd-discid thinks your
-favorite audio cd is a data cd.
diff --git a/multimedia/abcde/abcde.SlackBuild b/multimedia/abcde/abcde.SlackBuild
deleted file mode 100644
index dee9c05230..0000000000
--- a/multimedia/abcde/abcde.SlackBuild
+++ /dev/null
@@ -1,80 +0,0 @@
-#!/bin/sh
-# Slackware build script for abcde
-# abcde has a dependency of cd-discid, see the README
-
-# Copyright 2007 Jim Capozzoli <saltmiser@gmail.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# Modified by the SlackBuilds.org project
-
-set -e
-
-PRGNAM=abcde
-VERSION=2.3.3
-ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-rm -rf $TMP/$PRGNAM-$VERSION
-
-cd $TMP
-tar -xzvf $CWD/$PRGNAM\_$VERSION.orig.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
-
-# Fix mandir and remove setting of ownership during install
-# The mandir can easily be changed by passing a 'mandir' variable to the
-# 'make install' process, but the setting of ownership isn't so easy to
-# work around without a patch. This isn't an issue if the SlackBuild
-# script is run as root, but I'm guessing that I'm not the only person who
-# likes to test a script as normal user before running it as root, and the
-# ownership setting in the Makefile will break installs as a normal user.
-# --rworkman
-patch -p1 < $CWD/Makefile.diff
-
-make
-make install DESTDIR=$PKG || exit
-
-# Let's not overwrite the config file if it already exists
-mv $PKG/etc/$PRGNAM.conf $PKG/etc/$PRGNAM.conf.new
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING FAQ README TODO changelog examples $PKG/usr/doc/$PRGNAM-$VERSION
-find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-( cd $PKG/usr/man || exit
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/multimedia/abcde/abcde.info b/multimedia/abcde/abcde.info
deleted file mode 100644
index b20b3fd7c9..0000000000
--- a/multimedia/abcde/abcde.info
+++ /dev/null
@@ -1,8 +0,0 @@
-PRGNAM="abcde"
-VERSION="2.3.3"
-HOMEPAGE="http://www.hispalinux.es/~data/abcde.php"
-DOWNLOAD="http://www.hispalinux.es/~data/files/abcde_2.3.3.orig.tar.gz"
-MD5SUM="94877d1e410ae420630b1048e82907d3"
-MAINTAINER="Jim Capozzoli"
-EMAIL="saltmiser@gmail.com"
-APPROVED="rworkman,BP{k}"
diff --git a/multimedia/abcde/doinst.sh b/multimedia/abcde/doinst.sh
deleted file mode 100644
index 351330037a..0000000000
--- a/multimedia/abcde/doinst.sh
+++ /dev/null
@@ -1,15 +0,0 @@
-config() {
- NEW="$1"
- OLD="`dirname $NEW`/`basename $NEW .new`"
- # If there's no config file by that name, mv it over:
- if [ ! -r $OLD ]; then
- mv $NEW $OLD
- elif [ "`cat $OLD | md5sum`" = "`cat $NEW | md5sum`" ]; then
- # toss the redundant copy
- rm $NEW
- fi
- # Otherwise, we leave the .new copy for the admin to consider...
-}
-
-config etc/abcde.conf.new
-
diff --git a/multimedia/abcde/slack-desc b/multimedia/abcde/slack-desc
deleted file mode 100644
index 60034d01a0..0000000000
--- a/multimedia/abcde/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-abcde: abcde (shell script to encode CD's)
-abcde:
-abcde: abcde is a frontend command-line utility (actually, a shell script)
-abcde: that grabs tracks off a CD, encodes them to Ogg/Vorbis, MP3, FLAC,
-abcde: OGG/Speex and/or MPP/MP+(Musepack) format, and tags them, all in one
-abcde: go.
-abcde:
-abcde:
-abcde:
-abcde:
-abcde: