summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-01-23 11:03:22 +0100
committer Erik Hanson2014-01-30 06:21:11 +0100
commit55a281b5d62a40074f8af8ce751a620bf282982d (patch)
tree092250651e7a0dee266d4e106068e3accc371804 /multimedia
parent0cbfb5f80eb56b5b6ae56164829e624fb95a3a8b (diff)
downloadslackbuilds-55a281b5d62a40074f8af8ce751a620bf282982d.tar.gz
multimedia/OpenLP: Added (Open Source Worship Presentation).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/OpenLP/OpenLP.SlackBuild95
-rw-r--r--multimedia/OpenLP/OpenLP.desktop10
-rw-r--r--multimedia/OpenLP/OpenLP.info10
-rw-r--r--multimedia/OpenLP/README15
-rw-r--r--multimedia/OpenLP/doinst.sh7
-rw-r--r--multimedia/OpenLP/slack-desc19
6 files changed, 156 insertions, 0 deletions
diff --git a/multimedia/OpenLP/OpenLP.SlackBuild b/multimedia/OpenLP/OpenLP.SlackBuild
new file mode 100644
index 0000000000..0c54e0e70d
--- /dev/null
+++ b/multimedia/OpenLP/OpenLP.SlackBuild
@@ -0,0 +1,95 @@
+#!/bin/sh
+
+# Slackware build script for OpenLP
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=OpenLP
+VERSION=${VERSION:-2.0.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+install -D -m644 documentation/openlp.1 $PKG/usr/man/man1/openlp.1
+find $PKG/usr/man -type f -name "*.?" -exec gzip -9f {} \;
+
+mkdir -p $PKG/usr/share/applications
+install -D -m644 $CWD/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
+
+mkdir -p $PKG/usr/share/pixmaps/
+install -D -m644 resources/images/$PRGNAM.ico $PKG/usr/share/pixmaps/$PRGNAM.svg
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.txt LICENSE copyright.txt documentation/* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/multimedia/OpenLP/OpenLP.desktop b/multimedia/OpenLP/OpenLP.desktop
new file mode 100644
index 0000000000..0dbadb6933
--- /dev/null
+++ b/multimedia/OpenLP/OpenLP.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Open Source Worship Presentation
+Name[he]= OpenLP
+Comment=Open Source Worship Presentation
+Exec=openlp.pyw
+Icon=OpenLP
+Terminal=false
+Type=Application
+Categories=Multimedia;AudioVideo
+GenericName=AudioVideo
diff --git a/multimedia/OpenLP/OpenLP.info b/multimedia/OpenLP/OpenLP.info
new file mode 100644
index 0000000000..abad3180ad
--- /dev/null
+++ b/multimedia/OpenLP/OpenLP.info
@@ -0,0 +1,10 @@
+PRGNAM="OpenLP"
+VERSION="2.0.3"
+HOMEPAGE="http://openlp.org/"
+DOWNLOAD="http://downloads.sourceforge.net/project/openlp/openlp/2.0.3/OpenLP-2.0.3.tar.gz"
+MD5SUM="8cf67c3e95a1943b63f01593aaa74e5f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="lxml SQLAlchemy"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/multimedia/OpenLP/README b/multimedia/OpenLP/README
new file mode 100644
index 0000000000..bd84291889
--- /dev/null
+++ b/multimedia/OpenLP/README
@@ -0,0 +1,15 @@
+OpenLP stands for “Open Lyrics Projection” and is presentation software
+developed for churches to provide a single easy to use interface for the
+projection needs of a typical worship service.
+First created in 2004, it has steadily grown in features and maturity such
+that it is now a mainstay in hundreds of churches around the world.
+
+OpenLP has searchable databases of songs and Bible verses allowing them to be
+projected instantly or saved in a pre-prepared order of service file. Themes
+allow for a variety of presentation options and allow you to add attractive
+visuals to enhance your presentations. PowerPoint and OpenOffice presentations,
+videos and audio files can be run from within the program removing the need
+to switch between different programs. Alert messages can be displayed so the
+nursery or car park stewards can notify the congregation easily.
+Remote capability allows the worship leader to change songs, or for alert
+messages to be sent from anywhere on the network, even via smart phone/tablet.
diff --git a/multimedia/OpenLP/doinst.sh b/multimedia/OpenLP/doinst.sh
new file mode 100644
index 0000000000..9a8ded3c60
--- /dev/null
+++ b/multimedia/OpenLP/doinst.sh
@@ -0,0 +1,7 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
diff --git a/multimedia/OpenLP/slack-desc b/multimedia/OpenLP/slack-desc
new file mode 100644
index 0000000000..48c7666877
--- /dev/null
+++ b/multimedia/OpenLP/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+OpenLP: OpenLP (Open Source Worship Presentation)
+OpenLP:
+OpenLP: OpenLP stands for “Open Lyrics Projection” and is presentation
+OpenLP: software developed or churches to provide a single easy to use
+OpenLP: nterface for the projection needs of a typical worship service.
+OpenLP: First created in 2004, it has steadily grown in features and maturity
+OpenLP: that it is now a mainstay in hundreds of churches around the world.
+OpenLP:
+OpenLP: Homepage: http://openlp.org/
+OpenLP:
+OpenLP: