summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author Minime2013-06-05 18:03:11 +0200
committer dsomero2013-06-05 18:03:11 +0200
commitcfe57a13e4f2c1f5675e73f1be72dad0ab44cb23 (patch)
treef7ebc38e684bce676f36205286e94384d4918978 /multimedia
parent801ba30e341ad8a7e662b45a29ec543a9f207499 (diff)
downloadslackbuilds-cfe57a13e4f2c1f5675e73f1be72dad0ab44cb23.tar.gz
multimedia/spotify: Updated for version 0.9.0.133.gd18ed58.259.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/spotify/README4
-rw-r--r--multimedia/spotify/slack-desc12
-rw-r--r--multimedia/spotify/spotify3
-rw-r--r--multimedia/spotify/spotify.SlackBuild36
-rw-r--r--multimedia/spotify/spotify.desktop11
-rw-r--r--multimedia/spotify/spotify.info10
6 files changed, 46 insertions, 30 deletions
diff --git a/multimedia/spotify/README b/multimedia/spotify/README
index 5a93310207..f8ca3b50b9 100644
--- a/multimedia/spotify/README
+++ b/multimedia/spotify/README
@@ -1,3 +1 @@
-You need to be Premium User to login and be able to listen to music
-from this application, also note this software might not run on AMD
-CPU hardware.
+Spotify is a social music player.
diff --git a/multimedia/spotify/slack-desc b/multimedia/spotify/slack-desc
index b7c1defce1..6d00a5a3ed 100644
--- a/multimedia/spotify/slack-desc
+++ b/multimedia/spotify/slack-desc
@@ -1,9 +1,9 @@
- HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
spotify: Spotify (digital music service)
diff --git a/multimedia/spotify/spotify b/multimedia/spotify/spotify
deleted file mode 100644
index 4057104668..0000000000
--- a/multimedia/spotify/spotify
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-LD_LIBRARY_PATH="/usr/share/spotify/" /usr/share/spotify/spotify $@
diff --git a/multimedia/spotify/spotify.SlackBuild b/multimedia/spotify/spotify.SlackBuild
index 8b98fa63da..1e51b85c75 100644
--- a/multimedia/spotify/spotify.SlackBuild
+++ b/multimedia/spotify/spotify.SlackBuild
@@ -2,9 +2,10 @@
#
# Slackware build script for spotify
-# Copyright 2011-2012 Minime
+# Copyright 2011-2013 Minime
# All rights reserved.
-#
+# Updated for 0.9.0.133.gd18ed58.259 by Klaatu @member.fsf.org
+
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
@@ -23,7 +24,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=spotify
-VERSION=0.8.4.103.g9cb177b.260
+VERSION=0.9.0.133.gd18ed58.259
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -47,18 +48,27 @@ ar -p $CWD/${PRGNAM}-client_${VERSION}-1_${DEBARCH}.deb data.tar.gz | tar zxv
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
-# Replace the symlink with our wrapper.
-rm $PKG/usr/bin/spotify
-install -m0755 -oroot -groot $CWD/spotify $PKG/usr/bin/spotify
-
# Symlinks to fix lib naming issue.
-cd $PKG/usr/share/spotify/
-ln -s /usr/lib$LIBDIRSUFFIX/libnss3.so libnss3.so.1d
-ln -s /usr/lib$LIBDIRSUFFIX/libnssutil3.so libnssutil3.so.1d
-ln -s /usr/lib$LIBDIRSUFFIX/libsmime3.so libsmime3.so.1d
-ln -s /usr/lib$LIBDIRSUFFIX/libplc4.so libplc4.so.0d
-ln -s /usr/lib$LIBDIRSUFFIX/libnspr4.so libnspr4.so.0d
+ln -sf /usr/lib${LIBDIRSUFFIX}/libnspr4.so $PKG/opt/spotify/spotify-client/libnspr4.so.0d
+ln -sf /usr/lib${LIBDIRSUFFIX}/libnss3.so $PKG/opt/spotify/spotify-client/libnss3.so.1d
+ln -sf /usr/lib${LIBDIRSUFFIX}/libnssutil3.so $PKG/opt/spotify/spotify-client/libnssutil3.so.1d
+ln -sf /usr/lib${LIBDIRSUFFIX}/libplc4.so $PKG/opt/spotify/spotify-client/libplc4.so.0d
+ln -sf /usr/lib${LIBDIRSUFFIX}/libplds4.so $PKG/opt/spotify/spotify-client/libplds4.so.0d
+ln -sf /usr/lib${LIBDIRSUFFIX}/libsmime3.so $PKG/opt/spotify/spotify-client/libsmime3.so.1d
+ln -sf /usr/lib${LIBDIRSUFFIX}/libssl3.so $PKG/opt/spotify/spotify-client/libssl3.so.1d
+ln -sf /usr/lib${LIBDIRSUFFIX}/libssl.so.10 $PKG/opt/spotify/spotify-client/libssl.so.0.9.8
+ln -sf /usr/lib${LIBDIRSUFFIX}/libcrypto.so.10 $PKG/opt/spotify/spotify-client/libcrypto.so.0.9.8
+
+# Stole a sed command
+# from github.com/xhochy/gentoo-overlay/blob/master/media-sound/spotify/spotify-0.8.8.323.ebuild
+sed -i \
+ -e 's/\(lib\(ssl\|crypto\).so\).0.9.8/\1.1.0.0/g' \
+ $PKG/opt/spotify/spotify-client/spotify || exit 1
+
+rm $PKG/opt/spotify/spotify-client/spotify.desktop
+mkdir -p $PKG/usr/share/applications/
+cat $CWD/spotify.desktop > $PKG/usr/share/applications/spotify.desktop
mv $PKG/usr/share/doc $PKG/usr
mv $PKG/usr/doc/$PRGNAM-client $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/multimedia/spotify/spotify.desktop b/multimedia/spotify/spotify.desktop
new file mode 100644
index 0000000000..8b5510169b
--- /dev/null
+++ b/multimedia/spotify/spotify.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Name=Spotify
+GenericName=Music Player
+Comment=Listen to music using Spotify
+Icon=/opt/spotify/spotify-client/Icons/spotify-linux-128.png
+Exec=spotify %U
+TryExec=spotify
+Terminal=false
+Type=Application
+Categories=Qt;Audio;Player;AudioVideo;
+MimeType=x-scheme-handler/spotify;
diff --git a/multimedia/spotify/spotify.info b/multimedia/spotify/spotify.info
index 7d0dbad135..e0eb53a238 100644
--- a/multimedia/spotify/spotify.info
+++ b/multimedia/spotify/spotify.info
@@ -1,10 +1,10 @@
PRGNAM="spotify"
-VERSION="0.8.4.103.g9cb177b.260"
+VERSION="0.9.0.133.gd18ed58.259"
HOMEPAGE="http://www.spotify.com"
-DOWNLOAD="http://repository.spotify.com/pool/non-free/s/spotify/spotify-client_0.8.4.103.g9cb177b.260-1_i386.deb"
-MD5SUM="0d87b47e356b308b56399ceabe8bd6c8"
-DOWNLOAD_x86_64="http://repository.spotify.com/pool/non-free/s/spotify/spotify-client_0.8.4.103.g9cb177b.260-1_amd64.deb"
-MD5SUM_x86_64="d85ef9a3e612510b8565834df66eb47e"
+DOWNLOAD="http://repository.spotify.com/pool/non-free/s/spotify/spotify-client_0.9.0.133.gd18ed58.259-1_i386.deb"
+MD5SUM="52d3bf6176a5060e41fb497b3efddd13"
+DOWNLOAD_x86_64="http://repository.spotify.com/pool/non-free/s/spotify/spotify-client_0.9.0.133.gd18ed58.259-1_amd64.deb"
+MD5SUM_x86_64="2f1596a85ebb63e3590b88530b745078"
REQUIRES=""
MAINTAINER="Minime"
EMAIL="i_am_minime_2003@hotmail.com"