summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author B. Watson2011-07-17 18:57:32 +0200
committer Robby Workman2011-07-17 18:57:32 +0200
commitfb0fb8df54bd2833fce97454b7c31c2da16f8015 (patch)
tree70ce6344f030d8c70f9907051253b5dff8224223 /multimedia
parent03afa910a80f51c377a24ac4464fc81fef4f86aa (diff)
downloadslackbuilds-fb0fb8df54bd2833fce97454b7c31c2da16f8015.tar.gz
multimedia/grip: Removed (replaced by audio/grip2)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/grip/README14
-rw-r--r--multimedia/grip/doinst.sh3
-rw-r--r--multimedia/grip/dot.grip.sample55
-rw-r--r--multimedia/grip/grip.SlackBuild91
-rw-r--r--multimedia/grip/grip.desktop7
-rw-r--r--multimedia/grip/grip.info10
-rw-r--r--multimedia/grip/grip2-nptl.diff12
-rw-r--r--multimedia/grip/slack-desc19
-rw-r--r--multimedia/grip/system_cdparanoia_libs.diff44
9 files changed, 0 insertions, 255 deletions
diff --git a/multimedia/grip/README b/multimedia/grip/README
deleted file mode 100644
index 8417f35c29..0000000000
--- a/multimedia/grip/README
+++ /dev/null
@@ -1,14 +0,0 @@
-Grip is a gtk-based cd-player and cd-ripper. It has the ripping
-capabilities of cdparanoia builtin, but can also use external rippers
-(such as cdda2wav).
-
-This is an older version of Grip that does not require GNOME.
-
-Although a .desktop file is included for KDE menu integration, this
-package is mainly intended for non-KDE environments (since KDE includes
-its own CD-ripping facilities, this package would be redundant anyway).
-
-Before running grip for the first time, you may want to copy the file
-"/usr/doc/grip-2.96/dot.grip.sample" to "$HOME/.grip". This sets the
-default encoder to oggenc, and puts the track number at the front of
-each output filename.
diff --git a/multimedia/grip/doinst.sh b/multimedia/grip/doinst.sh
deleted file mode 100644
index 3857649f50..0000000000
--- a/multimedia/grip/doinst.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications &> /dev/null
-fi
diff --git a/multimedia/grip/dot.grip.sample b/multimedia/grip/dot.grip.sample
deleted file mode 100644
index 4daca9a89a..0000000000
--- a/multimedia/grip/dot.grip.sample
+++ /dev/null
@@ -1,55 +0,0 @@
-GRIP 1
-ripexename /usr/bin/cdparanoia
-ripcmdline -d %c %t:[.%b]-%t:[.%e] %f
-wav_filter_cmd
-mp3exename /usr/bin/oggenc
-mp3cmdline -o %o -a "%A" -l "%d" -t "%n" %f
-dbserver freedb.freedb.org
-ripfileformat ~/mp3/%a/%d/%n.wav
-mp3fileformat ~/mp3/%a/%d/%n.ogg
-m3ufileformat ~/mp3/%a-%d.m3u
-delete_wavs 1
-add_m3u 1
-rel_m3u 1
-add_to_db 0
-outputdir
-use_proxy 0
-proxy_name
-proxy_port 8000
-cdupdate
-user_email nobody@example.com
-ripnice 0
-mp3nice 0
-doid3 1
-max_wavs 99
-auto_rip 0
-eject_after_rip 0
-eject_delay 0
-beep_after_rip 0
-faulty_eject 0
-use_proxy_env 0
-db_cgi ~cddb/cddb.cgi
-cddb_submit_email freedb-submit@freedb.org
-dbserver2
-db2_cgi ~cddb/cddb.cgi
-no_interrupt 0
-stop_first 0
-play_first 1
-automatic_cddb 1
-automatic_reshuffle 1
-no_lower_case 0
-no_underscore 0
-allow_high_bits 0
-allow_these_chars
-keep_min_size 1
-num_cpu 1
-kbits_per_sec 128
-selected_encoder 6
-selected_ripper 0
-disable_paranoia 0
-disable_extra_paranoia 0
-disable_scratch_detect 0
-disable_scratch_repair 0
-play_mode 0
-playloop 1
-volume 255
diff --git a/multimedia/grip/grip.SlackBuild b/multimedia/grip/grip.SlackBuild
deleted file mode 100644
index 6794ceff30..0000000000
--- a/multimedia/grip/grip.SlackBuild
+++ /dev/null
@@ -1,91 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for grip
-
-# Written by B. Watson (yalhcru@gmail.com)
-
-PRGNAM=grip
-VERSION=${VERSION:-2.96}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-# Automatically determine the architecture we're building on:
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tgz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-chmod -R a-s,u+w,go+r-w .
-
-# Slack 12.2 and up keeps cdda headers in /usr/include/cdda, 12.1 has them
-# in /usr/include itself. Be adaptable.
-if [ -r /usr/include/cdda/cdda_interface.h ]; then
- SLKCFLAGS="$SLKCFLAGS -I/usr/include/cdda"
-fi
-
-# Patch to use system-installed cdparanoia libs:
-patch -p1 --verbose < $CWD/system_cdparanoia_libs.diff
-
-# Patch to fix a compile issue with threads (probably came from gentoo):
-patch -p1 --verbose < $CWD/grip2-nptl.diff
-
-# The Makefile ignores any CFLAGS we pass in, so:
-perl -i.bak -pe 's,(CFLAGS\s*=\s*),$1 '"$SLKCFLAGS"' ,' Makefile
-
-make
-
-# DESTDIR not supported.
-make install PREFIX=$PKG/usr
-
-strip --strip-unneeded $PKG/usr/bin/*
-
-rm -f $PKG/usr/man/man1/gcd.1
-gzip $PKG/usr/man/man1/$PRGNAM.1
-( cd $PKG/usr/man/man1 && ln -s $PRGNAM.1.gz gcd.1.gz )
-
-# Why does it create an empty usr/lib dir?
-rm -rf $PKG/usr/lib
-
-mkdir -p $PKG/usr/share/{applications,pixmaps}
-cp $CWD/grip.desktop $PKG/usr/share/applications
-cp pixmaps/grip.xpm $PKG/usr/share/pixmaps
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- $CWD/dot.grip.sample CHANGES CREDITS LICENSE README TODO \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-chown -R root:root $PKG/usr/doc ; chmod 0644 $PKG/usr/doc/$PRGNAM-$VERSION/*
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/multimedia/grip/grip.desktop b/multimedia/grip/grip.desktop
deleted file mode 100644
index 168f92fa31..0000000000
--- a/multimedia/grip/grip.desktop
+++ /dev/null
@@ -1,7 +0,0 @@
-[Desktop Entry]
-Name=Grip
-Exec=grip
-Type=Application
-Icon=grip
-GenericName=Grip CD Ripper
-Categories=AudioVideo;Audio;
diff --git a/multimedia/grip/grip.info b/multimedia/grip/grip.info
deleted file mode 100644
index ecae43daf8..0000000000
--- a/multimedia/grip/grip.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="grip"
-VERSION="2.96"
-HOMEPAGE="http://nostatic.org/grip/"
-DOWNLOAD="http://downloads.sourceforge.net/grip/grip-2.96.tgz"
-MD5SUM="29d03b2874c5cb60096ac3051fbbc4e3"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-MAINTAINER="B. Watson"
-EMAIL="yalhcru@gmail.com"
-APPROVED="rworkman"
diff --git a/multimedia/grip/grip2-nptl.diff b/multimedia/grip/grip2-nptl.diff
deleted file mode 100644
index 36968fc3fd..0000000000
--- a/multimedia/grip/grip2-nptl.diff
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur grip-2.93.orig/grip.c grip-2.93/grip.c
---- grip-2.93.orig/grip.c 2007-04-19 01:15:23.000000000 -0400
-+++ grip-2.93/grip.c 2007-04-19 01:34:39.000000000 -0400
-@@ -1637,7 +1637,7 @@
- #if defined(SOLARIS) || defined(__FreeBSD__)
- pthread_exit(&status);
- #else
-- pthread_kill_other_threads_np();
-+ /* pthread_kill_other_threads_np(); */
- #endif
- Debug("Aborted\n");
- looking_up=FALSE;
diff --git a/multimedia/grip/slack-desc b/multimedia/grip/slack-desc
deleted file mode 100644
index 82661ed432..0000000000
--- a/multimedia/grip/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|'
-# on the right side marks the last column you can put a character in. You must
-# make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-grip: grip (graphical CD player and ripper)
-grip:
-grip: Grip is a gtk-based cd-player and cd-ripper. It has the ripping
-grip: capabilities of cdparanoia builtin, but can also use external
-grip: rippers (such as cdda2wav).
-grip:
-grip: This is an older version of Grip that does not require GNOME.
-grip:
-grip:
-grip:
-grip:
diff --git a/multimedia/grip/system_cdparanoia_libs.diff b/multimedia/grip/system_cdparanoia_libs.diff
deleted file mode 100644
index 7656af8107..0000000000
--- a/multimedia/grip/system_cdparanoia_libs.diff
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -Naur grip-2.96.orig/Makefile grip-2.96/Makefile
---- grip-2.96.orig/Makefile 2001-07-16 12:15:32.000000000 -0400
-+++ grip-2.96/Makefile 2009-02-05 00:38:28.000000000 -0500
-@@ -28,8 +28,8 @@
- ifeq ($(OS), FreeBSD)
- LIBS+= -pthread
- endif
--PARLIBS= cdparanoia/interface/libcdda_interface.a \
-- cdparanoia/paranoia/libcdda_paranoia.a
-+PARLIBS= -lcdda_interface \
-+ -lcdda_paranoia
-
- # This is needed for "make install"
- OWNER = root
-diff -Naur grip-2.96.orig/cdpar.c grip-2.96/cdpar.c
---- grip-2.96.orig/cdpar.c 2001-07-16 12:15:32.000000000 -0400
-+++ grip-2.96/cdpar.c 2009-02-05 00:39:02.000000000 -0500
-@@ -36,9 +36,9 @@
- #define size16 short
- #define size32 int
-
--#include "cdparanoia/interface/cdda_interface.h"
--#include "cdparanoia/paranoia/cdda_paranoia.h"
--#include "cdparanoia/utils.h"
-+#include <cdda_interface.h>
-+#include <cdda_paranoia.h>
-+#include <utils.h>
-
- static void PutNum(long num,int f,int endianness,int bytes);
- static void WriteWav(int f,long bytes);
-diff -Naur grip-2.96.orig/grip.c grip-2.96/grip.c
---- grip-2.96.orig/grip.c 2001-07-16 12:15:32.000000000 -0400
-+++ grip-2.96/grip.c 2009-02-05 00:42:26.000000000 -0500
-@@ -57,8 +57,8 @@
- #ifdef CDPAR
- #define size16 short
- #define size32 int
--#include "cdparanoia/interface/cdda_interface.h"
--#include "cdparanoia/paranoia/cdda_paranoia.h"
-+#include <cdda_interface.h>
-+#include <cdda_paranoia.h>
- #endif
-
- void ShutDownCB(void);