summaryrefslogtreecommitdiffstats
path: root/multimedia
diff options
context:
space:
mode:
author vvoody2011-07-08 19:19:35 +0200
committer Niels Horn2011-07-15 00:50:56 +0200
commitef6396109b755d1b78f79e117ea55037ccb77d09 (patch)
treec827b6e3bea49be047fa91cdaaca61e956739eb0 /multimedia
parentb49ca26f7b548c3c56f889d9fac4eddc07367454 (diff)
downloadslackbuilds-ef6396109b755d1b78f79e117ea55037ccb77d09.tar.gz
multimedia/mimms: Added (mms stream downloader)
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mimms/README3
-rw-r--r--multimedia/mimms/mimms.SlackBuild56
-rw-r--r--multimedia/mimms/mimms.info10
-rw-r--r--multimedia/mimms/slack-desc19
4 files changed, 88 insertions, 0 deletions
diff --git a/multimedia/mimms/README b/multimedia/mimms/README
new file mode 100644
index 0000000000..11877bee81
--- /dev/null
+++ b/multimedia/mimms/README
@@ -0,0 +1,3 @@
+mimms is an mms stream downloader that uses libmms.
+
+This requires libmms.
diff --git a/multimedia/mimms/mimms.SlackBuild b/multimedia/mimms/mimms.SlackBuild
new file mode 100644
index 0000000000..1370d81384
--- /dev/null
+++ b/multimedia/mimms/mimms.SlackBuild
@@ -0,0 +1,56 @@
+#!/bin/sh
+
+# Slackware build script for mimms
+
+# Written by vvoody <ydoovv@gmail.com>
+
+PRGNAM=mimms
+VERSION=${VERSION:-3.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Fix location of man pages
+sed -i 's|share/man/|man/|g' setup.py
+
+python setup.py install --prefix=/usr --root=$PKG
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING NEWS README teststreams.list $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/multimedia/mimms/mimms.info b/multimedia/mimms/mimms.info
new file mode 100644
index 0000000000..f4c2dc1704
--- /dev/null
+++ b/multimedia/mimms/mimms.info
@@ -0,0 +1,10 @@
+PRGNAM="mimms"
+VERSION="3.2"
+HOMEPAGE="http://savannah.nongnu.org/projects/mimms/"
+DOWNLOAD="http://launchpad.net/mimms/trunk/3.2/+download/mimms-3.2.tar.bz2"
+MD5SUM="819104b7364f6d300d4327d7b01058ae"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="vvoody"
+EMAIL="ydoovv@gmail.com"
+APPROVED="Niels Horn"
diff --git a/multimedia/mimms/slack-desc b/multimedia/mimms/slack-desc
new file mode 100644
index 0000000000..fe7e766092
--- /dev/null
+++ b/multimedia/mimms/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+mimms: mimms (an mms stream downloader)
+mimms:
+mimms: mimms is a program designed to allow you to download streams using the
+mimms: MMS protocol and save them to your computer.
+mimms:
+mimms: The mimms 3.x series is implemented entirely in python.
+mimms:
+mimms:
+mimms:
+mimms:
+mimms: