summaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
author Larry Hajali2018-09-03 20:22:39 +0200
committer Willy Sudiarto Raharjo2018-09-08 03:37:52 +0200
commitc8d0c2665d7832b25942ee0c3f7a7fb755b0b81e (patch)
tree87a0b52f62e899185b6b24671747744fa395d30d /misc
parent03a3d6f6e53291db030cae063ad4bf339d11a7de (diff)
downloadslackbuilds-c8d0c2665d7832b25942ee0c3f7a7fb755b0b81e.tar.gz
misc/subsurface: Updated for version 4.8.1
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com>
Diffstat (limited to 'misc')
-rw-r--r--misc/subsurface/subsurface.SlackBuild45
-rw-r--r--misc/subsurface/subsurface.info14
2 files changed, 22 insertions, 37 deletions
diff --git a/misc/subsurface/subsurface.SlackBuild b/misc/subsurface/subsurface.SlackBuild
index 23b4daa89e..79bf2c8241 100644
--- a/misc/subsurface/subsurface.SlackBuild
+++ b/misc/subsurface/subsurface.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for subsurface
-# Copyright 2014-2017 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2014-2018 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,8 @@
PRGNAM=subsurface
SRCNAM=Subsurface
-VERSION=${VERSION:-4.6.4}
+VERSION=${VERSION:-4.8.1}
+MD5LONG=${MD5LONG:-54a357f9590d9cf011bf1713589f66bad65e00eb}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -64,7 +65,7 @@ rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tgz
cd $SRCNAM-$VERSION
tar xvf $CWD/libdivecomputer-$PRGNAM-branch-$VERSION.tgz
-tar xvf $CWD/marble-$PRGNAM-branch-$VERSION.tgz
+tar xvf $CWD/googlemaps-$MD5LONG.tar.gz
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -80,6 +81,9 @@ cat /usr/include/Grantlee5/grantlee_templates.h | \
sed -e 's|grantlee/|Grantlee5/grantlee/|'\
> grantlee_templates_local.h
+# Fix the location detection of googlemaps
+sed -i "s|../install-root|googlemaps-$MD5LONG|" CMakeLists.txt
+
# We already have packages for libdivecomputer and marble on the system.
# Subsurface requires newer (custom) packages then what is currently available,
# so we're going to compile them into the Subsurface package.
@@ -102,26 +106,13 @@ make
make install DESTDIR="$PWD/.."
cd -
-mkdir -p marble-$PRGNAM-branch-$VERSION/build
-cd marble-$PRGNAM-branch-$VERSION/build
- cmake -G "Unix Makefiles" \
- -DCMAKE_INSTALL_PREFIX:PATH="/usr" \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS -std=c++11" \
- -DQT5BUILD:BOOL=ON \
- -DQTONLY:BOOL=TRUE \
- -DBUILD_MARBLE_APPS:BOOL=OFF \
- -DBUILD_MARBLE_EXAMPLES:BOOL=OFF \
- -DBUILD_MARBLE_TESTS:BOOL=OFF \
- -DBUILD_MARBLE_TOOLS:BOOL=OFF \
- -DWITH_DESIGNER_PLUGIN:BOOL=OFF \
- -DBUILD_TESTING:BOOL=OFF \
- -DBUILD_WITH_DBUS:BOOL=OFF \
- -DLIB_SUFFIX:STRING="$LIBDIRSUFFIX" \
- -DCMAKE_BUILD_TYPE=Release ..
+# Build qt5 locations googlemaps plugin
+cd googlemaps-$MD5LONG
+qmake-qt5 QMAKE_CFLAGS+="$SLKCFLAGS" QMAKE_CXXLAGS+="$SLKCFLAGS" \
+ -o Makefile googlemaps.pro
- make VERBOSE=1
- make -C src/lib/marble install DESTDIR=$PKG
+make
+make install INSTALL_ROOT=$PKG
cd -
# Build subsurface with libftdi support. Default is no.
@@ -142,13 +133,11 @@ mkdir build
cd build
cmake -G "Unix Makefiles" \
-DCMAKE_INSTALL_PREFIX:PATH="/usr" \
- -DUSE_LIBGIT23_API:BOOL=ON \
-DFTDISUPPORT:BOOL="$FTDISUPPORT" \
-DUSE_WEBENGINE:BOOL="$QWEBSUPPORT" \
+ -DMAKE_TESTS:BOOL=OFF \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DMARBLE_LIBRARIES="$PKG/usr/lib${LIBDIRSUFFIX}/libssrfmarblewidget.so" \
- -DMARBLE_INCLUDE_DIR="$PKG/usr/include" \
-DLIBDIVECOMPUTER_INCLUDE_DIR="../usr/include" \
-DLIBDIVECOMPUTER_LIBRARIES="../usr/lib${LIBDIRSUFFIX}/libdivecomputer.a" \
-DCMAKE_BUILD_TYPE=Release ..
@@ -160,12 +149,8 @@ cd -
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-# Remove unneeded files/directories.
-rm -rf $PKG/usr/include/marble
-find $PKG -type d -empty -delete
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a gpl-2.0.txt INSTALL README SupportedDivecomputers.* TODO.CCR \
+cp -a gpl-2.0.txt INSTALL README.md SupportedDivecomputers.* TODO.CCR \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/misc/subsurface/subsurface.info b/misc/subsurface/subsurface.info
index 52986fa702..3310b7ee36 100644
--- a/misc/subsurface/subsurface.info
+++ b/misc/subsurface/subsurface.info
@@ -1,12 +1,12 @@
PRGNAM="subsurface"
-VERSION="4.6.4"
+VERSION="4.8.1"
HOMEPAGE="http://subsurface.hohndel.org/"
-DOWNLOAD="http://subsurface.hohndel.org/downloads/Subsurface-4.6.4.tgz \
- http://subsurface-divelog.org/downloads/libdivecomputer-subsurface-branch-4.6.4.tgz \
- http://subsurface-divelog.org/downloads/marble-subsurface-branch-4.6.4.tgz"
-MD5SUM="9c679b43d23bce8facd98e0b41d8939a \
- 7bc7cfc1226d7b1f1c6812a664fa0cd1 \
- a696bba0d5b5eedaafe1ad67af99c8f0"
+DOWNLOAD="https://subsurface-divelog.org/downloads/Subsurface-4.8.1.tgz \
+ https://subsurface-divelog.org/downloads/libdivecomputer-subsurface-branch-4.8.1.tgz \
+ https://github.com/vladest/googlemaps/archive/54a357f/googlemaps-54a357f9590d9cf011bf1713589f66bad65e00eb.tar.gz"
+MD5SUM="e51d0273b169f6522c2d5f39ec79a83f \
+ 2ecc398a539a25aa50c1cd8a83abf921 \
+ 78770b2e3a46071f80c7747ed116a128"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="libgit2 grantlee-qt5 qt5-webkit"