summaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
author B. Watson2022-03-01 09:30:17 +0100
committer Willy Sudiarto Raharjo2022-03-01 13:35:42 +0100
commit5e4a18289f64a0a3b26a29ad6395d5e5a1902029 (patch)
treeac3bdecf2dba21b7cd1ba563c08c4a63242a6b36 /misc
parent7f58d4bfea8b9c78860679848736f56c5aaf2e87 (diff)
downloadslackbuilds-5e4a18289f64a0a3b26a29ad6395d5e5a1902029.tar.gz
misc/tegaki-zinnia-japanese: Fix build when TMP != /tmp.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'misc')
-rw-r--r--misc/tegaki-zinnia-japanese/tegaki-zinnia-japanese.SlackBuild47
1 files changed, 12 insertions, 35 deletions
diff --git a/misc/tegaki-zinnia-japanese/tegaki-zinnia-japanese.SlackBuild b/misc/tegaki-zinnia-japanese/tegaki-zinnia-japanese.SlackBuild
index cddd1609e6..ad911b181d 100644
--- a/misc/tegaki-zinnia-japanese/tegaki-zinnia-japanese.SlackBuild
+++ b/misc/tegaki-zinnia-japanese/tegaki-zinnia-japanese.SlackBuild
@@ -23,25 +23,22 @@
# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
# THE SOFTWARE.
+# 20220222 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - fix build when TMP is set to something other than /tmp (srsly?!)
+# - ARCH=noarch
+# - just copy the files where they go instead of screwing around with
+# sedding a Makefile so 'make install' works.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=tegaki-zinnia-japanese
VERSION=${VERSION:-0.3}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
+ARCH=noarch
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -51,20 +48,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -74,17 +57,11 @@ rm -rf $PRGNAM-$VERSION
unzip $CWD/$PRGNAM-$VERSION.zip
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+chmod 644 *
-#prepare
-sed -i 's|installpath=/usr/local/|installpath=/tmp/SBo/package-tegaki-zinnia-japanese/usr/|g' \
- ./Makefile
-make
-make install DESTDIR=$PKG
+DIR=$PKG/usr/share/tegaki/models/zinnia/
+mkdir -p $DIR
+cp -a handwriting-ja.m* $DIR
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING VERSION README.txt $PKG/usr/doc/$PRGNAM-$VERSION