summaryrefslogtreecommitdiffstats
path: root/misc
diff options
context:
space:
mode:
author Howard Pepper2010-06-28 16:44:56 +0200
committer dsomero2010-06-28 16:44:56 +0200
commitda4fec67cba27e3271fc8ff00f857a0ea855a2b9 (patch)
tree09eeeaa97fc19c3586a73578ee919cace895da0f /misc
parentd303b34c505d41e13a623dbf616fcafb7d7e0d33 (diff)
downloadslackbuilds-da4fec67cba27e3271fc8ff00f857a0ea855a2b9.tar.gz
misc/xlog: Added (ham radio contact logging program)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'misc')
-rw-r--r--misc/xlog/README8
-rw-r--r--misc/xlog/doinst.sh8
-rw-r--r--misc/xlog/slack-desc19
-rw-r--r--misc/xlog/xlog.SlackBuild101
-rw-r--r--misc/xlog/xlog.info10
5 files changed, 146 insertions, 0 deletions
diff --git a/misc/xlog/README b/misc/xlog/README
new file mode 100644
index 0000000000..3b5fbaff8f
--- /dev/null
+++ b/misc/xlog/README
@@ -0,0 +1,8 @@
+xlog (ham radio contact logging program)
+
+Xlog is an easy to use program for logging your ham radio contacts.
+Contacts are saved in a browsable list which can be edited.
+
+Homepage: http://savannah.nongnu.org/projects/Xlog
+
+Xlog requires hamlib for rig control.
diff --git a/misc/xlog/doinst.sh b/misc/xlog/doinst.sh
new file mode 100644
index 0000000000..e4e6459838
--- /dev/null
+++ b/misc/xlog/doinst.sh
@@ -0,0 +1,8 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
+
diff --git a/misc/xlog/slack-desc b/misc/xlog/slack-desc
new file mode 100644
index 0000000000..7eea7194dd
--- /dev/null
+++ b/misc/xlog/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+xlog: xlog (ham radio contact logging program)
+xlog:
+xlog: Xlog is an easy to use program for logging your ham radio contacts.
+xlog: Contacts are saved in a browsable list which can be edited.
+xlog:
+xlog: Homepage: http://savannah.nongnu.org/projects/Xlog
+xlog:
+xlog:
+xlog:
+xlog:
+xlog:
diff --git a/misc/xlog/xlog.SlackBuild b/misc/xlog/xlog.SlackBuild
new file mode 100644
index 0000000000..ad5772afab
--- /dev/null
+++ b/misc/xlog/xlog.SlackBuild
@@ -0,0 +1,101 @@
+#!/bin/sh
+
+# SlackBuild script for hamlib.
+#
+# Copyright 2010 Howard Pepper <h_pepper {at} bellsouth [dot] net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=xlog
+VERSION=2.0.3
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCFILES="AUTHORS COPYING ChangeLog INSTALL NEWS README"
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --mandir=/usr/man
+
+# Fix linking when --libdir=/usr/lib64
+sed -i \
+ -e '/RANLIB/s:$(libdir)/\(.*LIBNAME)\):$(libdir)/`basename \1`:g' \
+ src/Makefile || exit
+
+make
+make install DESTDIR=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/
+cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/misc/xlog/xlog.info b/misc/xlog/xlog.info
new file mode 100644
index 0000000000..527be51ebf
--- /dev/null
+++ b/misc/xlog/xlog.info
@@ -0,0 +1,10 @@
+PRGNAM="xlog"
+VERSION="2.0.3"
+HOMEPAGE="http://savannah.nongnu.org/projects/Xlog"
+DOWNLOAD="http://nongnu.askapache.com/xlog/xlog-2.0.3.tar.gz"
+MD5SUM="c583ac96e3f1c3873f1030d44333e747"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Howard Pepper"
+EMAIL="h_pepper <at> bellsouth {dot} net"
+APPROVED="dsomero"