summaryrefslogtreecommitdiffstats
path: root/misc/torrentinfo
diff options
context:
space:
mode:
author Erik Hanson2010-05-11 22:54:30 +0200
committer Robby Workman2010-05-11 22:54:30 +0200
commit59a87f34dc0d0b22c1514a2fdf2cb75ff10598e1 (patch)
tree26c13e83300c4f502b09a0ee718af414130e7fde /misc/torrentinfo
parent03500d8093627849c34deae5bcd298efd5cf8aa8 (diff)
downloadslackbuilds-59a87f34dc0d0b22c1514a2fdf2cb75ff10598e1.tar.gz
misc/torrentinfo: Added to 12.1 repository
Diffstat (limited to 'misc/torrentinfo')
-rw-r--r--misc/torrentinfo/README4
-rw-r--r--misc/torrentinfo/slack-desc19
-rw-r--r--misc/torrentinfo/torrentinfo.SlackBuild38
-rw-r--r--misc/torrentinfo/torrentinfo.info8
4 files changed, 69 insertions, 0 deletions
diff --git a/misc/torrentinfo/README b/misc/torrentinfo/README
new file mode 100644
index 0000000000..b7fc920a00
--- /dev/null
+++ b/misc/torrentinfo/README
@@ -0,0 +1,4 @@
+TorrentInfo is a command line script that parses .torrent files and displays
+the information contained within them. Currently, it can display a summary of
+the whole torrent, information on each file within the torrent, and a full
+hierarchical dump of the torrent file's contents.
diff --git a/misc/torrentinfo/slack-desc b/misc/torrentinfo/slack-desc
new file mode 100644
index 0000000000..ef5caf2700
--- /dev/null
+++ b/misc/torrentinfo/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler-------------------------------------------------|
+torrentinfo: TorrentInfo (command-line tool that parses .torrent files)
+torrentinfo:
+torrentinfo: TorrentInfo is a command line script that parses .torrent files
+torrentinfo: and displays the information contained within them. Currently,
+torrentinfo: it can display a summary of the whole torrent, information on
+torrentinfo: each file within the torrent, and a full hierarchical dump of
+torrentinfo: the torrent file's contents.
+torrentinfo:
+torrentinfo: http://vrai.net/project.php?project=torrentinfo
+torrentinfo:
+torrentinfo:
diff --git a/misc/torrentinfo/torrentinfo.SlackBuild b/misc/torrentinfo/torrentinfo.SlackBuild
new file mode 100644
index 0000000000..dbe73d7a27
--- /dev/null
+++ b/misc/torrentinfo/torrentinfo.SlackBuild
@@ -0,0 +1,38 @@
+#!/bin/sh
+
+# Slackware build script for TorrentInfo
+# Written by Erik Hanson erik@slackbuilds.org
+
+PRGNAM=torrentinfo
+VERSION=1.0.1
+ARCH=noarch
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -eu
+
+rm -rf $PKG
+mkdir -p $TMP $PKG
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/misc/torrentinfo/torrentinfo.info b/misc/torrentinfo/torrentinfo.info
new file mode 100644
index 0000000000..90e6112254
--- /dev/null
+++ b/misc/torrentinfo/torrentinfo.info
@@ -0,0 +1,8 @@
+PRGNAM="torrentinfo"
+VERSION="1.0.1"
+HOMEPAGE="http://vrai.net/project.php?project=torrentinfo"
+DOWNLOAD="http://vrai.net/files/software_projects/torrentinfo/torrentinfo-1.0.1.tar.bz2"
+MD5SUM="89c49aef71e312491646209e38ee4001"
+MAINTAINER="Erik Hanson"
+EMAIL="erik@slackbuilds.org"
+APPROVED="rworkman"