summaryrefslogtreecommitdiffstats
path: root/misc/grc
diff options
context:
space:
mode:
author Edinaldo P. Silva2017-02-12 21:48:37 +0100
committer David Spencer2017-02-13 00:49:25 +0100
commit81c6c48af31bac7eddc71dc99017937d9fe284ef (patch)
treec3b1ccbffa6190304d77b90e449e90cde8a8cda0 /misc/grc
parent34efa7ddf39effb4e4863c2ebe3ed1d36afeeda6 (diff)
downloadslackbuilds-81c6c48af31bac7eddc71dc99017937d9fe284ef.tar.gz
misc/grc: Amended SlackBuild.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'misc/grc')
-rw-r--r--misc/grc/README8
-rw-r--r--misc/grc/doinst.sh6
-rw-r--r--misc/grc/grc.SlackBuild29
3 files changed, 20 insertions, 23 deletions
diff --git a/misc/grc/README b/misc/grc/README
index 6f4aa1247f..08d4689320 100644
--- a/misc/grc/README
+++ b/misc/grc/README
@@ -5,9 +5,9 @@ acts as a filter, i.e. taking standard input, colourising it and
writing to standard output. grcat takes as a parameter the name of
configuration file.
-To use, add following lines into your ~/.bashrc, ~/.zshrc or in
+NOTE: to use, add following lines into your ~/.bashrc, ~/.zshrc or in
~/.config/fish/config.fish:
- [[ -s "/etc/profile.d/grc.bashrc" ]] && source /etc/profile.d/grc.bashrc
- [[ -s "/etc/profile.d/grc.zsh" ]] && source /etc/profile.d/grc.zsh
- [[ -s "/etc/profile.d/grc.fish" ]] && source /etc/profile.d/grc.fish
+[[ -s "/etc/profile.d/grc.bashrc" ]] && source /etc/profile.d/grc.bashrc
+[[ -s "/etc/profile.d/grc.zsh" ]] && source /etc/profile.d/grc.zsh
+[[ -s "/etc/profile.d/grc.fish" ]] && source /etc/profile.d/grc.fish
diff --git a/misc/grc/doinst.sh b/misc/grc/doinst.sh
index b8ee3107a8..7be6ad2127 100644
--- a/misc/grc/doinst.sh
+++ b/misc/grc/doinst.sh
@@ -12,6 +12,6 @@ config() {
}
config etc/grc.conf.new
-config etc/grc.bashrc.new
-config etc/grc.zsh.new
-config etc/grc.fish.new
+config etc/profile.d/grc.bashrc.new
+config etc/profile.d/grc.zsh.new
+config etc/profile.d/grc.fish.new
diff --git a/misc/grc/grc.SlackBuild b/misc/grc/grc.SlackBuild
index 9285f69709..02733b06b8 100644
--- a/misc/grc/grc.SlackBuild
+++ b/misc/grc/grc.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM="grc"
VERSION=${VERSION:-1.10}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -63,28 +63,25 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-install -d $PKG/etc/profile.d
-install -D -m644 grc.conf $PKG/etc/grc.conf.new
-install -D -m644 grc.bashrc $PKG/etc/profile.d/grc.bashrc.new
-install -D -m644 grc.zsh $PKG/etc/profile.d/grc.zsh.new
-install -D -m644 grc.fish $PKG/etc/profile.d/grc.fish.new
+./install.sh $PKG/usr $PKG
-install -d $PKG/usr/bin
-install -D -m755 {grc,grcat} $PKG/usr/bin
+mv $PKG/etc/grc.conf $PKG/etc/grc.conf.new
-install -d $PKG/usr/share/grc
-install -D -m644 conf.* $PKG/usr/share/grc
-
-install -d $PKG/usr/man/man1
-install -D -m644 {grc.1,grcat.1} $PKG/usr/man/man1
+# for Bash, Fish and Zsh.
+mv $PKG/etc/profile.d/grc.bashrc $PKG/etc/profile.d/grc.bashrc.new
+cp -a grc.zsh $PKG/etc/profile.d/grc.zsh.new
+cp -a grc.fish $PKG/etc/profile.d/grc.fish.new
+mv $PKG/usr/share/man $PKG/usr/man
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-install -d $PKG/usr/share/$PRGNAM
-install -D -m644 conf.* $PKG/usr/share/$PRGNAM
-
DOCS="contrib debian/changelog debian/copyright CREDITS INSTALL \
README.markdown Regexp.txt TODO"