summaryrefslogtreecommitdiffstats
path: root/misc/conkyforecast/conkyforecast.SlackBuild
diff options
context:
space:
mode:
author M.Dinslage2010-04-20 00:52:07 +0200
committer Heinz Wiesinger2010-05-15 10:38:30 +0200
commitd99d6aba3e181f287210b69c33cd96fa4507c6b0 (patch)
tree0a906ff581024edccb70c1bcd1575959c3ec10bf /misc/conkyforecast/conkyforecast.SlackBuild
parent50cf5d8ac663367bb8297bd5cc73c5d0da40efb8 (diff)
downloadslackbuilds-d99d6aba3e181f287210b69c33cd96fa4507c6b0.tar.gz
misc/conkyforecast Added (weather plugin for conky)
Diffstat (limited to 'misc/conkyforecast/conkyforecast.SlackBuild')
-rw-r--r--misc/conkyforecast/conkyforecast.SlackBuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/misc/conkyforecast/conkyforecast.SlackBuild b/misc/conkyforecast/conkyforecast.SlackBuild
new file mode 100644
index 0000000000..ea19a83dde
--- /dev/null
+++ b/misc/conkyforecast/conkyforecast.SlackBuild
@@ -0,0 +1,55 @@
+#!/bin/sh
+
+# Slackware build script for conkyforecast
+
+# Written by M.Dinslage (daedra1980@gmail.com)
+
+PRGNAM=conkyforecast
+VERSION=${VERSION:-2.09}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf src
+tar xvf $CWD/conkyforecast_2.09.tar.gz
+cd src
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Fix font path for slackware
+sed -i 's,/usr/share/fonts/truetype/conkyforecast,/usr/share/fonts/TTF,g' setup.py
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+# remove font .sfd files, they shouldn't be needed
+rm -r $PKG/usr/share/fonts/TTF/*.tar.gz
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS CHANGELOG COPYING README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}