summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author B. Watson2022-04-22 17:08:30 +0200
committer B. Watson2022-04-22 17:08:30 +0200
commit3708925e3f0ac234ae8505b71bb889e5a0522965 (patch)
tree534c9e88132eae8e8cfc422c47164d4e0861b018 /libraries
parentb39307e0c5552a7c8d0df7fd03c3d3113fcae493 (diff)
downloadslackbuilds-3708925e3f0ac234ae8505b71bb889e5a0522965.tar.gz
libraries/progressbar: Fix PRINT_PACKAGE_NAME.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/progressbar/progressbar.SlackBuild27
1 files changed, 14 insertions, 13 deletions
diff --git a/libraries/progressbar/progressbar.SlackBuild b/libraries/progressbar/progressbar.SlackBuild
index 54ee2c3e66..1840fa7067 100644
--- a/libraries/progressbar/progressbar.SlackBuild
+++ b/libraries/progressbar/progressbar.SlackBuild
@@ -5,6 +5,10 @@
# Written by Lionel Young <redtricycle@gmail.com>
# Based on http://slackbuilds.org/template.SlackBuild
+# 20220422 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - fix PRINT_PACKAGE_NAME.
+# - i486 => i586.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=progressbar
@@ -13,26 +17,23 @@ BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) export ARCH=i486 ;;
+ i?86) export ARCH=i586 ;;
arm*) export ARCH=arm ;;
*) export ARCH=$( uname -m ) ;;
esac
fi
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
set -e
rm -rf $PKG
@@ -44,12 +45,12 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ -exec chmod 644 {} \+
-python setup.py build || exit 1
-python setup.py install --root=$PKG || exit 1
+python setup.py build
+python setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \