summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Larry Hajali2020-01-26 21:03:23 +0100
committer Willy Sudiarto Raharjo2020-02-01 03:00:35 +0100
commitce225276535893662ec13e21aac058ed6de742ab (patch)
treeb8959750ee607feafa19810c98a6bc25930aa39c /libraries
parentff746b390580c04fb9b8b63220e943fbed05155f (diff)
downloadslackbuilds-ce225276535893662ec13e21aac058ed6de742ab.tar.gz
libraries/html5lib: Add python3 support
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/html5lib/html5lib.SlackBuild3
-rw-r--r--libraries/html5lib/html5lib.info2
2 files changed, 3 insertions, 2 deletions
diff --git a/libraries/html5lib/html5lib.SlackBuild b/libraries/html5lib/html5lib.SlackBuild
index 8195587882..60fb4d9aba 100644
--- a/libraries/html5lib/html5lib.SlackBuild
+++ b/libraries/html5lib/html5lib.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=html5lib
VERSION=${VERSION:-1.0.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -56,6 +56,7 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/libraries/html5lib/html5lib.info b/libraries/html5lib/html5lib.info
index 07cc7eabc8..b9f29a8b44 100644
--- a/libraries/html5lib/html5lib.info
+++ b/libraries/html5lib/html5lib.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://pypi.io/packages/source/h/html5lib/html5lib-1.0.1.tar.gz"
MD5SUM="942a0688d6bdf20d087c9805c40182ad"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="six python-webencodings"
+REQUIRES="six python3-six python-webencodings"
MAINTAINER="Larry Hajali"
EMAIL="larryhaja[at]gmail[dot]com"