summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Dominik Drobek2019-03-17 22:39:15 +0100
committer Willy Sudiarto Raharjo2019-03-20 14:45:59 +0100
commitb73cbb74f680c3074e76fb09aeac9dba374651be (patch)
tree6f68f58351239d013acc3f917420da578cc70779 /libraries
parent3647060904b229780b12ab484177c741eaaae6dd (diff)
downloadslackbuilds-b73cbb74f680c3074e76fb09aeac9dba374651be.tar.gz
python/GeoIP-Python: enable Python3
Also, move from "libraries" to "python" category. The latter did not exist at the time this SlackBuild was added to SBo. Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/GeoIP-Python/GeoIP-Python.SlackBuild90
-rw-r--r--libraries/GeoIP-Python/GeoIP-Python.info10
-rw-r--r--libraries/GeoIP-Python/README2
-rw-r--r--libraries/GeoIP-Python/slack-desc19
4 files changed, 0 insertions, 121 deletions
diff --git a/libraries/GeoIP-Python/GeoIP-Python.SlackBuild b/libraries/GeoIP-Python/GeoIP-Python.SlackBuild
deleted file mode 100644
index 46a797207b..0000000000
--- a/libraries/GeoIP-Python/GeoIP-Python.SlackBuild
+++ /dev/null
@@ -1,90 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for GeoIP-Python
-
-# Copyright Dominik Drobek <dominik.drobek (at) o2.pl>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=GeoIP-Python
-VERSION=${VERSION:-1.3.2}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-DISTNAME=GeoIP
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$DISTNAME-$VERSION.tar.gz
-mv $DISTNAME-$VERSION $PRGNAM-$VERSION
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- LICENSE README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/GeoIP-Python/GeoIP-Python.info b/libraries/GeoIP-Python/GeoIP-Python.info
deleted file mode 100644
index f4b7e21b3f..0000000000
--- a/libraries/GeoIP-Python/GeoIP-Python.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="GeoIP-Python"
-VERSION="1.3.2"
-HOMEPAGE="http://dev.maxmind.com/geoip/legacy/downloadable"
-DOWNLOAD="https://pypi.python.org/packages/f2/7b/a463b7c3df8ef4b9c92906da29ddc9e464d4045f00c475ad31cdb9a97aae/GeoIP-1.3.2.tar.gz"
-MD5SUM="6d1a82798b9f5f8448fca50296d974ba"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="GeoIP"
-MAINTAINER="Dominik Drobek"
-EMAIL="dominik.drobek@o2.pl"
diff --git a/libraries/GeoIP-Python/README b/libraries/GeoIP-Python/README
deleted file mode 100644
index bd19f393e3..0000000000
--- a/libraries/GeoIP-Python/README
+++ /dev/null
@@ -1,2 +0,0 @@
-This package provides an open source Python API for MaxMind's
-IP geolocation data and services.
diff --git a/libraries/GeoIP-Python/slack-desc b/libraries/GeoIP-Python/slack-desc
deleted file mode 100644
index 56bf82ffb5..0000000000
--- a/libraries/GeoIP-Python/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-GeoIP-Python: GeoIP-Python (GeoIP Python API)
-GeoIP-Python:
-GeoIP-Python: This package provides an open source Python API for MaxMind's
-GeoIP-Python: IP geolocation data and services.
-GeoIP-Python:
-GeoIP-Python:
-GeoIP-Python:
-GeoIP-Python:
-GeoIP-Python:
-GeoIP-Python:
-GeoIP-Python: