summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo2021-11-23 02:24:35 +0100
committer Willy Sudiarto Raharjo2021-11-23 02:24:35 +0100
commitbbd1142f0a70c2fb087cfbd7d4532aa03acb2784 (patch)
tree21689956277f0910aff872ac2d8a5a5d78d6395a /libraries
parenta487cc23e4417addd6a7914ee0071c6d7bcaf7ea (diff)
downloadslackbuilds-bbd1142f0a70c2fb087cfbd7d4532aa03acb2784.tar.gz
libraries/python3-PyYAML: Removed (Added to Slackware).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/python3-PyYAML/README5
-rw-r--r--libraries/python3-PyYAML/python3-PyYAML.SlackBuild98
-rw-r--r--libraries/python3-PyYAML/python3-PyYAML.info10
-rw-r--r--libraries/python3-PyYAML/slack-desc19
4 files changed, 0 insertions, 132 deletions
diff --git a/libraries/python3-PyYAML/README b/libraries/python3-PyYAML/README
deleted file mode 100644
index 2bede18e0f..0000000000
--- a/libraries/python3-PyYAML/README
+++ /dev/null
@@ -1,5 +0,0 @@
-pyyaml (YAML parser and emitter for Python)
-
-YAML is a data serialization format designed for human readability
-and interaction with scripting languages. PyYAML is a YAML parser and
-emitter for Python.
diff --git a/libraries/python3-PyYAML/python3-PyYAML.SlackBuild b/libraries/python3-PyYAML/python3-PyYAML.SlackBuild
deleted file mode 100644
index 2d0a5a631e..0000000000
--- a/libraries/python3-PyYAML/python3-PyYAML.SlackBuild
+++ /dev/null
@@ -1,98 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for python-PyYAML
-# Copyright 2010 David Woodfall <dave@slackbuilds.org>
-# Copyright 2015-2019 Jeremy Hansen <jebrhansen+SBo -at- gmail.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# Adapted for python3-PyYAML by Jeremy Hansen <jebrhansen+SBo -at- gmail.com>
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python3-PyYAML
-SRCNAM=PyYAML
-VERSION=${VERSION:-5.3.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/libraries/python3-PyYAML/python3-PyYAML.info b/libraries/python3-PyYAML/python3-PyYAML.info
deleted file mode 100644
index a46bb24e7d..0000000000
--- a/libraries/python3-PyYAML/python3-PyYAML.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python3-PyYAML"
-VERSION="5.3.1"
-HOMEPAGE="https://pyyaml.org/"
-DOWNLOAD="https://pyyaml.org/download/pyyaml/PyYAML-5.3.1.tar.gz"
-MD5SUM="d3590b85917362e837298e733321962b"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Jeremy Hansen"
-EMAIL="jebrhansen+SBo -at- gmail.com"
diff --git a/libraries/python3-PyYAML/slack-desc b/libraries/python3-PyYAML/slack-desc
deleted file mode 100644
index 11bd17600c..0000000000
--- a/libraries/python3-PyYAML/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python3-PyYAML: python3-PyYAML (YAML parser and emitter for Python)
-python3-PyYAML:
-python3-PyYAML: YAML is a data serialization format designed for human readability
-python3-PyYAML: and interaction with scripting languages. PyYAML is a YAML parser
-python3-PyYAML: and emitter for Python.
-python3-PyYAML:
-python3-PyYAML: Homepage: https://pyyaml.org/
-python3-PyYAML:
-python3-PyYAML: This builds the python3 version of PyYAML. It is safe to install this
-python3-PyYAML: on a system that has the SBo's PyYAML (python2) package installed.
-python3-PyYAML: