summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Larry Hajali2019-08-24 02:37:43 +0200
committer Willy Sudiarto Raharjo2019-08-24 02:37:43 +0200
commitf054c587164c52fe440c4d0e5f31bf08bc892db4 (patch)
tree0cdb4d54b02071bace37453a222761b62f5a9857 /libraries
parentf7390313b6fa0b071735c2ee83ea5efd191f8762 (diff)
downloadslackbuilds-f054c587164c52fe440c4d0e5f31bf08bc892db4.tar.gz
libraries/grpc: Added (High performance general RPC framework).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/grpc/README3
-rw-r--r--libraries/grpc/grpc-use-shell-loop-instead-makefile-function.patch25
-rw-r--r--libraries/grpc/grpc.SlackBuild117
-rw-r--r--libraries/grpc/grpc.info10
-rw-r--r--libraries/grpc/slack-desc19
5 files changed, 174 insertions, 0 deletions
diff --git a/libraries/grpc/README b/libraries/grpc/README
new file mode 100644
index 0000000000..dc9eef11b7
--- /dev/null
+++ b/libraries/grpc/README
@@ -0,0 +1,3 @@
+gRPC is a modern, open source, high-performance remote procedure call (RPC)
+framework that can run anywhere. gRPC enables client and server applications to
+communicate transparently, and simplifies the building of connected systems.
diff --git a/libraries/grpc/grpc-use-shell-loop-instead-makefile-function.patch b/libraries/grpc/grpc-use-shell-loop-instead-makefile-function.patch
new file mode 100644
index 0000000000..2d1c98fe1d
--- /dev/null
+++ b/libraries/grpc/grpc-use-shell-loop-instead-makefile-function.patch
@@ -0,0 +1,25 @@
+From fe221f7d6fcf04e296f3b8598f57abc9e3dea821 Mon Sep 17 00:00:00 2001
+From: Sergey Avseyev <sergey.avseyev@gmail.com>
+Date: Wed, 16 Jan 2019 20:00:40 +0300
+Subject: [PATCH 3/4] use shell loop instead makefile function
+
+this avoids failure when too long string passed to exec
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 2bdfa6395d..51614620af 100644
+--- a/Makefile
++++ b/Makefile
+@@ -2950,7 +2950,7 @@ install-headers_c:
+ install-headers_cxx:
+ $(E) "[INSTALL] Installing public C++ headers"
+ $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX), $(INSTALL) -d $(prefix)/$(dir $(h)) && ) exit 0 || exit 1
+- $(Q) $(foreach h, $(PUBLIC_HEADERS_CXX), $(INSTALL) $(h) $(prefix)/$(h) && ) exit 0 || exit 1
++ $(Q) for h in $(PUBLIC_HEADERS_CXX); do $(INSTALL) $$h $(prefix)/$$h; done || exit 1
+
+ install-static: install-static_c install-static_cxx
+
+--
+2.21.0
diff --git a/libraries/grpc/grpc.SlackBuild b/libraries/grpc/grpc.SlackBuild
new file mode 100644
index 0000000000..11bb6756b4
--- /dev/null
+++ b/libraries/grpc/grpc.SlackBuild
@@ -0,0 +1,117 @@
+#!/bin/sh
+
+# Slackware build script for grpc
+
+# Copyright 2019 Larry Hajali <larryhaja[at]gmail[dot]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+PRGNAM=grpc
+VERSION=${VERSION:-1.23.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Fix Makefile
+# Ref: https://github.com/grpc/grpc/issues/14844
+patch -p1 < $CWD/grpc-use-shell-loop-instead-makefile-function.patch
+
+sed -i 's|^prefix ?= .*|prefix ?= /usr|' Makefile
+sed -i "s|\$(prefix)/lib|\$(prefix)/lib${LIBDIRSUFFIX}|" Makefile
+sed -i "/libdir/s|/lib|/lib${LIBDIRSUFFIX}|" Makefile
+sed -i 's|^GTEST_LIB =.*||' Makefile
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+make shared plugins V=1
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+make install prefix=$PKG/usr V=1
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+make install-grpc-cli prefix=$PKG/usr V=1
+
+if $(python3 -c 'import Cython' 2>/dev/null); then
+ GRPC_PYTHON_BUILD_WITH_CYTHON=True \
+ GRPC_PYTHON_BUILD_SYSTEM_OPENSSL=True \
+ GRPC_PYTHON_BUILD_SYSTEM_ZLIB=True \
+ GRPC_PYTHON_BUILD_SYSTEM_CARES=True \
+ CFLAGS="$SLKCFLAGS" \
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+# Clean up
+find $PKG -type f -name '*.a' -exec rm -f {} \;
+find $PKG/usr/include -type f -exec chmod 0644 {} \;
+find $PKG/usr/share -type f -exec chmod 0644 {} \;
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS *.md LICENSE OWNERS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/grpc/grpc.info b/libraries/grpc/grpc.info
new file mode 100644
index 0000000000..f482f72ddc
--- /dev/null
+++ b/libraries/grpc/grpc.info
@@ -0,0 +1,10 @@
+PRGNAM="grpc"
+VERSION="1.23.0"
+HOMEPAGE="https://grpc.io/"
+DOWNLOAD="https://github.com/grpc/grpc/archive/v1.23.0/grpc-1.23.0.tar.gz"
+MD5SUM="e43bafaa73098dd07b6a3f96f6c85956"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="c-ares protobuf3 gflags"
+MAINTAINER="Larry Hajali"
+EMAIL="larryhaja[at]gmail[dot]com"
diff --git a/libraries/grpc/slack-desc b/libraries/grpc/slack-desc
new file mode 100644
index 0000000000..8241cc0d93
--- /dev/null
+++ b/libraries/grpc/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+grpc: grpc (High performance, open source, general RPC framework)
+grpc:
+grpc: gRPC is a modern, open source, high-performance remote procedure call
+grpc: (RPC) framework that can run anywhere. gRPC enables client and server
+grpc: applications to communicate transparently, and simplifies the
+grpc: building of connected systems.
+grpc:
+grpc: Homepage: https://grpc.io/
+grpc:
+grpc:
+grpc: