summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Yth - Arnaud2019-09-14 06:29:57 +0200
committer Willy Sudiarto Raharjo2019-09-14 06:29:57 +0200
commita762c0b6cbc67dc54f69271153f621f23aaa7634 (patch)
treeb5b5832e6ca0945fdf40825515c17da136d63521 /libraries
parent6113d4a75618f88e1ad6c011fb6c1180117a7c14 (diff)
downloadslackbuilds-a762c0b6cbc67dc54f69271153f621f23aaa7634.tar.gz
libraries/libcbor: Added (Schema-less binary data format).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/libcbor/README12
-rw-r--r--libraries/libcbor/libcbor.SlackBuild95
-rw-r--r--libraries/libcbor/libcbor.info10
-rw-r--r--libraries/libcbor/slack-desc19
4 files changed, 136 insertions, 0 deletions
diff --git a/libraries/libcbor/README b/libraries/libcbor/README
new file mode 100644
index 0000000000..08e84fa39b
--- /dev/null
+++ b/libraries/libcbor/README
@@ -0,0 +1,12 @@
+libcbor is a C library for parsing and generating CBOR, the general-purpose schema-less binary data format.
+
+Main features:
+ Complete RFC conformance
+ Robust C99 implementation
+ Layered architecture offers both control and convenience
+ Flexible memory management
+ No shared global state - threading friendly
+ Proper handling of UTF-8
+ Full support for streams & incremental processing
+ Extensive documentation and test suite
+ No runtime dependencies, small footprint
diff --git a/libraries/libcbor/libcbor.SlackBuild b/libraries/libcbor/libcbor.SlackBuild
new file mode 100644
index 0000000000..9af63b8ef9
--- /dev/null
+++ b/libraries/libcbor/libcbor.SlackBuild
@@ -0,0 +1,95 @@
+#!/bin/sh
+# Slackware build script for libcbor
+#
+# Yth | Pont-en-Royans, France | yth@ythogtha.org
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=libcbor
+VERSION=${VERSION:-0.5.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i 's/-flto//g' CMakeLists.txt
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCBOR_CUSTOM_ALLOC=ON ..
+ make VERBOSE=1
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+DOCS="CHANGELOG* LICENSE* README*"
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/libcbor/libcbor.info b/libraries/libcbor/libcbor.info
new file mode 100644
index 0000000000..9d598f3678
--- /dev/null
+++ b/libraries/libcbor/libcbor.info
@@ -0,0 +1,10 @@
+PRGNAM="libcbor"
+VERSION="0.5.0"
+HOMEPAGE="https://github.com/PJK/libcbor"
+DOWNLOAD="https://github.com/PJK/libcbor/archive/v0.5.0/libcbor-0.5.0.tar.gz"
+MD5SUM="801a17e95592b39beecb2406604f5ba3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/libraries/libcbor/slack-desc b/libraries/libcbor/slack-desc
new file mode 100644
index 0000000000..92654de5c2
--- /dev/null
+++ b/libraries/libcbor/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+libcbor: libcbor (Schema-less binary data format)
+libcbor:
+libcbor: libcbor is a C library for parsing and generating CBOR,
+libcbor: the general-purpose schema-less binary data format.
+libcbor:
+libcbor:
+libcbor:
+libcbor:
+libcbor:
+libcbor:
+libcbor: