summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Philip Lacroix2015-12-18 07:21:53 +0100
committer Willy Sudiarto Raharjo2015-12-19 01:23:01 +0100
commit70ce00b00311edc99ef5c453e44734a3fc058002 (patch)
tree9f79facd3934584b0952a5c1fbab90fe321afb3b /libraries
parentd52fd0dd8e34b82a49a0ffafcef8d59f30d138b7 (diff)
downloadslackbuilds-70ce00b00311edc99ef5c453e44734a3fc058002.tar.gz
libraries/CondConfigParser: Addec (Python library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/CondConfigParser/CondConfigParser.SlackBuild75
-rw-r--r--libraries/CondConfigParser/CondConfigParser.info10
-rw-r--r--libraries/CondConfigParser/README5
-rw-r--r--libraries/CondConfigParser/slack-desc19
4 files changed, 109 insertions, 0 deletions
diff --git a/libraries/CondConfigParser/CondConfigParser.SlackBuild b/libraries/CondConfigParser/CondConfigParser.SlackBuild
new file mode 100644
index 0000000000..00eb5f8844
--- /dev/null
+++ b/libraries/CondConfigParser/CondConfigParser.SlackBuild
@@ -0,0 +1,75 @@
+#!/bin/sh
+
+# Slackware build script for CondConfigParser
+
+# Copyright 2015 Philip Lacroix <slackph at posteo dot de>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=CondConfigParser
+VERSION=${VERSION:-1.0.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$PRGNAM}
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvjf $CWD/$PRGNAM-$VERSION.tar.bz2
+
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 \
+ -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
+ | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+
+# Install documentation.
+mkdir -p $PRGDOC
+cp -a AUTHORS COPYING* ChangeLog INSTALL.txt README.rst TODO $PRGDOC/
+cat $CWD/$PRGNAM.SlackBuild > $PRGDOC/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/CondConfigParser/CondConfigParser.info b/libraries/CondConfigParser/CondConfigParser.info
new file mode 100644
index 0000000000..75557ceea2
--- /dev/null
+++ b/libraries/CondConfigParser/CondConfigParser.info
@@ -0,0 +1,10 @@
+PRGNAM="CondConfigParser"
+VERSION="1.0.2"
+HOMEPAGE="http://people.via.ecp.fr/~flo/projects/CondConfigParser"
+DOWNLOAD="http://people.via.ecp.fr/~flo/projects/CondConfigParser/dist/1.0.2/CondConfigParser-1.0.2.tar.bz2"
+MD5SUM="4d8e6e31bc789aa9abd09e44e80166c0"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3 pysetuptools"
+MAINTAINER="Philip Lacroix"
+EMAIL="slackph at posteo dot de"
diff --git a/libraries/CondConfigParser/README b/libraries/CondConfigParser/README
new file mode 100644
index 0000000000..59e4e82277
--- /dev/null
+++ b/libraries/CondConfigParser/README
@@ -0,0 +1,5 @@
+CondConfigParser is a Python library designed to help developers of Python
+applications to parse configuration files. Compared to well-known modules such
+as ConfigParser and json, CondConfigParser allows the user to define conditions
+using boolean operators and specific sections in the configuration file, which
+are only applied when the corresponding condition is fulfilled.
diff --git a/libraries/CondConfigParser/slack-desc b/libraries/CondConfigParser/slack-desc
new file mode 100644
index 0000000000..f641450a7f
--- /dev/null
+++ b/libraries/CondConfigParser/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+CondConfigParser: CondConfigParser (Python library for parsing configuration files)
+CondConfigParser:
+CondConfigParser: CondConfigParser is a Python library designed to help developers of
+CondConfigParser: Python applications to parse configuration files. Compared to well-
+CondConfigParser: known modules such as ConfigParser and json, CondConfigParser allows
+CondConfigParser: the user to define conditions using boolean operators and specific
+CondConfigParser: sections in the configuration file, which are only applied when the
+CondConfigParser: corresponding condition is fulfilled.
+CondConfigParser:
+CondConfigParser: Homepage: http://people.via.ecp.fr/~flo/projects/CondConfigParser
+CondConfigParser: