summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Philip Lacroix2015-09-10 20:48:59 +0200
committer Willy Sudiarto Raharjo2015-09-10 20:48:59 +0200
commit519ea16abd4355c5e3ff98defcc7cb5cdeb66a47 (patch)
treebb78bbfecf10d835311e351b9004075d3223f552 /libraries
parent4e7c68052434879912d3eed66ac2e1c4db960df2 (diff)
downloadslackbuilds-519ea16abd4355c5e3ff98defcc7cb5cdeb66a47.tar.gz
libraries/pymdstat: Update EMAIL.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/pymdstat/pymdstat.SlackBuild20
-rw-r--r--libraries/pymdstat/pymdstat.info2
-rw-r--r--libraries/pymdstat/slack-desc2
3 files changed, 12 insertions, 12 deletions
diff --git a/libraries/pymdstat/pymdstat.SlackBuild b/libraries/pymdstat/pymdstat.SlackBuild
index 0971d96085..7f1b8562db 100644
--- a/libraries/pymdstat/pymdstat.SlackBuild
+++ b/libraries/pymdstat/pymdstat.SlackBuild
@@ -1,8 +1,8 @@
#!/bin/sh
-# Slackware build script for PyMDstat
+# Slackware build script for pymdstat
-# Copyright 2015 Philip Lacroix <philnx at posteo dot de>
+# Copyright 2015 Philip Lacroix <slackph at posteo dot de>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -47,8 +47,8 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-# The upstream tarball will be named differently, depending on the file
-# being downloaded manually (web browser) or with wget.
+# The upstream tarball will be named differently, depending on
+# the file being downloaded manually (web browser) or with wget.
if [ -e $CWD/v$VERSION.tar.gz ]; then
tar xvzf $CWD/v$VERSION.tar.gz
else
@@ -63,10 +63,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 \
-o -perm 400 \) -exec chmod 644 {} \;
-PRGUSR=$PKG/usr
-PRGSHR=$PKG/usr/share
-PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
-
python setup.py install --root=$PKG
# Python 3 support.
@@ -75,9 +71,13 @@ if $(python3 -c 'import sys' 2>/dev/null); then
fi
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
- | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null \
- || true
+ | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+PRGUSR=$PKG/usr
+PRGSHR=$PKG/usr/share
+PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+# Install documentation.
mkdir -p $PRGDOC
mv $PRGSHR/doc/$PRGNAM/* $PRGDOC/
rm -rf $PRGSHR
diff --git a/libraries/pymdstat/pymdstat.info b/libraries/pymdstat/pymdstat.info
index 739b544433..cb42b02d6d 100644
--- a/libraries/pymdstat/pymdstat.info
+++ b/libraries/pymdstat/pymdstat.info
@@ -7,4 +7,4 @@ DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="pysetuptools"
MAINTAINER="Philip Lacroix"
-EMAIL="philnx at posteo dot de"
+EMAIL="slackph at posteo dot de"
diff --git a/libraries/pymdstat/slack-desc b/libraries/pymdstat/slack-desc
index ab1c531328..819065ff8b 100644
--- a/libraries/pymdstat/slack-desc
+++ b/libraries/pymdstat/slack-desc
@@ -11,8 +11,8 @@ pymdstat:
pymdstat: PyMDstat is a pythonic library to parse /proc/mdstat, which shows a
pymdstat: snapshot of the kernel's RAID/md state.
pymdstat:
-pymdstat:
pymdstat: Homepage: https://github.com/nicolargo/pymdstat
+pymdstat:
pymdstat:
pymdstat:
pymdstat: