summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Kyle Guinn2014-01-25 03:35:26 +0100
committer Robby Workman2014-01-31 07:53:33 +0100
commit928fce8faa704aaf0a03021ff58c21eaea1ee967 (patch)
treed531801cc42a5be62e8c8c6b6de8863426897f7e /libraries
parentffffac9b041e2c6d745ba31c868c0e08f8f92912 (diff)
downloadslackbuilds-928fce8faa704aaf0a03021ff58c21eaea1ee967.tar.gz
academic/colamd: Renamed and moved from libraries.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/COLAMD/COLAMD.SlackBuild106
-rw-r--r--libraries/COLAMD/COLAMD.info10
-rw-r--r--libraries/COLAMD/README6
-rw-r--r--libraries/COLAMD/autotoolize.diff139
-rw-r--r--libraries/COLAMD/slack-desc19
5 files changed, 0 insertions, 280 deletions
diff --git a/libraries/COLAMD/COLAMD.SlackBuild b/libraries/COLAMD/COLAMD.SlackBuild
deleted file mode 100644
index baea95ceeb..0000000000
--- a/libraries/COLAMD/COLAMD.SlackBuild
+++ /dev/null
@@ -1,106 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for COLAMD
-
-# Copyright 2013 Kyle Guinn <elyk03@gmail.com>, USA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=COLAMD
-VERSION=${VERSION:-2.8.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$(uname -m)" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$(uname -m) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-DOCS="README.txt Doc/ChangeLog Doc/lesser.txt"
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-# Recommended by SuiteSparse
-SLKCFLAGS="$SLKCFLAGS -fexceptions -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE"
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-patch -p1 < $CWD/autotoolize.diff
-autoreconf -vif
-
-CFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --infodir=/usr/info \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --enable-shared \
- --disable-static \
- --disable-dependency-tracking \
- --build=$ARCH-slackware-linux
-
-make
-make check
-make install-strip DESTDIR=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/COLAMD/COLAMD.info b/libraries/COLAMD/COLAMD.info
deleted file mode 100644
index f524a8b8a1..0000000000
--- a/libraries/COLAMD/COLAMD.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="COLAMD"
-VERSION="2.8.0"
-HOMEPAGE="https://www.cise.ufl.edu/research/sparse/colamd/"
-DOWNLOAD="https://www.cise.ufl.edu/research/sparse/colamd/COLAMD-2.8.0.tar.gz"
-MD5SUM="482dc4f958c2dafdd430d4c3148d15c5"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="SuiteSparse_config"
-MAINTAINER="Kyle Guinn"
-EMAIL="elyk03@gmail.com"
diff --git a/libraries/COLAMD/README b/libraries/COLAMD/README
deleted file mode 100644
index caa522b0e7..0000000000
--- a/libraries/COLAMD/README
+++ /dev/null
@@ -1,6 +0,0 @@
-The COLAMD column approximate minimum degree ordering algorithm computes
-a permutation vector P such that the LU factorization of A (:,P)
-tends to be sparser than that of A. The Cholesky factorization of
-(A (:,P))'*(A (:,P)) will also tend to be sparser than that of A'*A.
-
-This package is part of SuiteSparse.
diff --git a/libraries/COLAMD/autotoolize.diff b/libraries/COLAMD/autotoolize.diff
deleted file mode 100644
index 632e5a2c10..0000000000
--- a/libraries/COLAMD/autotoolize.diff
+++ /dev/null
@@ -1,139 +0,0 @@
-diff --git a/Demo/Makefile.am b/Demo/Makefile.am
-new file mode 100644
---- /dev/null
-+++ b/Demo/Makefile.am
-@@ -0,0 +1,30 @@
-+AM_CPPFLAGS = -I$(top_srcdir)/Include $(SUITESPARSECONFIG_CFLAGS)
-+LDADD = $(top_builddir)/Source/libcolamd.la
-+
-+EXTRA_DIST = \
-+ colamd_example.out \
-+ colamd_l_example.out
-+
-+# Disable the .out implicit pattern rule. Prevents GNU make from
-+# adding bogus dependencies for the .out files listed above.
-+%.out: %
-+
-+check_PROGRAMS = \
-+ colamd_example \
-+ colamd_l_example
-+
-+colamd_example_SOURCES = colamd_example.c
-+colamd_l_example_SOURCES = colamd_l_example.c
-+
-+check-local: $(check_PROGRAMS) $(check_PROGRAMS:=.out)
-+ @for i in $(check_PROGRAMS); do \
-+ echo "Testing $$i"; \
-+ ./$$i$(EXEEXT) > my_$$i.out; \
-+ if diff -u $(srcdir)/$$i.out my_$$i.out; then \
-+ echo "Test $$i PASSED."; \
-+ else \
-+ echo "Test $$i FAILED."; \
-+ fi; \
-+ done
-+
-+CLEANFILES = my_*.out
-diff --git a/Include/Makefile.am b/Include/Makefile.am
-new file mode 100644
---- /dev/null
-+++ b/Include/Makefile.am
-@@ -0,0 +1 @@
-+pkginclude_HEADERS = colamd.h
-diff --git a/Makefile.am b/Makefile.am
-new file mode 100644
---- /dev/null
-+++ b/Makefile.am
-@@ -0,0 +1,5 @@
-+SUBDIRS = Include Source Demo
-+EXTRA_DIST = README.txt Doc/ChangeLog Doc/lesser.txt
-+
-+pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfig_DATA = colamd.pc
-diff --git a/Source/Makefile.am b/Source/Makefile.am
-new file mode 100644
---- /dev/null
-+++ b/Source/Makefile.am
-@@ -0,0 +1,18 @@
-+AM_CPPFLAGS = -I$(top_srcdir)/Include $(SUITESPARSECONFIG_CFLAGS)
-+
-+COLAMDSRC = \
-+ colamd.c
-+
-+lib_LTLIBRARIES = libcolamd.la
-+noinst_LTLIBRARIES = libcolamdi.la libcolamdl.la
-+
-+libcolamdi_la_SOURCES = $(COLAMDSRC)
-+libcolamdi_la_LIBADD = -lm
-+
-+libcolamdl_la_SOURCES = $(COLAMDSRC)
-+libcolamdl_la_LIBADD = -lm
-+libcolamdl_la_CPPFLAGS = $(AM_CPPFLAGS) -DDLONG
-+
-+libcolamd_la_SOURCES = colamd_global.c
-+libcolamd_la_LIBADD = libcolamdi.la libcolamdl.la
-+libcolamd_la_LDFLAGS = -no-undefined -version-number 2:8:0
-diff --git a/colamd.pc.in b/colamd.pc.in
-new file mode 100644
---- /dev/null
-+++ b/colamd.pc.in
-@@ -0,0 +1,13 @@
-+prefix=@prefix@
-+exec_prefix=@exec_prefix@
-+libdir=@libdir@
-+includedir=@includedir@
-+
-+Name: @PACKAGE_NAME@
-+Description: Column approximate minimum degree ordering
-+Version: @PACKAGE_VERSION@
-+URL: @PACKAGE_URL@
-+Requires.private: suitesparseconfig
-+Libs: -L${libdir} -lcolamd
-+Libs.private: -lm
-+Cflags: -I${includedir}/colamd
-diff --git a/configure.ac b/configure.ac
-new file mode 100644
---- /dev/null
-+++ b/configure.ac
-@@ -0,0 +1,42 @@
-+# -*- Autoconf -*-
-+# Process this file with autoconf to produce a configure script.
-+
-+AC_PREREQ([2.69])
-+AC_INIT([COLAMD],[2.8.0],[DrTimothyAldenDavis@gmail.com],[colamd],[http://www.suitesparse.com/])
-+AC_CONFIG_SRCDIR([Source/colamd_global.c])
-+AC_CONFIG_HEADERS([config.h])
-+AM_INIT_AUTOMAKE([foreign])
-+LT_INIT
-+
-+# Checks for programs.
-+AC_PROG_INSTALL
-+AC_PROG_CC
-+
-+LIBS_SAVED=$LIBS
-+
-+# Checks for libraries.
-+AC_CHECK_LIB([m], [sqrt])
-+
-+PKG_PROG_PKG_CONFIG
-+PKG_CHECK_MODULES([SUITESPARSECONFIG],[suitesparseconfig],
-+ [],
-+ [AC_MSG_ERROR([cannot find suitesparseconfig])])
-+
-+# Checks for header files.
-+AC_CHECK_HEADERS([limits.h stdlib.h])
-+
-+# Checks for typedefs, structures, and compiler characteristics.
-+AC_TYPE_SIZE_T
-+
-+# Checks for library functions.
-+AC_CHECK_FUNCS([sqrt])
-+
-+LIBS=$LIBS_SAVED
-+
-+AC_CONFIG_FILES([
-+ colamd.pc
-+ Makefile
-+ Demo/Makefile
-+ Include/Makefile
-+ Source/Makefile])
-+AC_OUTPUT
diff --git a/libraries/COLAMD/slack-desc b/libraries/COLAMD/slack-desc
deleted file mode 100644
index 7ed1be1ae1..0000000000
--- a/libraries/COLAMD/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-COLAMD: COLAMD (sparse matrix ordering routines)
-COLAMD:
-COLAMD: The COLAMD column approximate minimum degree ordering algorithm
-COLAMD: computes a permutation vector P such that the LU factorization of
-COLAMD: A (:,P) tends to be sparser than that of A. The Cholesky
-COLAMD: factorization of (A (:,P))'*(A (:,P)) will also tend to be sparser
-COLAMD: than that of A'*A.
-COLAMD:
-COLAMD:
-COLAMD:
-COLAMD: