summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Mikko Värri2010-08-14 22:47:03 +0200
committer Erik Hanson2010-08-15 02:04:53 +0200
commitd587a7c1a8af15616463e2a05daaeaf4b908c3a1 (patch)
tree3bd184f1358370fb3842d25cfb7b9da60461e03a /libraries
parent3d8692d01b7a3be20fa9fe4afbc29574ec5d39b3 (diff)
downloadslackbuilds-d587a7c1a8af15616463e2a05daaeaf4b908c3a1.tar.gz
libraries/ZConfig: Added (Structured Configuration Library)
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/ZConfig/README7
-rw-r--r--libraries/ZConfig/ZConfig.SlackBuild51
-rw-r--r--libraries/ZConfig/ZConfig.info10
-rw-r--r--libraries/ZConfig/slack-desc19
4 files changed, 87 insertions, 0 deletions
diff --git a/libraries/ZConfig/README b/libraries/ZConfig/README
new file mode 100644
index 0000000000..15bf834395
--- /dev/null
+++ b/libraries/ZConfig/README
@@ -0,0 +1,7 @@
+ZConfig (Structured Configuration Library)
+
+ZConfig supports a hierarchical schema-driven configuration model
+that allows a schema to specify data conversion routines written in
+Python.
+
+To build, this requires pysetuptools.
diff --git a/libraries/ZConfig/ZConfig.SlackBuild b/libraries/ZConfig/ZConfig.SlackBuild
new file mode 100644
index 0000000000..b60f44a927
--- /dev/null
+++ b/libraries/ZConfig/ZConfig.SlackBuild
@@ -0,0 +1,51 @@
+#!/bin/sh
+
+# Slackware build script for ZConfig
+
+# Written by Mikko Värri (vmj@linuxbox.fi)
+# Public domain.
+
+PRGNAM=ZConfig
+VERSION=${VERSION:-2.8.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE.txt COPYRIGHT.txt NEWS.txt README.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/ZConfig/ZConfig.info b/libraries/ZConfig/ZConfig.info
new file mode 100644
index 0000000000..bafa8387be
--- /dev/null
+++ b/libraries/ZConfig/ZConfig.info
@@ -0,0 +1,10 @@
+PRGNAM="ZConfig"
+VERSION="2.8.0"
+HOMEPAGE="http://pypi.python.org/pypi/ZConfig"
+DOWNLOAD="http://pypi.python.org/packages/source/Z/ZConfig/ZConfig-2.8.0.tar.gz"
+MD5SUM="4d1358d3e2e643430716103d5e495509"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Mikko Värri"
+EMAIL="vmj@linuxbox.fi"
+APPROVED="Erik Hanson"
diff --git a/libraries/ZConfig/slack-desc b/libraries/ZConfig/slack-desc
new file mode 100644
index 0000000000..337878d225
--- /dev/null
+++ b/libraries/ZConfig/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+ZConfig: ZConfig (Structured Configuration Library)
+ZConfig:
+ZConfig: ZConfig supports a hierarchical schema-driven configuration model
+ZConfig: that allows a schema to specify data conversion routines written in
+ZConfig: Python.
+ZConfig:
+ZConfig:
+ZConfig:
+ZConfig:
+ZConfig:
+ZConfig: