summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-02-03 10:01:58 +0100
committer Erik Hanson2014-02-08 18:10:07 +0100
commit9e5328da0de5d4418a5a7a00a15a50067f81b140 (patch)
tree509aa5367675dbc20a7f079192b54c6429a7a449 /libraries
parent400784487009960f5a747f48fc43267637ed2899 (diff)
downloadslackbuilds-9e5328da0de5d4418a5a7a00a15a50067f81b140.tar.gz
libraries/rarfile: Added (RAR archive reader for Python).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/rarfile/README13
-rw-r--r--libraries/rarfile/rarfile.SlackBuild89
-rw-r--r--libraries/rarfile/rarfile.info10
-rw-r--r--libraries/rarfile/slack-desc19
4 files changed, 131 insertions, 0 deletions
diff --git a/libraries/rarfile/README b/libraries/rarfile/README
new file mode 100644
index 0000000000..958db48240
--- /dev/null
+++ b/libraries/rarfile/README
@@ -0,0 +1,13 @@
+RAR archive reader for Python.
+
+This is Python module for RAR archive reading. The interface
+is made as zipfile like as possible. Licensed under ISC
+license.
+- Supports both RAR 2.x and 3.x archives.
+- Supports multi volume archives.
+- Supports Unicode filenames.
+- Supports password-protected archives.
+- Supports archive and file comments.
+- Archive parsing and non-compressed files are handled in pure Python code.
+- For compressed files runs ``unrar`` utility.
+- Works with both Python 2.x and 3.x.
diff --git a/libraries/rarfile/rarfile.SlackBuild b/libraries/rarfile/rarfile.SlackBuild
new file mode 100644
index 0000000000..4e180b435c
--- /dev/null
+++ b/libraries/rarfile/rarfile.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# Slackware build script for rarfile
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=rarfile
+VERSION=${VERSION:-2.6}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/rarfile/rarfile.info b/libraries/rarfile/rarfile.info
new file mode 100644
index 0000000000..cb28aee025
--- /dev/null
+++ b/libraries/rarfile/rarfile.info
@@ -0,0 +1,10 @@
+PRGNAM="rarfile"
+VERSION="2.6"
+HOMEPAGE="https://pypi.python.org/pypi/rarfile/2.6"
+DOWNLOAD="https://pypi.python.org/packages/source/r/rarfile/rarfile-2.6.tar.gz"
+MD5SUM="50ce3f3fdb9196a00059a5ea7b3739fd"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/libraries/rarfile/slack-desc b/libraries/rarfile/slack-desc
new file mode 100644
index 0000000000..cf97d0ea3a
--- /dev/null
+++ b/libraries/rarfile/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+rarfile: rarfile (RAR archive reader for Python)
+rarfile:
+rarfile: This is Python module for RAR archive reading. The interface is made
+rarfile: as zipfile like as possible. Licensed under ISC license.
+rarfile:
+rarfile: Homepage: https://github.com/markokr/rarfile
+rarfile:
+rarfile:
+rarfile:
+rarfile:
+rarfile: