summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Kyle Guinn2014-01-25 03:30:43 +0100
committer Robby Workman2014-01-31 07:53:28 +0100
commit6f66dde845afc17a6678f9f73ef61f6a5744202e (patch)
treeadfb1fcc67984795067186cd39bcc61c2dafa6a9 /libraries
parent2609c5958604038f62b8cedbb2133ee23c888f2c (diff)
downloadslackbuilds-6f66dde845afc17a6678f9f73ef61f6a5744202e.tar.gz
academic/camd: Renamed and moved from libraries.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/CAMD/CAMD.SlackBuild106
-rw-r--r--libraries/CAMD/CAMD.info10
-rw-r--r--libraries/CAMD/README4
-rw-r--r--libraries/CAMD/autotoolize.diff191
-rw-r--r--libraries/CAMD/slack-desc19
5 files changed, 0 insertions, 330 deletions
diff --git a/libraries/CAMD/CAMD.SlackBuild b/libraries/CAMD/CAMD.SlackBuild
deleted file mode 100644
index 169dcfbd33..0000000000
--- a/libraries/CAMD/CAMD.SlackBuild
+++ /dev/null
@@ -1,106 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for CAMD
-
-# Copyright 2013 Kyle Guinn <elyk03@gmail.com>, USA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=CAMD
-VERSION=${VERSION:-2.3.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$(uname -m)" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$(uname -m) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-DOCS="README.txt Doc/ChangeLog Doc/License Doc/lesser.txt"
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-# Recommended by SuiteSparse
-SLKCFLAGS="$SLKCFLAGS -fexceptions -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE"
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-patch -p1 < $CWD/autotoolize.diff
-autoreconf -vif
-
-CFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --infodir=/usr/info \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --enable-shared \
- --disable-static \
- --disable-dependency-tracking \
- --build=$ARCH-slackware-linux
-
-make
-make check
-make install-strip DESTDIR=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/CAMD/CAMD.info b/libraries/CAMD/CAMD.info
deleted file mode 100644
index bde446856c..0000000000
--- a/libraries/CAMD/CAMD.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="CAMD"
-VERSION="2.3.1"
-HOMEPAGE="https://www.cise.ufl.edu/research/sparse/camd/"
-DOWNLOAD="https://www.cise.ufl.edu/research/sparse/camd/CAMD-2.3.1.tar.gz"
-MD5SUM="2df3aa57af6bf241fa7f9c4ebb696ac8"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="SuiteSparse_config"
-MAINTAINER="Kyle Guinn"
-EMAIL="elyk03@gmail.com"
diff --git a/libraries/CAMD/README b/libraries/CAMD/README
deleted file mode 100644
index 40b8fefbae..0000000000
--- a/libraries/CAMD/README
+++ /dev/null
@@ -1,4 +0,0 @@
-CAMD is a set of routines for ordering a sparse matrix prior to Cholesky
-factorization (or for LU factorization with diagonal pivoting).
-
-This package is part of SuiteSparse.
diff --git a/libraries/CAMD/autotoolize.diff b/libraries/CAMD/autotoolize.diff
deleted file mode 100644
index b427dc4c54..0000000000
--- a/libraries/CAMD/autotoolize.diff
+++ /dev/null
@@ -1,191 +0,0 @@
-diff --git a/Demo/Makefile.am b/Demo/Makefile.am
-new file mode 100644
---- /dev/null
-+++ b/Demo/Makefile.am
-@@ -0,0 +1,36 @@
-+AM_CPPFLAGS = -I$(top_srcdir)/Include $(SUITESPARSECONFIG_CFLAGS)
-+LDADD = $(top_builddir)/Source/libcamd.la
-+
-+EXTRA_DIST = \
-+ camd_demo.out \
-+ camd_demo2.out \
-+ camd_l_demo.out \
-+ camd_simple.out
-+
-+# Disable the .out implicit pattern rule. Prevents GNU make from
-+# adding bogus dependencies for the .out files listed above.
-+%.out: %
-+
-+check_PROGRAMS = \
-+ camd_demo \
-+ camd_demo2 \
-+ camd_l_demo \
-+ camd_simple
-+
-+camd_demo_SOURCES = camd_demo.c
-+camd_demo2_SOURCES = camd_demo2.c
-+camd_l_demo_SOURCES = camd_l_demo.c
-+camd_simple_SOURCES = camd_simple.c
-+
-+check-local: $(check_PROGRAMS) $(check_PROGRAMS:=.out)
-+ @for i in $(check_PROGRAMS); do \
-+ echo "Testing $$i"; \
-+ ./$$i$(EXEEXT) > my_$$i.out; \
-+ if diff -u $(srcdir)/$$i.out my_$$i.out; then \
-+ echo "Test $$i PASSED."; \
-+ else \
-+ echo "Test $$i FAILED."; \
-+ fi; \
-+ done
-+
-+CLEANFILES = my_*.out
-diff --git a/Doc/Makefile.am b/Doc/Makefile.am
-new file mode 100644
---- /dev/null
-+++ b/Doc/Makefile.am
-@@ -0,0 +1,28 @@
-+EXTRA_DIST = ChangeLog License lesser.txt
-+
-+dist_noinst_SCRIPTS = cdiff docdiff
-+dist_noinst_DATA = CAMD_UserGuide.tex CAMD_UserGuide.bib camd.sed
-+dist_pdf_DATA = CAMD_UserGuide.pdf
-+
-+CAMD_UserGuide.pdf CAMD_UserGuide.aux: camd_h.tex
-+.INTERMEDIATE: CAMD_UserGuide.aux camd_h.tex
-+
-+%_h.tex: $(top_srcdir)/Include/%.h
-+ echo '\begin{verbatim}' > $@
-+ expand -8 $< >> $@
-+ echo '\end{verbatim}' >> $@
-+
-+TEX = TEXINPUTS="$(srcdir):" pdflatex -interaction nonstopmode -file-line-error
-+BIB = BIBINPUTS="$(srcdir):" bibtex
-+%.pdf: %.tex %.bbl
-+ $(TEX) $*
-+ while grep -q "Rerun to get cross-references right" $*.log; do \
-+ $(TEX) $*; \
-+ done
-+%.bbl: %.aux %.bib
-+ $(BIB) $*
-+%.aux: %.tex
-+ $(TEX) $*
-+
-+CLEANFILES = *.aux *.bbl *.blg *.log *.toc *_h.tex
-+MAINTAINERCLEANFILES = $(dist_pdf_DATA)
-diff --git a/Include/Makefile.am b/Include/Makefile.am
-new file mode 100644
---- /dev/null
-+++ b/Include/Makefile.am
-@@ -0,0 +1,2 @@
-+pkginclude_HEADERS = camd.h
-+noinst_HEADERS = camd_internal.h
-diff --git a/Makefile.am b/Makefile.am
-new file mode 100644
---- /dev/null
-+++ b/Makefile.am
-@@ -0,0 +1,5 @@
-+SUBDIRS = Include Source Demo Doc
-+EXTRA_DIST = README.txt
-+
-+pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfig_DATA = camd.pc
-diff --git a/Source/Makefile.am b/Source/Makefile.am
-new file mode 100644
---- /dev/null
-+++ b/Source/Makefile.am
-@@ -0,0 +1,29 @@
-+AM_CPPFLAGS = -I$(top_srcdir)/Include $(SUITESPARSECONFIG_CFLAGS)
-+
-+CAMDSRC = \
-+ camd_1.c \
-+ camd_2.c \
-+ camd_aat.c \
-+ camd_control.c \
-+ camd_defaults.c \
-+ camd_dump.c \
-+ camd_info.c \
-+ camd_order.c \
-+ camd_postorder.c \
-+ camd_preprocess.c \
-+ camd_valid.c
-+
-+lib_LTLIBRARIES = libcamd.la
-+noinst_LTLIBRARIES = libcamdi.la libcamdl.la
-+
-+libcamdi_la_SOURCES = $(CAMDSRC)
-+libcamdi_la_LIBADD = -lm
-+libcamdi_la_CPPFLAGS = $(AM_CPPFLAGS) -DDINT
-+
-+libcamdl_la_SOURCES = $(CAMDSRC)
-+libcamdl_la_LIBADD = -lm
-+libcamdl_la_CPPFLAGS = $(AM_CPPFLAGS) -DDLONG
-+
-+libcamd_la_SOURCES = camd_global.c
-+libcamd_la_LIBADD = libcamdl.la libcamdi.la
-+libcamd_la_LDFLAGS = -no-undefined -version-number 2:3:1
-diff --git a/camd.pc.in b/camd.pc.in
-new file mode 100644
---- /dev/null
-+++ b/camd.pc.in
-@@ -0,0 +1,13 @@
-+prefix=@prefix@
-+exec_prefix=@exec_prefix@
-+libdir=@libdir@
-+includedir=@includedir@
-+
-+Name: @PACKAGE_NAME@
-+Description: Constrained approximate minimum degree ordering
-+Version: @PACKAGE_VERSION@
-+URL: @PACKAGE_URL@
-+Requires.private: suitesparseconfig
-+Libs: -L${libdir} -lcamd
-+Libs.private: -lm
-+Cflags: -I${includedir}/camd
-diff --git a/configure.ac b/configure.ac
-new file mode 100644
---- /dev/null
-+++ b/configure.ac
-@@ -0,0 +1,43 @@
-+# -*- Autoconf -*-
-+# Process this file with autoconf to produce a configure script.
-+
-+AC_PREREQ([2.69])
-+AC_INIT([CAMD],[2.3.1],[DrTimothyAldenDavis@gmail.com],[camd],[http://www.suitesparse.com/])
-+AC_CONFIG_SRCDIR([Source/camd_global.c])
-+AC_CONFIG_HEADERS([config.h])
-+AM_INIT_AUTOMAKE([foreign])
-+LT_INIT
-+
-+# Checks for programs.
-+AC_PROG_INSTALL
-+AC_PROG_CC
-+
-+LIBS_SAVED=$LIBS
-+
-+# Checks for libraries.
-+AC_CHECK_LIB([m], [sqrt])
-+
-+PKG_PROG_PKG_CONFIG
-+PKG_CHECK_MODULES([SUITESPARSECONFIG],[suitesparseconfig],
-+ [],
-+ [AC_MSG_ERROR([cannot find suitesparseconfig])])
-+
-+# Checks for header files.
-+AC_CHECK_HEADERS([limits.h stddef.h stdlib.h])
-+
-+# Checks for typedefs, structures, and compiler characteristics.
-+AC_TYPE_SIZE_T
-+
-+# Checks for library functions.
-+AC_CHECK_FUNCS([sqrt])
-+
-+LIBS=$LIBS_SAVED
-+
-+AC_CONFIG_FILES([
-+ camd.pc
-+ Makefile
-+ Demo/Makefile
-+ Doc/Makefile
-+ Include/Makefile
-+ Source/Makefile])
-+AC_OUTPUT
diff --git a/libraries/CAMD/slack-desc b/libraries/CAMD/slack-desc
deleted file mode 100644
index ac7f9355cc..0000000000
--- a/libraries/CAMD/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-CAMD: CAMD (sparse matrix ordering routines)
-CAMD:
-CAMD: CAMD is a set of routines for ordering a sparse matrix prior to
-CAMD: Cholesky factorization (or for LU factorization with diagonal
-CAMD: pivoting).
-CAMD:
-CAMD:
-CAMD:
-CAMD:
-CAMD:
-CAMD: