summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author David Spencer2012-05-20 23:02:36 +0200
committer Erik Hanson2012-05-22 00:58:12 +0200
commit13aeb802fddd9a29c8fdd1352825ddab1fb96613 (patch)
tree01440f1ec0afe50391db2b37da44e5fbaec5e55c /libraries
parentde7a834adbcf09aaee3713741f1fdbafad7f9986 (diff)
downloadslackbuilds-13aeb802fddd9a29c8fdd1352825ddab1fb96613.tar.gz
libraries/gdal: Updated for version 1.9.0.
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/gdal/gdal-python-install.patch10
-rw-r--r--libraries/gdal/gdal.SlackBuild31
-rw-r--r--libraries/gdal/gdal.info8
3 files changed, 36 insertions, 13 deletions
diff --git a/libraries/gdal/gdal-python-install.patch b/libraries/gdal/gdal-python-install.patch
new file mode 100644
index 0000000000..8ec414d37a
--- /dev/null
+++ b/libraries/gdal/gdal-python-install.patch
@@ -0,0 +1,10 @@
+--- swig/python/GNUmakefile.orig 2010-04-24 01:22:07.000000000 +0200
++++ swig/python/GNUmakefile 2010-05-05 19:14:58.000000000 +0200
+@@ -72,5 +72,5 @@
+ ifeq ($(PY_HAVE_SETUPTOOLS),1)
+- $(PYTHON) setup.py install
++ $(PYTHON) setup.py install --root=$(DESTDIR)
+ else
+- $(PYTHON) setup.py install --prefix=$(DESTDIR)$(prefix)
++ $(PYTHON) setup.py install --root=$(DESTDIR) --prefix=$(prefix)
+ endif
diff --git a/libraries/gdal/gdal.SlackBuild b/libraries/gdal/gdal.SlackBuild
index e26fa573f0..f55942630c 100644
--- a/libraries/gdal/gdal.SlackBuild
+++ b/libraries/gdal/gdal.SlackBuild
@@ -1,5 +1,6 @@
#!/bin/sh
# Slackware build script for GDAL
+
# Copyright 2009 Marco Cecchetti <mrc.ild@gmail.com>
# All rights reserved.
#
@@ -23,7 +24,7 @@
# Maintained by David Spencer <baildon.research@googlemail.com>
PRGNAM=gdal
-VERSION=${VERSION:-1.8.1}
+VERSION=${VERSION:-1.9.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -70,7 +71,7 @@ find . \
-exec chmod 644 {} \;
WITHLIST=""
-# Grass support causes segfaults on x86_64. If you really want it,
+# Grass support is buggy. If you really want it,
# here is an undocumented option to enable it :-/
if pkg-config --exists grass; then
if [ ${GRASS:-no} = "yes" ]; then
@@ -78,18 +79,25 @@ if pkg-config --exists grass; then
fi
fi
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
+# Thanks to the people at Arch for this:
+patch -p0 <$CWD/gdal-python-install.patch
+
+CFLAGS="$SLKCFLAGS -Wno-error" \
+CXXFLAGS="$SLKCFLAGS -Wno-error" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
--enable-static=no \
--with-threads \
--with-geos=yes \
--with-ogr=yes \
--with-libz=/usr/lib${LIBDIRSUFFIX} \
+ --with-liblzma \
+ --with-jpeg=internal \
--with-libtiff=internal \
--with-curl=/usr/bin/curl-config \
--without-grib \
@@ -102,18 +110,23 @@ CXXFLAGS="$SLKCFLAGS" \
make
make install DESTDIR=$PKG
-make -f GNUmakefile -B man
+
+# Kill erroneously installed .dox files
+rm $PKG/usr/bin/*.dox
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-cp -a man/ $PKG/usr/
+make -f GNUmakefile -B man
+make install-man DESTDIR=$PKG
gzip -9 $PKG/usr/man/man?/* || exit 1
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+make -f GNUmakefile -B docs
+# --docdir is ignored :-(
+make install-docs DESTDIR=$PKG INST_DOCS=/usr/doc/$PRGNAM-$VERSION
cp -a \
- COMMITERS HOWTO-RELEASE LICENSE.TXT NEWS PROVENANCE.TXT VERSION doc/* \
- $PKG/usr/doc/$PRGNAM-$VERSION
+ COMMITERS HOWTO-RELEASE LICENSE.TXT NEWS PROVENANCE.TXT VERSION \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/libraries/gdal/gdal.info b/libraries/gdal/gdal.info
index 999257f3c3..b10fb58c19 100644
--- a/libraries/gdal/gdal.info
+++ b/libraries/gdal/gdal.info
@@ -1,10 +1,10 @@
PRGNAM="gdal"
-VERSION="1.8.1"
+VERSION="1.9.0"
HOMEPAGE="http://www.gdal.org/"
-DOWNLOAD="http://download.osgeo.org/gdal/gdal-1.8.1.tar.gz"
-MD5SUM="b32269893afc9dc9eced45e74e4c6bb4"
+DOWNLOAD="http://download.osgeo.org/gdal/gdal-1.9.0.tar.gz"
+MD5SUM="1853f3d8eb5232ae030abe007840cade"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="David Spencer"
EMAIL="baildon.research@googlemail.com"
-APPROVED="Niels Horn"
+APPROVED="dsomero"