summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Erwin van Zanten2012-12-26 14:16:24 +0100
committer Matteo Bernardini2012-12-26 21:36:49 +0100
commit48bf84caed6b41b794e442553eb4826a99ece80e (patch)
tree702b4ceb787cab9992d98b51fbade7b8b9960a29 /libraries
parent1d29caccdba7a1bdda02e0da02100637fd271c33 (diff)
downloadslackbuilds-48bf84caed6b41b794e442553eb4826a99ece80e.tar.gz
libraries/libgnomemm: Added (C++ wrappers for libgnome).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/libgnomemm/README6
-rw-r--r--libraries/libgnomemm/libgnomemm.SlackBuild100
-rw-r--r--libraries/libgnomemm/libgnomemm.info10
-rw-r--r--libraries/libgnomemm/slack-desc19
4 files changed, 135 insertions, 0 deletions
diff --git a/libraries/libgnomemm/README b/libraries/libgnomemm/README
new file mode 100644
index 0000000000..2e23915d24
--- /dev/null
+++ b/libraries/libgnomemm/README
@@ -0,0 +1,6 @@
+C++ wrappers for libgnome.
+
+Gnomemm is a powerful C++ binding for the GNOME libraries.
+Gnomemm includes bindings for all the popular GNOME interfaces
+like canvas and MDI as well as useful application templates
+for constructing good looking apps.
diff --git a/libraries/libgnomemm/libgnomemm.SlackBuild b/libraries/libgnomemm/libgnomemm.SlackBuild
new file mode 100644
index 0000000000..0fe0b4117a
--- /dev/null
+++ b/libraries/libgnomemm/libgnomemm.SlackBuild
@@ -0,0 +1,100 @@
+#!/bin/sh
+#
+# Slackware build script for libgnomemm
+#
+# Copyright 2012 Erwin van Zanten, Dordrecht, The Netherlands
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=libgnomemm
+VERSION=${VERSION:-2.30.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -eu
+
+rm -rf $PKG
+mkdir -p $TMP $PKG
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Move a generated header between the others
+sed -i "s|(libdir)/libgnomemm-2\.6/include|(includedir)/libgnomemm-2.6|" \
+ libgnome/Makefile.in
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib$LIBDIRSUFFIX \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --disable-static \
+ --build=$ARCH-slackware-linux
+
+make
+make install-strip DESTDIR=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING ChangeLog INSTALL NEWS README TODO \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/libgnomemm/libgnomemm.info b/libraries/libgnomemm/libgnomemm.info
new file mode 100644
index 0000000000..0e154876e1
--- /dev/null
+++ b/libraries/libgnomemm/libgnomemm.info
@@ -0,0 +1,10 @@
+PRGNAM="libgnomemm"
+VERSION="2.30.0"
+HOMEPAGE="http://www.gtkmm.org"
+DOWNLOAD="http://ftp.gnome.org/pub/gnome/sources/libgnomemm/2.30/libgnomemm-2.30.0.tar.bz2"
+MD5SUM="860f5e835cd4674393ffdd692b0c9147"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="libgnome"
+MAINTAINER="Erwin van Zanten"
+EMAIL="e.van.zanten.evz@gmail.com"
diff --git a/libraries/libgnomemm/slack-desc b/libraries/libgnomemm/slack-desc
new file mode 100644
index 0000000000..e0b0ea0eff
--- /dev/null
+++ b/libraries/libgnomemm/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+libgnomemm: libgnomemm (C++ wrappers for libgnome)
+libgnomemm:
+libgnomemm: Gnomemm is a powerful C++ binding for the GNOME libraries.
+libgnomemm: Gnomemm includes bindings for all the popular GNOME interfaces
+libgnomemm: like canvas and MDI as well as useful application templates for
+libgnomemm: constructing good looking apps.
+libgnomemm:
+libgnomemm: homepage: http://www.gtkmm.org
+libgnomemm:
+libgnomemm:
+libgnomemm: