summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author B. Watson2012-04-08 16:58:11 +0200
committer dsomero2012-04-08 16:58:11 +0200
commitae78605749e0b0d8d0f81217a3fe3096be988f35 (patch)
tree0233e615c635e495b46ed006279042df030ea0a2 /libraries
parent171d8c755a4f8d14dab249b90b30e16a2134f625 (diff)
downloadslackbuilds-ae78605749e0b0d8d0f81217a3fe3096be988f35.tar.gz
libraries/girara: Added (GTK+ GUI for text-oriented applications)
Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/girara/README6
-rw-r--r--libraries/girara/girara.SlackBuild77
-rw-r--r--libraries/girara/girara.info10
-rw-r--r--libraries/girara/slack-desc19
4 files changed, 112 insertions, 0 deletions
diff --git a/libraries/girara/README b/libraries/girara/README
new file mode 100644
index 0000000000..e1fd988f95
--- /dev/null
+++ b/libraries/girara/README
@@ -0,0 +1,6 @@
+girara (GTK+ based GUI for text-oriented applications)
+
+girara is a library that implements a user interface that focuses on
+simplicity and minimalism. girara was designed to replace and enhance
+the user interface that is used by zathura and jumanji and other features
+that those applications share.
diff --git a/libraries/girara/girara.SlackBuild b/libraries/girara/girara.SlackBuild
new file mode 100644
index 0000000000..09674bdd5c
--- /dev/null
+++ b/libraries/girara/girara.SlackBuild
@@ -0,0 +1,77 @@
+#!/bin/sh
+
+# Slackware build script for girara
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+PRGNAM=girara
+VERSION=${VERSION:-0.1.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+sed -i "s,-fPIC,$SLKCFLAGS," config.mk
+make LIBDIR=/usr/lib$LIBDIRSUFFIX
+make install LIBDIR=/usr/lib$LIBDIRSUFFIX DESTDIR=$PKG
+
+# don't need static lib:
+rm -f $PKG/usr/lib$LIBDIRSUFFIX/*.a
+
+# .so library not installed +x, fix:
+chmod 755 $PKG/usr/lib$LIBDIRSUFFIX/*.so.*.*
+
+# strip it, strip it good
+strip $PKG/usr/lib$LIBDIRSUFFIX/*.so.*.*
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ AUTHORS LICENSE README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/girara/girara.info b/libraries/girara/girara.info
new file mode 100644
index 0000000000..bc88bf3231
--- /dev/null
+++ b/libraries/girara/girara.info
@@ -0,0 +1,10 @@
+PRGNAM="girara"
+VERSION="0.1.1"
+HOMEPAGE="https://pwmt.org/projects/girara/"
+DOWNLOAD="https://pwmt.org/projects/girara/download/girara-0.1.1.tar.gz"
+MD5SUM="baa3ddb35703474c4a32dd2535785670"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"
+APPROVED="dsomero"
diff --git a/libraries/girara/slack-desc b/libraries/girara/slack-desc
new file mode 100644
index 0000000000..3fc8df7cb3
--- /dev/null
+++ b/libraries/girara/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+girara: girara (GTK+ based GUI for text-oriented applications)
+girara:
+girara: girara is a library that implements a user interface that focuses
+girara: on simplicity and minimalism. girara was designed to replace and
+girara: enhance the user interface that is used by zathura and jumanji and
+girara: other features that those applications share.
+girara:
+girara:
+girara:
+girara:
+girara: