summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Marco Bonetti2011-12-10 23:36:56 +0100
committer Niels Horn2011-12-11 00:58:16 +0100
commitb53f581a61d7b6a6b60f97f7b93a189cc30547cf (patch)
treed578a917979b258ede73a64b82e763f47de18910 /libraries
parent3aa48f231b9a0ee0495ba05040a91a212785ae6b (diff)
downloadslackbuilds-b53f581a61d7b6a6b60f97f7b93a189cc30547cf.tar.gz
libraries/libixp: Added (standalone client/server 9P library)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/libixp/README3
-rw-r--r--libraries/libixp/libixp-0.5-libdir.diff18
-rw-r--r--libraries/libixp/libixp.SlackBuild110
-rw-r--r--libraries/libixp/libixp.info10
-rw-r--r--libraries/libixp/slack-desc19
5 files changed, 160 insertions, 0 deletions
diff --git a/libraries/libixp/README b/libraries/libixp/README
new file mode 100644
index 0000000000..0286f96ef7
--- /dev/null
+++ b/libraries/libixp/README
@@ -0,0 +1,3 @@
+libixp is a stand-alone client/server 9P library including ixpc
+client which behaves like wmiir in the past. It consists of less
+than 2000 lines of code (including ixpc).
diff --git a/libraries/libixp/libixp-0.5-libdir.diff b/libraries/libixp/libixp-0.5-libdir.diff
new file mode 100644
index 0000000000..951290cd64
--- /dev/null
+++ b/libraries/libixp/libixp-0.5-libdir.diff
@@ -0,0 +1,18 @@
+diff -Naur libixp-0.5.orig/mk/lib.mk libixp-0.5/mk/lib.mk
+--- libixp-0.5.orig/mk/lib.mk 2008-09-21 05:39:51.000000000 +0200
++++ libixp-0.5/mk/lib.mk 2011-11-15 09:59:26.333380697 +0100
+@@ -1,4 +1,4 @@
+-PTARG = $(ROOT)/lib/$(TARG)
++PTARG = $(ROOT)/@basedir@/$(TARG)
+ LIB = $(PTARG).a
+ OFILES = ${OBJ:=.o}
+
+@@ -22,7 +22,7 @@
+
+ $(LIB): $(OFILES)
+ echo AR $$($(CLEANNAME) $(BASE)/$@)
+- mkdir $(ROOT)/lib 2>/dev/null || true
++ mkdir $(ROOT)/@basedir@ 2>/dev/null || true
+ $(AR) $@ $(OFILES)
+
+ SOMKSH=case "$(MAKESO)" in 1|[Yy][Ee][Ss]|[Tt][Rr][Uu][Ee]) echo $(ROOT)/mk/so.mk;; *) echo /dev/null;; esac
diff --git a/libraries/libixp/libixp.SlackBuild b/libraries/libixp/libixp.SlackBuild
new file mode 100644
index 0000000000..03b9292186
--- /dev/null
+++ b/libraries/libixp/libixp.SlackBuild
@@ -0,0 +1,110 @@
+#!/bin/sh
+
+# Slackware build script for libixp
+
+# Copyright (c) 2011, Marco Bonetti <sid77@slackware.it>
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are met:
+# 1.- Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY
+# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY
+# DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+# LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=libixp
+VERSION=0.5
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Fix cflags value
+sed -i 's:^CFLAGS =:CFLAGS += :' config.mk
+
+CFLAGS="$SLKCFLAGS" make \
+ PREFIX=/usr \
+ LIBDIR=/usr/lib${LIBDIRSUFFIX} \
+ MAN=/usr/man \
+ ETC=/etc
+
+# Fix hardcoded /usr/lib
+sed "s%@baselibdir@%lib$LIBDIRSUFFIX%g" $CWD/libixp-0.5-libdir.diff | patch -p1
+
+make install \
+ PREFIX=$PKG/usr \
+ LIBDIR=$PKG/usr/lib${LIBDIRSUFFIX} \
+ MAN=$PKG/usr/man \
+ ETC=$PKG/etc
+
+# Erase "/etc", it's empty
+rmdir $PKG/etc
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a libixp/LICENSE* libixp/README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/libixp/libixp.info b/libraries/libixp/libixp.info
new file mode 100644
index 0000000000..fda20dceee
--- /dev/null
+++ b/libraries/libixp/libixp.info
@@ -0,0 +1,10 @@
+PRGNAM="libixp"
+VERSION="0.5"
+HOMEPAGE="http://libs.suckless.org/libixp"
+DOWNLOAD="http://dl.suckless.org/libs/libixp-0.5.tar.gz"
+MD5SUM="2a394310c209605ba54ecf5eab518bff"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Marco Bonetti"
+EMAIL="sid77@slackware.it"
+APPROVED="rworkman"
diff --git a/libraries/libixp/slack-desc b/libraries/libixp/slack-desc
new file mode 100644
index 0000000000..e147e5a903
--- /dev/null
+++ b/libraries/libixp/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+libixp: libixp (A standalone client/server 9P library)
+libixp:
+libixp: libixp is a stand-alone client/server 9P library including ixpc
+libixp: client which behaves like wmiir in the past. It consists of less
+libixp: than 2000 lines of code (including ixpc).
+libixp:
+libixp: Homepage: http://libs.suckless.org/libixp
+libixp:
+libixp:
+libixp:
+libixp: