summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Dominik Drobek2011-02-02 06:20:53 +0100
committer Robby Workman2011-02-02 06:20:53 +0100
commit401a4255ce9e19b7bbc1a195edaec74c6fe60a83 (patch)
tree37c5f1ae40bd5b1e7b1510b5105bda6b23968735 /libraries
parent0fb0d7be22ca03a1407c6b8f03e18f35f11c5ecb (diff)
downloadslackbuilds-401a4255ce9e19b7bbc1a195edaec74c6fe60a83.tar.gz
libraries/GeoIP-Python: Added (GeoIP Python API)
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/GeoIP-Python/GeoIP-Python.SlackBuild68
-rw-r--r--libraries/GeoIP-Python/GeoIP-Python.info10
-rw-r--r--libraries/GeoIP-Python/README4
-rw-r--r--libraries/GeoIP-Python/slack-desc19
4 files changed, 101 insertions, 0 deletions
diff --git a/libraries/GeoIP-Python/GeoIP-Python.SlackBuild b/libraries/GeoIP-Python/GeoIP-Python.SlackBuild
new file mode 100644
index 0000000000..6c8e9a0914
--- /dev/null
+++ b/libraries/GeoIP-Python/GeoIP-Python.SlackBuild
@@ -0,0 +1,68 @@
+#!/bin/sh
+
+# Slackware build script for GeoIP-Python
+# Written by Dominik Drobek <dominik.drobek (at) o2.pl>
+
+PRGNAM=GeoIP-Python
+VERSION=${VERSION:-1.2.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ ChangeLog LICENSE MANIFEST README \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/GeoIP-Python/GeoIP-Python.info b/libraries/GeoIP-Python/GeoIP-Python.info
new file mode 100644
index 0000000000..a17e4a05de
--- /dev/null
+++ b/libraries/GeoIP-Python/GeoIP-Python.info
@@ -0,0 +1,10 @@
+PRGNAM="GeoIP-Python"
+VERSION="1.2.4"
+HOMEPAGE="http://www.maxmind.com/app/python"
+DOWNLOAD="http://geolite.maxmind.com/download/geoip/api/python/GeoIP-Python-1.2.4.tar.gz"
+MD5SUM="50f820d854476efaf3b7af733ffe4236"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+MAINTAINER="Dominik Drobek"
+EMAIL="dominik.drobek@o2.pl"
+APPROVED="rworkman"
diff --git a/libraries/GeoIP-Python/README b/libraries/GeoIP-Python/README
new file mode 100644
index 0000000000..5e30bf603c
--- /dev/null
+++ b/libraries/GeoIP-Python/README
@@ -0,0 +1,4 @@
+This package provides an open source Python API for MaxMind's
+IP geolocation data and services.
+
+This requires GeoIP.
diff --git a/libraries/GeoIP-Python/slack-desc b/libraries/GeoIP-Python/slack-desc
new file mode 100644
index 0000000000..df8d429784
--- /dev/null
+++ b/libraries/GeoIP-Python/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+GeoIP-Python: GeoIP-Python (GeoIP Python API)
+GeoIP-Python:
+GeoIP-Python: This package provides an open source Python API for MaxMind's
+GeoIP-Python: IP geolocation data and services.
+GeoIP-Python:
+GeoIP-Python: Homepage: http://www.maxmind.com/app/python
+GeoIP-Python:
+GeoIP-Python:
+GeoIP-Python:
+GeoIP-Python:
+GeoIP-Python: